summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-18 09:54:18 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-18 09:56:03 +0200
commit59ebe3e0174f4ce763d47a26acf18cf07a73b64c (patch)
treec6c0b2c254efe529ae3c57cf930e84282c7063ad /dev-libs
parentdev-lang/elixir: remove unused patch (diff)
downloadgentoo-59ebe3e0174f4ce763d47a26acf18cf07a73b64c.tar.gz
gentoo-59ebe3e0174f4ce763d47a26acf18cf07a73b64c.tar.bz2
gentoo-59ebe3e0174f4ce763d47a26acf18cf07a73b64c.zip
dev-libs/libxmlb: Bump to version 0.1.13
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxmlb/Manifest1
-rw-r--r--dev-libs/libxmlb/libxmlb-0.1.13.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libxmlb/Manifest b/dev-libs/libxmlb/Manifest
index 1857b33ecd32..240fae725449 100644
--- a/dev-libs/libxmlb/Manifest
+++ b/dev-libs/libxmlb/Manifest
@@ -1,4 +1,5 @@
DIST libxmlb-0.1.10.tar.gz 86237 BLAKE2B 042898be9ff8bb6b253ce7194e774bf6a1d8f08316ba54647b3667b1969c035364c3ef25d179fab20cbf9ca83bbd7e4d6012ec1adf08849fe99e40ab9a294983 SHA512 81f5edf776241580c0e47f43f9b15ecbc695022007cf90070f95ca190f2a270f15a856a89246c772f52e93b8eed88d228c5f426cd4dc84e8e6fdf2556b8714b3
DIST libxmlb-0.1.11.tar.gz 88848 BLAKE2B b8ae448f8ead51c884304c190c2b5535f864eb410f45adc4c1f548d6aedcba944b6e0418fbc781e2561e18b392f3a77df8512f6d3ec5e0831513a2dac520409d SHA512 734082c4c15d8b02eb3e526b59fb6be8a7a61758a059792fca567c9a647df0597561fb6967903fb44d566ccd6e8e6d99286d0cae495b9d8ec12a3cd257c24a16
DIST libxmlb-0.1.12.tar.gz 91256 BLAKE2B b063bed9d7794b300ec40622c7fd0caac974b7f1be57b08ccb1864587b7bf47f892a39d1f4f0df226d3fe7ca03ffcec471a4f28afb8e64ae841d6898a337b60f SHA512 aebd9f41421bb0d78954038b3221bed879d296ec2d3061e7e7747980974e01081e51ea36d4e94545af5006b3dc4714d535aeea1943e42a7f1661ba1177979b31
+DIST libxmlb-0.1.13.tar.gz 91597 BLAKE2B f5b1cffba36f25260df44b85109df22aca9f76a47a71c82b99504ce6f072b5b01c32aa26ae36ee37ff717a25dcbf094def8c3b65c7e53883aad726d919181db1 SHA512 ae2c043db0c3a9719c1527933e087825068f970bde28bc7b507a6535b51133d463b1dce6c8b02148a555bb28868ab563f7bb01e6324661dac92fab556c9a39b0
DIST libxmlb-0.1.8.tar.gz 85945 BLAKE2B 4d17aaf4e5ed3001a4db24e7ca220cba3fc14ee446b127b65b545fab997c7c31835b57b0dd9d23da74200d774e3986558e7618789f42d1e95c0734fa5bb6e098 SHA512 4109f171da4622429d18afdb9ae183a64f89e0b92df285efae5736017970f877a92391876969c20894184c6d5df96390ccd46be1d1087882a5461476c39e433a
diff --git a/dev-libs/libxmlb/libxmlb-0.1.13.ebuild b/dev-libs/libxmlb/libxmlb-0.1.13.ebuild
new file mode 100644
index 000000000000..203b7a1d9e50
--- /dev/null
+++ b/dev-libs/libxmlb/libxmlb-0.1.13.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Library to help create and query binary XML blobs"
+HOMEPAGE="https://github.com/hughsie/libxmlb"
+SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc introspection stemmer test"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-apps/util-linux
+ stemmer? ( dev-libs/snowball-stemmer )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+"
+
+BDEPEND="
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use introspection && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgtkdoc="$(usex doc true false)"
+ -Dintrospection="$(usex introspection true false)"
+ -Dstemmer="$(usex stemmer true false)"
+ -Dtests="$(usex test true false)"
+ )
+ meson_src_configure
+}