summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-05-27 16:58:05 +0200
committerPacho Ramos <pacho@gentoo.org>2023-05-27 16:58:05 +0200
commit605b3695e9c637ad8ee89575a5cdab2bf8250797 (patch)
treea4cc606c78f89bb41444e02349af69e15f87cc4a /dev-libs
parentmedia-libs/libsdl: add 1.2.64 (diff)
downloadgentoo-605b3695e9c637ad8ee89575a5cdab2bf8250797.tar.gz
gentoo-605b3695e9c637ad8ee89575a5cdab2bf8250797.tar.bz2
gentoo-605b3695e9c637ad8ee89575a5cdab2bf8250797.zip
dev-libs/xapian: drop 1.4.19, 1.4.21, 1.4.21-r1
Closes: https://bugs.gentoo.org/878555 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian/Manifest2
-rw-r--r--dev-libs/xapian/xapian-1.4.19.ebuild75
-rw-r--r--dev-libs/xapian/xapian-1.4.21-r1.ebuild60
-rw-r--r--dev-libs/xapian/xapian-1.4.21.ebuild75
4 files changed, 0 insertions, 212 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index f2640b5f0189..e2eaea148e9b 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -1,3 +1 @@
-DIST xapian-core-1.4.19.tar.xz 2994860 BLAKE2B 9566df1646192370e346c1b0d1e1cda68034fe5d3ab94835709f969df643fd36da49a58a2d3b4177a42faf5af2e71df771277848169ae62f94fe0bb0378ba6aa SHA512 d596058d7f9bfa0b73c5b6354331a799936b45f27012894f6792872ade8656bb0387b504aea8c1c3edfbd48787190452e7a49d2b62d181cb050c46edd3e67346
-DIST xapian-core-1.4.21.tar.xz 3018384 BLAKE2B 61a25ee381c84e0a9f20650d94aa097225f2e947dafad7f6b5497db74f383f5b0fcf277a35ea27ff461b34cd2a9a0b6333f88264c5817cff09a2caf42fa3b398 SHA512 4071791daf47f5ae77f32f358c6020fcfa9aa81c15c8da25489b055eef30383695e449ab1cb73670f2f5db2b2a5f78056da0e8eea89d83aaad91dfe340a6b13a
DIST xapian-core-1.4.22.tar.xz 3019608 BLAKE2B f4aec86cd5f63f6f1825a4f8f427ea23be2092ffb4ca11a2fdf20bdf652e7b9f768b1155bcf7ee5e5c5313206c92e1725d1b4d562e3074539a2e8f9901c44f8e SHA512 60d66adbacbd59622d25e392060984bd1dc6c870f9031765f54cb335fb29f72f6d006d27af82a50c8da2cfbebd08dac4503a8afa8ad51bc4e6fa9cb367a59d29
diff --git a/dev-libs/xapian/xapian-1.4.19.ebuild b/dev-libs/xapian/xapian-1.4.19.ebuild
deleted file mode 100644
index 757d51d72f7e..000000000000
--- a/dev-libs/xapian/xapian-1.4.19.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit multilib-minimal
-
-MY_P="${PN}-core-${PV}"
-
-DESCRIPTION="Xapian Probabilistic Information Retrieval library"
-HOMEPAGE="https://xapian.org/"
-SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/30" # ABI version of libxapian.so
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos ~x64-solaris"
-IUSE="doc static-libs cpu_flags_x86_sse cpu_flags_x86_sse2 +inmemory +remote"
-
-DEPEND="sys-apps/util-linux[${MULTILIB_USEDEP}]
- sys-libs/zlib[${MULTILIB_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-multilib_src_configure() {
- local myconf=""
-
- if use cpu_flags_x86_sse2; then
- myconf="${myconf} --enable-sse=sse2"
- else
- if use cpu_flags_x86_sse; then
- myconf="${myconf} --enable-sse=sse"
- else
- myconf="${myconf} --disable-sse"
- fi
- fi
-
- myconf="${myconf} $(use_enable static-libs static)"
-
- use inmemory || myconf="${myconf} --disable-backend-inmemory"
- use remote || myconf="${myconf} --disable-backend-remote"
-
- myconf="${myconf} --enable-backend-glass --enable-backend-chert --program-suffix="
-
- ECONF_SOURCE=${S} econf ${myconf}
-}
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/xapian/postingsource.h
- /usr/include/xapian/attributes.h
- /usr/include/xapian/valuesetmatchdecider.h
- /usr/include/xapian/version.h
- /usr/include/xapian/version.h
- /usr/include/xapian/types.h
- /usr/include/xapian/positioniterator.h
- /usr/include/xapian/registry.h
-)
-
-multilib_src_test() {
- emake check VALGRIND=
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
-}
-
-multilib_src_install_all() {
- if use doc; then
- rm -rf "${ED}/usr/share/doc/xapian-core-${PV}" || die
- fi
-
- dodoc AUTHORS HACKING PLATFORMS README NEWS
-
- find "${ED}" -name "*.la" -type f -delete || die
-}
diff --git a/dev-libs/xapian/xapian-1.4.21-r1.ebuild b/dev-libs/xapian/xapian-1.4.21-r1.ebuild
deleted file mode 100644
index 92452883c607..000000000000
--- a/dev-libs/xapian/xapian-1.4.21-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-MY_P="${PN}-core-${PV}"
-
-DESCRIPTION="Xapian Probabilistic Information Retrieval library"
-HOMEPAGE="https://xapian.org/"
-SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/30" # ABI version of libxapian.so
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos ~x64-solaris"
-IUSE="doc static-libs cpu_flags_x86_sse cpu_flags_x86_sse2 +inmemory +remote"
-
-DEPEND="sys-apps/util-linux
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local myconf=""
-
- if use cpu_flags_x86_sse2; then
- myconf="${myconf} --enable-sse=sse2"
- else
- if use cpu_flags_x86_sse; then
- myconf="${myconf} --enable-sse=sse"
- else
- myconf="${myconf} --disable-sse"
- fi
- fi
-
- myconf="${myconf} $(use_enable static-libs static)"
-
- use inmemory || myconf="${myconf} --disable-backend-inmemory"
- use remote || myconf="${myconf} --disable-backend-remote"
-
- myconf="${myconf} --enable-backend-glass --enable-backend-chert --program-suffix="
-
- econf ${myconf}
-}
-
-src_test() {
- emake check VALGRIND=
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if use doc; then
- rm -rf "${ED}/usr/share/doc/xapian-core-${PV}" || die
- fi
-
- dodoc AUTHORS HACKING PLATFORMS README NEWS
-
- find "${ED}" -name "*.la" -type f -delete || die
-}
diff --git a/dev-libs/xapian/xapian-1.4.21.ebuild b/dev-libs/xapian/xapian-1.4.21.ebuild
deleted file mode 100644
index 767d663dd8f7..000000000000
--- a/dev-libs/xapian/xapian-1.4.21.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit multilib-minimal
-
-MY_P="${PN}-core-${PV}"
-
-DESCRIPTION="Xapian Probabilistic Information Retrieval library"
-HOMEPAGE="https://xapian.org/"
-SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/30" # ABI version of libxapian.so
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos ~x64-solaris"
-IUSE="doc static-libs cpu_flags_x86_sse cpu_flags_x86_sse2 +inmemory +remote"
-
-DEPEND="sys-apps/util-linux[${MULTILIB_USEDEP}]
- sys-libs/zlib[${MULTILIB_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-multilib_src_configure() {
- local myconf=""
-
- if use cpu_flags_x86_sse2; then
- myconf="${myconf} --enable-sse=sse2"
- else
- if use cpu_flags_x86_sse; then
- myconf="${myconf} --enable-sse=sse"
- else
- myconf="${myconf} --disable-sse"
- fi
- fi
-
- myconf="${myconf} $(use_enable static-libs static)"
-
- use inmemory || myconf="${myconf} --disable-backend-inmemory"
- use remote || myconf="${myconf} --disable-backend-remote"
-
- myconf="${myconf} --enable-backend-glass --enable-backend-chert --program-suffix="
-
- ECONF_SOURCE=${S} econf ${myconf}
-}
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/xapian/postingsource.h
- /usr/include/xapian/attributes.h
- /usr/include/xapian/valuesetmatchdecider.h
- /usr/include/xapian/version.h
- /usr/include/xapian/version.h
- /usr/include/xapian/types.h
- /usr/include/xapian/positioniterator.h
- /usr/include/xapian/registry.h
-)
-
-multilib_src_test() {
- emake check VALGRIND=
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
-}
-
-multilib_src_install_all() {
- if use doc; then
- rm -rf "${ED}/usr/share/doc/xapian-core-${PV}" || die
- fi
-
- dodoc AUTHORS HACKING PLATFORMS README NEWS
-
- find "${ED}" -name "*.la" -type f -delete || die
-}