summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-06-07 20:46:27 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-06-07 20:47:18 +0200
commit646212efa126022d0001ab5c75bcb8562e3b84fe (patch)
treea3293a18e16b22eb7a0212fc58a391790b7aed0c /dev-libs
parentapp-portage/eix: Bump to 0.35.1 (diff)
downloadgentoo-646212efa126022d0001ab5c75bcb8562e3b84fe.tar.gz
gentoo-646212efa126022d0001ab5c75bcb8562e3b84fe.tar.bz2
gentoo-646212efa126022d0001ab5c75bcb8562e3b84fe.zip
dev-libs/libpcre2: Revbump to fix a JIT issue
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libpcre2/files/libpcre2-10.37-jit_fixes.patch80
-rw-r--r--dev-libs/libpcre2/libpcre2-10.37-r2.ebuild98
2 files changed, 178 insertions, 0 deletions
diff --git a/dev-libs/libpcre2/files/libpcre2-10.37-jit_fixes.patch b/dev-libs/libpcre2/files/libpcre2-10.37-jit_fixes.patch
new file mode 100644
index 000000000000..6ee5494f2bc5
--- /dev/null
+++ b/dev-libs/libpcre2/files/libpcre2-10.37-jit_fixes.patch
@@ -0,0 +1,80 @@
+Index: pcre2/ChangeLog
+===================================================================
+--- pcre2/ChangeLog (revision 1314)
++++ pcre2/ChangeLog (revision 1315)
+@@ -1,7 +1,14 @@
+ Change Log for PCRE2
+ --------------------
+
++Version 10.38-RC1 xx-xxx-2021
++-----------------------------
+
++1. Fix invalid single character repetition issues in JIT when the repetition
++is inside a capturing bracket and the bracket is preceeded by character
++literals.
++
++
+ Version 10.37 26-May-2021
+ -------------------------
+
+Index: pcre2/src/pcre2_jit_compile.c
+===================================================================
+--- pcre2/src/pcre2_jit_compile.c (revision 1314)
++++ pcre2/src/pcre2_jit_compile.c (revision 1315)
+@@ -1236,15 +1236,16 @@
+
+ return: current number of iterators enhanced with fast fail
+ */
+-static int detect_early_fail(compiler_common *common, PCRE2_SPTR cc, int *private_data_start, sljit_s32 depth, int start)
++static int detect_early_fail(compiler_common *common, PCRE2_SPTR cc, int *private_data_start,
++ sljit_s32 depth, int start, BOOL fast_forward_allowed)
+ {
+ PCRE2_SPTR begin = cc;
+ PCRE2_SPTR next_alt;
+ PCRE2_SPTR end;
+ PCRE2_SPTR accelerated_start;
++BOOL prev_fast_forward_allowed;
+ int result = 0;
+ int count;
+-BOOL fast_forward_allowed = TRUE;
+
+ SLJIT_ASSERT(*cc == OP_ONCE || *cc == OP_BRA || *cc == OP_CBRA);
+ SLJIT_ASSERT(*cc != OP_CBRA || common->optimized_cbracket[GET2(cc, 1 + LINK_SIZE)] != 0);
+@@ -1476,6 +1477,7 @@
+ case OP_CBRA:
+ end = cc + GET(cc, 1);
+
++ prev_fast_forward_allowed = fast_forward_allowed;
+ fast_forward_allowed = FALSE;
+ if (depth >= 4)
+ break;
+@@ -1484,7 +1486,7 @@
+ if (*end != OP_KET || (*cc == OP_CBRA && common->optimized_cbracket[GET2(cc, 1 + LINK_SIZE)] == 0))
+ break;
+
+- count = detect_early_fail(common, cc, private_data_start, depth + 1, count);
++ count = detect_early_fail(common, cc, private_data_start, depth + 1, count, prev_fast_forward_allowed);
+
+ if (PRIVATE_DATA(cc) != 0)
+ common->private_data_ptrs[begin - common->start] = 1;
+@@ -13657,7 +13659,7 @@
+ private_data_size = common->cbra_ptr + (re->top_bracket + 1) * sizeof(sljit_sw);
+
+ if ((re->overall_options & PCRE2_ANCHORED) == 0 && (re->overall_options & PCRE2_NO_START_OPTIMIZE) == 0 && !common->has_skip_in_assert_back)
+- detect_early_fail(common, common->start, &private_data_size, 0, 0);
++ detect_early_fail(common, common->start, &private_data_size, 0, 0, TRUE);
+
+ set_private_data_ptrs(common, &private_data_size, ccend);
+
+Index: pcre2/src/pcre2_jit_test.c
+===================================================================
+--- pcre2/src/pcre2_jit_test.c (revision 1314)
++++ pcre2/src/pcre2_jit_test.c (revision 1315)
+@@ -351,6 +351,7 @@
+ { MU, A, 0, 0, ".[ab]*a", "xxa" },
+ { MU, A, 0, 0, ".[ab]?.", "xx" },
+ { MU, A, 0, 0, "_[ab]+_*a", "_aa" },
++ { MU, A, 0, 0, "#(A+)#\\d+", "#A#A#0" },
+
+ /* Bracket repeats with limit. */
+ { MU, A, 0, 0, "(?:(ab){2}){5}M", "abababababababababababM" },
diff --git a/dev-libs/libpcre2/libpcre2-10.37-r2.ebuild b/dev-libs/libpcre2/libpcre2-10.37-r2.ebuild
new file mode 100644
index 000000000000..8f86138dfd59
--- /dev/null
+++ b/dev-libs/libpcre2/libpcre2-10.37-r2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit libtool multilib-minimal usr-ldscript
+
+PATCH_SET="${PN}-10.36-patchset-01.tar.xz"
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="https://www.pcre.org/"
+MY_P="pcre2-${PV/_rc/-RC}"
+if [[ ${PV} != *_rc* ]] ; then
+ # Only the final releases are available here.
+ SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
+ https://ftp.pcre.org/pub/pcre/${MY_P}.tar.bz2"
+else
+ SRC_URI="https://ftp.pcre.org/pub/pcre/Testing/${MY_P}.tar.bz2"
+fi
+
+if [[ -n "${PATCH_SET}" ]] ; then
+ SRC_URI+=" https://dev.gentoo.org/~whissi/dist/${PN}/${PATCH_SET}
+ https://dev.gentoo.org/~polynomial-c/dist/${PATCH_SET}"
+fi
+
+LICENSE="BSD"
+SLOT="0/3" # libpcre2-posix.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 +jit libedit +pcre16 pcre32 +readline +recursion-limit static-libs unicode zlib"
+REQUIRED_USE="?? ( libedit readline )"
+
+BDEPEND="
+ virtual/pkgconfig
+ userland_GNU? ( >=sys-apps/findutils-4.4.0 )
+"
+RDEPEND="
+ bzip2? ( app-arch/bzip2 )
+ libedit? ( dev-libs/libedit )
+ readline? ( sys-libs/readline:0= )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-jit_fixes.patch"
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pcre2-config
+)
+
+src_prepare() {
+ if [[ -d "${WORKDIR}/patches" ]] ; then
+ rm "${WORKDIR}"/patches/pcre2-10.36-001-issue2698.patch || die
+ eapply "${WORKDIR}"/patches
+ fi
+
+ default
+
+ elibtoolize
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-pcre2-8
+ --enable-shared
+ --with-match-limit-depth=$(usex recursion-limit 8192 MATCH_LIMIT)
+ $(multilib_native_use_enable bzip2 pcre2grep-libbz2)
+ $(multilib_native_use_enable libedit pcre2test-libedit)
+ $(multilib_native_use_enable readline pcre2test-libreadline)
+ $(multilib_native_use_enable zlib pcre2grep-libz)
+ $(use_enable jit)
+ $(use_enable jit pcre2grep-jit)
+ $(use_enable pcre16 pcre2-16)
+ $(use_enable pcre32 pcre2-32)
+ $(use_enable static-libs static)
+ $(use_enable unicode)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1 $(multilib_is_native_abi || echo "bin_PROGRAMS=")
+}
+
+multilib_src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(multilib_is_native_abi || echo "bin_PROGRAMS= dist_html_DATA=") \
+ install
+ multilib_is_native_abi && gen_usr_ldscript -a pcre2-posix
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+}