summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Förster <Dessa@gmake.de>2019-12-31 14:58:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-07-15 17:10:34 +0200
commit64df37ffdbdf4eebeceec4b7d19ea26e4fa628a1 (patch)
tree4f66b608a139d5c8c1ceb6a18c8663f3fe40f934 /dev-libs
parentapp-office/orage: panel plugin requires gtk+2 panel (diff)
downloadgentoo-64df37ffdbdf4eebeceec4b7d19ea26e4fa628a1.tar.gz
gentoo-64df37ffdbdf4eebeceec4b7d19ea26e4fa628a1.tar.bz2
gentoo-64df37ffdbdf4eebeceec4b7d19ea26e4fa628a1.zip
dev-libs/Ice: version bump to 3.6.5
Closes: https://bugs.gentoo.org/718274 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Robert Förster <Dessa@gmake.de> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/Ice/Ice-3.6.5.ebuild336
-rw-r--r--dev-libs/Ice/Manifest1
-rw-r--r--dev-libs/Ice/files/Ice-3.6.5-csharp.patch50
-rw-r--r--dev-libs/Ice/files/Ice-3.6.5-db6.patch48
4 files changed, 435 insertions, 0 deletions
diff --git a/dev-libs/Ice/Ice-3.6.5.ebuild b/dev-libs/Ice/Ice-3.6.5.ebuild
new file mode 100644
index 000000000000..eded3b0ee7c3
--- /dev/null
+++ b/dev-libs/Ice/Ice-3.6.5.ebuild
@@ -0,0 +1,336 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+RUBY_OPTIONAL="yes"
+USE_RUBY="ruby25"
+
+PHP_EXT_NAME="IcePHP"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+PHP_EXT_OPTIONAL_USE=php
+
+USE_PHP="php7-4"
+
+# This variable does not belong to any eclass. It is solely used in this ebuild
+BERKDB_SLOTS=( 6.2 6.1 5.3 5.1 4.8 )
+
+inherit db-use mono-env php-ext-source-r3 python-r1 ruby-ng toolchain-funcs
+
+DESCRIPTION="ICE middleware C++ library and generator tools"
+HOMEPAGE="https://zeroc.com/products/ice"
+SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://download.zeroc.com/Ice/$(ver_cut 1-2)/${PN}-3.6.4.pdf )"
+LICENSE="GPL-2"
+SLOT="0/36"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug doc examples libressl +readline mono php python ruby test"
+RESTRICT="test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/expat-2.0.1
+ >=app-arch/bzip2-1.0.5
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ || (
+ $(for slot in ${BERKDB_SLOTS[@]} ; do printf '%s\n' "sys-libs/db:${slot}[cxx]" ; done)
+ )
+ dev-cpp/libmcpp
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( $(ruby_implementation_depend ruby25) )
+ mono? ( dev-lang/mono )"
+DEPEND="${RDEPEND}
+ readline? ( sys-libs/readline:0= )
+ test? (
+ ${PYTHON_DEPS}
+ dev-python/passlib[${PYTHON_USEDEP}]
+ )"
+
+# Maintainer notes:
+# TODO: java bindings
+
+S="${WORKDIR}/${P,}"
+PHP_EXT_S="${S}/php"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.6.3-no-arch-opts.patch"
+ "${FILESDIR}/${P}-db6.patch"
+ "${FILESDIR}/${P}-csharp.patch"
+)
+
+pkg_setup() {
+ # prevent ruby-ng.eclass from messing with pkg_setup
+ return
+}
+
+src_unpack() {
+ # prevent ruby-ng.eclass from messing with src_unpack
+ default
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|-L\$\(libdir\)||' \
+ cpp/config/Make.rules || die
+
+ sed -i \
+ -e 's|-O2 ||g' \
+ -e 's|-Werror ||g' \
+ cpp/config/Make.rules.Linux || die
+
+ sed -i \
+ -e 's|install-common||' \
+ {cpp,csharp,php,python,ruby}/Makefile || die
+
+ sed -i \
+ -e 's|-f -root|-f -gacdir $(GAC_DIR) -root|' \
+ csharp/config/Make.rules.cs || die
+
+ # skip mono tests, bug #498484
+ sed -i \
+ -e '/SUBDIRS/s|\ test||' \
+ csharp/Makefile || die
+
+ # skip udp test due to multicast
+ # skip IceGrid/admin bug #649850
+ # skip IceSSL tests due to requirement of internet connection
+ # skip IceStorm/single bug #636834
+ # IceUtil/stacktrace and IceStorm/stress fail with USE=debug
+ # Glacier2/staticFiltering requires network access
+ sed -i \
+ -e 's|allTests.py|allTests.py --rfilter=udp --rfilter=IceGrid\/admin --rfilter=IceSSL --rfilter=IceStorm\/single --rfilter=IceStorm\/stress --rfilter=IceUtil\/stacktrace --rfilter=Glacier2\/staticFiltering|' \
+ cpp/Makefile || die
+
+ # fails even on unicode locale
+ sed -i \
+ -e 's|allTests.py|allTests.py --rfilter=Slice\/unicodePaths|' \
+ ruby/Makefile || die
+
+ # fix for x86 IceBox test
+ sed -i \
+ -e 's|"32"|""|' \
+ scripts/TestUtil.py || die
+}
+
+src_configure() {
+ suitable_db_version() {
+ local ver
+ for ver in "${BERKDB_SLOTS[@]}"; do
+ if [[ -n $(db_findver sys-libs/db:${ver}) ]]; then
+ echo "${ver}"
+ return 0
+ fi
+ done
+ die "No suitable BerkDB versions found, aborting"
+ }
+
+ MAKE_RULES=(
+ "prefix=\"${ED}/usr\""
+ "install_docdir=\"${ED}/usr/share/doc/${PF}\""
+ "install_configdir=\"${ED}/usr/share/${P}/config\""
+ "install_mandir=\"${ED}/usr/share/man/man1\""
+ "embedded_runpath_prefix=\"${EPREFIX}/usr\""
+ "LP64=yes"
+ "new_dtags=yes"
+ "NOTEST=$(usex !test)"
+ "USE_READLINE=$(usex readline)"
+ "OPTIMIZE=$(usex !debug)"
+ )
+
+ local BERKDB_VERSION="$(suitable_db_version)"
+ MAKE_RULES+=("DB_FLAGS=-I$(db_includedir ${BERKDB_VERSION})")
+ sed -i \
+ -e "s|g++|$(tc-getCXX)|" \
+ -e "s|\(CFLAGS[[:space:]]*=\)|\1 ${CFLAGS}|" \
+ -e "s|\(CXXFLAGS[[:space:]]*=\)|\1 ${CXXFLAGS}|" \
+ -e "s|\(LDFLAGS[[:space:]]*=\)|\1 ${LDFLAGS}|" \
+ -e "s|\(DB_LIBS[[:space:]]*=\) \-ldb_cxx|\1 -ldb_cxx-$(db_findver sys-libs/db:${BERKDB_VERSION})|" \
+ cpp/config/Make.rules{,.Linux} python/config/Make.rules || die
+
+ if use python; then
+ local S="${S}/python"
+ python_copy_sources
+ fi
+
+ if use ruby; then
+ SITERUBY="$(ruby25 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
+ SITERUBYARCH="$(ruby25 -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')"
+ MAKE_RULES_RUBY=(
+ "install_rubydir=\"${ED}/${SITERUBY}\""
+ "install_libdir=\"${ED}/${SITERUBYARCH}\""
+ )
+
+ # make it use ruby25 only
+ sed -i \
+ -e 's|RUBY = ruby|\025|' \
+ ruby/config/Make.rules || die
+ sed -i \
+ -e 's|env ruby|\025|' \
+ ruby/config/s2rb.rb || die
+ sed -i \
+ -e 's|env ruby|\025|' \
+ ruby/scripts/slice2rb || die
+ sed -i \
+ -e 's|output.write("ruby|\025|' \
+ scripts/TestUtil.py || die
+ fi
+
+ MAKE_RULES_MONO=(
+ "GACINSTALL=yes"
+ "GAC_ROOT=\"${ED}/usr/$(get_libdir)\""
+ "GAC_DIR=\"${EPREFIX}/usr/$(get_libdir)\""
+ "install_libdir=\"${ED}/usr/$(get_libdir)\""
+ "install_pkgconfigdir=\"${ED}/usr/$(get_libdir)/pkgconfig\""
+ )
+
+ if has_version ">dev-lang/mono-4"; then
+ MAKE_RULES_MONO+=("MCS=mcs")
+ fi
+
+ use test && python_setup
+}
+
+src_compile() {
+ # Do not remove this export or build will break!
+ tc-export CXX
+
+ emake -C cpp "${MAKE_RULES[@]}"
+
+ if use php; then
+ local i
+ for i in $(php_get_slots); do
+ mkdir -p "${WORKDIR}/${i}" || die
+ cp -r "${PHP_EXT_S}" "${WORKDIR}/${i}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
+
+ pushd "${WORKDIR}/${i}" >/dev/null || die
+ ln -s "${S}/cpp" || die
+ ln -s "${S}/config" || die
+ ln -s "${S}/slice" || die
+ ln -s "${S}/Makefile" || die
+
+ emake -C php "${MAKE_RULES[@]}" USE_NAMESPACES=yes "PHP_CONFIG=\"${EPREFIX}/usr/$(get_libdir)/${i}/bin/php-config\""
+ popd >/dev/null || die
+ done
+ fi
+
+ if use python; then
+ building() {
+ emake -C "${BUILD_DIR}" "${MAKE_RULES[@]}" PYTHON="${EPYTHON}"
+ }
+ local S="${S}/python"
+ python_foreach_impl building
+ fi
+
+ if use ruby; then
+ emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}"
+ fi
+
+ if use mono; then
+ emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}"
+ fi
+}
+
+src_test() {
+ local -x LD_LIBRARY_PATH="${S}/cpp/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
+ emake -C cpp "${MAKE_RULES[@]}" test
+
+ # php tests require the extension loaded and are therefore skipped
+
+ if use python; then
+ testing() {
+ PYTHONPATH="${BUILD_DIR}"/python emake -C "${BUILD_DIR}" \
+ "${MAKE_RULES[@]}" \
+ PYTHON="${EPYTHON}" \
+ install_pythondir="\"${D}/$(python_get_sitedir)\"" \
+ install_libdir="\"${D}/$(python_get_sitedir)\"" test
+ }
+ local S="${S}/python"
+ python_foreach_impl testing
+ fi
+
+ if use ruby; then
+ emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" test
+ fi
+
+ if use mono; then
+ # skip mono tests, bug #498484
+ ewarn "Tests for C# are currently disabled."
+ #emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}" test
+ fi
+}
+
+src_install() {
+ local DOCS=( CHANGELOG*.md README.md )
+ use doc && DOCS+=( "${DISTDIR}/${PN}-3.6.4.pdf" )
+ einstalldocs
+
+ insinto /usr/share/${P}
+ doins -r slice
+
+ emake -C cpp "${MAKE_RULES[@]}" install
+
+ if use examples; then
+ docinto examples-cpp
+ dodoc cpp/config/*.cfg
+ docompress -x /usr/share/doc/${PF}/examples-cpp
+ fi
+
+ if use php; then
+ insinto "/usr/share/php/${PN}"
+
+ local i
+ while IFS="" read -d $'\0' -r i; do
+ doins "${i}"
+ done < <(find "${S}/php/lib/" -name '*.php' -print0)
+
+ pushd "${ED}/usr/share/${P}/slice" >/dev/null || die
+
+ local -x LD_LIBRARY_PATH="${ED}/usr/$(get_libdir):${LD_LIBRARY_PATH}"
+ for i in *; do
+ mkdir -p "${ED}/usr/share/php/${i}" || die
+ "${ED}"/usr/bin/slice2php \
+ -I"${ED}/usr/share/${P}/slice/" --all \
+ --output-dir "${ED}/usr/share/php/${i}" \
+ --ice "${ED}/usr/share/${P}/slice/${i}"/*
+ done
+
+ for i in $(php_get_slots); do
+ php_init_slot_env "${i}"
+ insinto "${EXT_DIR}"
+ newins "php/lib/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
+ done
+ php-ext-source-r3_createinifiles
+
+ popd >/dev/null || die
+ fi
+
+ if use python; then
+ installation() {
+ mkdir -p "${D}/$(python_get_sitedir)" || die
+
+ emake -C "${BUILD_DIR}" \
+ "${MAKE_RULES[@]}" \
+ install_pythondir="\"${D}/$(python_get_sitedir)\"" \
+ install_libdir="\"${D}/$(python_get_sitedir)\"" \
+ install
+ python_optimize
+ }
+ local S="${S}/python"
+ python_foreach_impl installation
+ fi
+
+ if use ruby; then
+ dodir "${SITERUBY}"
+ emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" install
+ fi
+
+ if use mono; then
+ emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}" install
+ fi
+}
diff --git a/dev-libs/Ice/Manifest b/dev-libs/Ice/Manifest
index 2f01fc407b04..e921ac64f9f4 100644
--- a/dev-libs/Ice/Manifest
+++ b/dev-libs/Ice/Manifest
@@ -1,2 +1,3 @@
DIST Ice-3.6.4.pdf 8907736 BLAKE2B 5a631c1e2e147c8ed3b31a84192210c92bbe83e8644ec9d7d164d1b94a20069ce77f6baf54910ac00c7216cbc2979caac6fa78457e9292a84407e93000f9903a SHA512 9bd2d373eb83e08e563cab174a53063a490367dea3e4b910f93f0477c3817282c859f07e46e503006e9bd37678fb6da31a58b88bfabd217b5e371fff685321a0
DIST Ice-3.6.4.tar.gz 5523841 BLAKE2B 4e50dcf0f004f14a38c173f181cabb97fdc201786c338800b9750dc0cf6ce9b1397ea26b4357de1f6e1ac6b4e69abbe2bf464a5f9c2926f6ae45abbf5a69803b SHA512 fdb412ce591bca7aede2ac7d70600184f3b67279e8ffdfee3649f517d5531d2dfee54b37d0cc6de2ef5de8ecd281c39d6c951781b68f9a36316a7607cefb9e57
+DIST Ice-3.6.5.tar.gz 5505499 BLAKE2B e16e8932f09270ac6bb86984ab47fa229ad873ee343ac4f56bb48b6f9547387ded0392a76302afac2c98b6d31da7c1faf294574cdba52654e7dea0af16b4169d SHA512 3431928e6168d716919aa9b3126d17a8ae14895bb78a369902a2bb350b2e82923f38ee17965ed3696512a016fcd34dc128e9aaca40fb2b032e7f7eb07bcb903b
diff --git a/dev-libs/Ice/files/Ice-3.6.5-csharp.patch b/dev-libs/Ice/files/Ice-3.6.5-csharp.patch
new file mode 100644
index 000000000000..cfdc1f6a8d47
--- /dev/null
+++ b/dev-libs/Ice/files/Ice-3.6.5-csharp.patch
@@ -0,0 +1,50 @@
+--- ice-3.6.5/csharp/src/Makefile~ 2015-06-23 17:30:20.000000000 +0200
++++ ice-3.6.5/csharp/src/Makefile 2015-06-27 20:07:04.217188211 +0200
+@@ -11,7 +11,7 @@
+
+ include $(top_srcdir)/config/Make.rules.cs
+
+-SUBDIRS = Ice IceStorm Glacier2 IcePatch2 IceGrid IceBox IceDiscovery IceLocatorDiscovery
++SUBDIRS = Ice IceStorm Glacier2 IcePatch2 IceGrid IceBox IceSSL IceDiscovery IceLocatorDiscovery
+
+ $(EVERYTHING)::
+ @for subdir in $(SUBDIRS); \
+--- /dev/null 2015-06-27 16:44:15.733558105 +0200
++++ ice-3.6.5/csharp/lib/pkgconfig/IceSSL.pc 2015-06-27 20:19:30.731894653 +0200
+@@ -0,0 +1,10 @@
++version = 3.6.5
++mono_root = /usr
++
++name = IceSSL
++
++Name: ${name}
++Description: IceSSL run-time support
++Version: ${version}
++Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
++Requires: Ice = ${version}
+--- /dev/null 2015-06-27 16:44:15.733558105 +0200
++++ ice-3.6.5/csharp/lib/pkgconfig/IceDiscovery.pc 2015-06-27 20:20:44.312515987 +0200
+@@ -0,0 +1,10 @@
++version = 3.6.5
++mono_root = /usr
++
++name = IceDiscovery
++
++Name: ${name}
++Description: IceDiscovery run-time support
++Version: ${version}
++Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
++Requires: Ice = ${version}
+--- /dev/null 2015-06-27 16:44:15.733558105 +0200
++++ ice-3.6.5/csharp/lib/pkgconfig/IceLocatorDiscovery.pc 2015-06-27 20:21:22.206185123 +0200
+@@ -0,0 +1,10 @@
++version = 3.6.5
++mono_root = /usr
++
++name = IceLocatorDiscovery
++
++Name: ${name}
++Description: IceLocatorDiscovery run-time support
++Version: ${version}
++Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
++Requires: Ice = ${version}
diff --git a/dev-libs/Ice/files/Ice-3.6.5-db6.patch b/dev-libs/Ice/files/Ice-3.6.5-db6.patch
new file mode 100644
index 000000000000..b78fae76a453
--- /dev/null
+++ b/dev-libs/Ice/files/Ice-3.6.5-db6.patch
@@ -0,0 +1,48 @@
+Avoid ambiguous ctor call (uint32_t vs DB_ENV*) with db 6.x.
+
+--- ice-3.6.3/cpp/src/Freeze/SharedDbEnv.cpp.orig 2016-10-05 16:59:08.000000000 +0200
++++ ice-3.6.3/cpp/src/Freeze/SharedDbEnv.cpp 2017-06-28 18:42:43.411869639 +0200
+@@ -530,7 +530,7 @@
+ {
+ if(_env == 0)
+ {
+- _envHolder.reset(new DbEnv(0));
++ _envHolder.reset(new DbEnv(0u));
+ _env = _envHolder.get();
+
+ if(_trace >= 1)
+--- ice-3.6.3/cpp/src/FreezeScript/transformdb.cpp.orig 2016-10-05 16:59:08.000000000 +0200
++++ ice-3.6.3/cpp/src/FreezeScript/transformdb.cpp 2017-06-28 19:15:03.928514164 +0200
+@@ -766,8 +766,8 @@
+ //
+ // Transform the database.
+ //
+- DbEnv dbEnv(0);
+- DbEnv dbEnvNew(0);
++ DbEnv dbEnv(0u);
++ DbEnv dbEnvNew(0u);
+ Freeze::TransactionPtr txNew;
+ Freeze::ConnectionPtr connection;
+ Freeze::ConnectionPtr connectionNew;
+--- ice-3.6.3/cpp/src/FreezeScript/Util.cpp.orig 2016-10-05 16:59:08.000000000 +0200
++++ ice-3.6.3/cpp/src/FreezeScript/Util.cpp 2017-06-28 19:22:29.318509063 +0200
+@@ -209,7 +209,7 @@
+ {
+ CatalogDataMap result;
+
+- DbEnv dbEnv(0);
++ DbEnv dbEnv(0u);
+ try
+ {
+ #ifdef _WIN32
+--- ice-3.6.3/cpp/src/FreezeScript/DumpDB.cpp.orig 2016-10-05 16:59:08.000000000 +0200
++++ ice-3.6.3/cpp/src/FreezeScript/DumpDB.cpp 2017-06-28 19:33:38.555168088 +0200
+@@ -481,7 +481,7 @@
+ FreezeScript::ObjectFactoryPtr objectFactory = new FreezeScript::ObjectFactory;
+ communicator->addObjectFactory(objectFactory, "");
+
+- DbEnv dbEnv(0);
++ DbEnv dbEnv(0u);
+ DbTxn* txn = 0;
+ Freeze::ConnectionPtr connection;
+ int status = EXIT_SUCCESS;