summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-02-06 23:19:14 -0800
committerMart Raudsepp <leio@gentoo.org>2019-02-18 20:57:34 +0200
commit697d1b58cdea610ab8cfc6c88cff37462946c5f2 (patch)
tree5c3e46eebf9b131bce74a08e63e243960abc040f /dev-libs
parentmedia-libs/mesa: Version bump to 18.3.4 (diff)
downloadgentoo-697d1b58cdea610ab8cfc6c88cff37462946c5f2.tar.gz
gentoo-697d1b58cdea610ab8cfc6c88cff37462946c5f2.tar.bz2
gentoo-697d1b58cdea610ab8cfc6c88cff37462946c5f2.zip
dev-libs/atk: Version bump to 2.30.0
Signed-off-by: Matt Turner <mattst88@gentoo.org> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/atk/Manifest1
-rw-r--r--dev-libs/atk/atk-2.30.0.ebuild48
-rw-r--r--dev-libs/atk/files/atk-2.30.0-use-basename-instead-of-filename.patch63
3 files changed, 112 insertions, 0 deletions
diff --git a/dev-libs/atk/Manifest b/dev-libs/atk/Manifest
index 721e42b4f2a4..eeb577790df1 100644
--- a/dev-libs/atk/Manifest
+++ b/dev-libs/atk/Manifest
@@ -1 +1,2 @@
DIST atk-2.28.1.tar.xz 712508 BLAKE2B 71aee8bc937e1e37d40e6a9820d0002bcc763dbf87385ede2484ec6fe17a9924d5753d74dc3a769602746c915d0c46da8eea78cc80c706e3c38faca2e5050364 SHA512 aa61e7718b3f4d9c33ec2b4747e35f894a51550ef39ecc4a7af5705811c029645bd3c728071f446b075a0b7aef0c35c1b73406a210cd30171838f24a8dfc0abb
+DIST atk-2.30.0.tar.xz 290264 BLAKE2B dec44abf3bd4937f417cd0b75bee32fdd073ccca1e44d883293d060afbbc30909aac483007e293231fafe0c5481df94d1113d287a0002a823f4e9c8e7bd647c2 SHA512 03f311378fdb91442f27ed542fa36edd2c9c036837c9f25ff37468bf7f743277d0b9253621563d15894e0da9d37e8df0a0e2c0e47e6aae33a38b13744c3b8b8e
diff --git a/dev-libs/atk/atk-2.30.0.ebuild b/dev-libs/atk/atk-2.30.0.ebuild
new file mode 100644
index 000000000000..496cdb291e58
--- /dev/null
+++ b/dev-libs/atk/atk-2.30.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org meson multilib-minimal
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="gtk-doc +introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.25 )
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ >=sys-devel/gettext-0.19.8
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-use-basename-instead-of-filename.patch
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddocs=$(multilib_native_usex gtk-doc true false)
+ -Dintrospection=$(multilib_native_usex introspection true false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}
diff --git a/dev-libs/atk/files/atk-2.30.0-use-basename-instead-of-filename.patch b/dev-libs/atk/files/atk-2.30.0-use-basename-instead-of-filename.patch
new file mode 100644
index 000000000000..763a15056702
--- /dev/null
+++ b/dev-libs/atk/files/atk-2.30.0-use-basename-instead-of-filename.patch
@@ -0,0 +1,63 @@
+From 14115cc94086fb2a0a5cd32e67c70f623847df64 Mon Sep 17 00:00:00 2001
+From: Samuel Thibault <samuel.thibault@ens-lyon.org>
+Date: Thu, 30 Aug 2018 11:39:25 +0200
+Subject: [PATCH] build: use @basename instead of @filename
+
+Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=789619
+---
+ atk/atk-enum-types.c.template | 2 +-
+ atk/atk-enum-types.h.template | 2 +-
+ atk/makefile.msc | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/atk/atk-enum-types.c.template b/atk/atk-enum-types.c.template
+index df2f546..b3c0b13 100644
+--- a/atk/atk-enum-types.c.template
++++ b/atk/atk-enum-types.c.template
+@@ -7,7 +7,7 @@
+
+ /*** BEGIN file-production ***/
+
+-/* enumerations from "@filename@" */
++/* enumerations from "@basename@" */
+ /*** END file-production ***/
+
+ /*** BEGIN value-header ***/
+diff --git a/atk/atk-enum-types.h.template b/atk/atk-enum-types.h.template
+index 7b4cec4..8321c24 100644
+--- a/atk/atk-enum-types.h.template
++++ b/atk/atk-enum-types.h.template
+@@ -14,7 +14,7 @@ G_BEGIN_DECLS
+
+ /*** BEGIN file-production ***/
+
+-/* enumerations from "@filename@" */
++/* enumerations from "@basename@" */
+ /*** END file-production ***/
+
+ /*** BEGIN value-header ***/
+diff --git a/atk/makefile.msc b/atk/makefile.msc
+index f407b7d..ed4656b 100644
+--- a/atk/makefile.msc
++++ b/atk/makefile.msc
+@@ -104,7 +104,7 @@ atkmarshal.c : atkmarshal.list
+ atk-enum-types.h : $(atk_headers) makefile.msc
+ $(PERL) $(GLIB)\gobject\glib-mkenums \
+ --fhead "#ifndef __ATK_ENUM_TYPES_H__\n#define __ATK_ENUM_TYPES_H__\n" \
+- --fprod "/* enumerations from \"@filename@\" */\n" \
++ --fprod "/* enumerations from \"@basename@\" */\n" \
+ --vhead "GType @enum_name@_get_type (void);\n#define ATK_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n" \
+ --ftail "#endif /* __ATK_ENUM_TYPES_H__ */" \
+ $(atk_headers) > atk-enum-types.h
+@@ -115,7 +115,7 @@ atk-enum-types.h : $(atk_headers) makefile.msc
+ atk-enum-types.c: $(atk_headers) makefile.msc
+ $(PERL) $(GLIB)\gobject\glib-mkenums \
+ --fhead "#include <atk.h>" \
+- --fprod "\n/* enumerations from \"@filename@\" */" \
++ --fprod "\n/* enumerations from \"@basename@\" */" \
+ --vhead "GType\n@enum_name@_get_type (void)\n{\n static GType etype = 0;\n if (etype == 0) {\n static const G@Type@Value values[] = {" \
+ --vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \
+ --vtail " { 0, NULL, NULL }\n };\n etype = g_@type@_register_static (\"@EnumName@\", values);\n }\n return etype;\n}\n" \
+--
+2.19.2
+