summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-22 09:51:41 +0000
committerSam James <sam@gentoo.org>2021-11-22 09:51:41 +0000
commit6d0711ff5c0e069faa6aed313e975b8800e48a65 (patch)
tree0462fd520f425ed9f905368ae2efd13d1bcb5bda /dev-libs
parentsys-libs/libblockdev: fix tests (to extent possible; they need root still) (diff)
downloadgentoo-6d0711ff5c0e069faa6aed313e975b8800e48a65.tar.gz
gentoo-6d0711ff5c0e069faa6aed313e975b8800e48a65.tar.bz2
gentoo-6d0711ff5c0e069faa6aed313e975b8800e48a65.zip
dev-libs/cyrus-sasl: fix autoconf 2.71 compatibility (breaks gssapi detection)
Closes: https://bugs.gentoo.org/825342 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r6.ebuild (renamed from dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r5.ebuild)1
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-autoconf-2.71.patch45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r5.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r6.ebuild
index 1a07aa6eace3..3f20ae795401 100644
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r5.ebuild
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27-r6.ebuild
@@ -58,6 +58,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.1.27-CVE-2019-19906.patch"
"${FILESDIR}/${PN}-2.1.27-slibtool.patch"
"${FILESDIR}/${PN}-2.1.27-db_gdbm-fix-gdbm_errno-overlay-from-gdbm_close.patch"
+ "${FILESDIR}/${PN}-2.1.27-autoconf-2.71.patch"
)
pkg_setup() {
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-autoconf-2.71.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-autoconf-2.71.patch
new file mode 100644
index 000000000000..b346cd7e5002
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-autoconf-2.71.patch
@@ -0,0 +1,45 @@
+https://bugs.gentoo.org/825342
+
+commit 5664c3f535289ce9efb513a2897991b5c436bb44
+Author: Pavel Raiskup <praiskup@redhat.com>
+Date: Thu Apr 1 17:26:28 2021 +0200
+
+ configure.ac: properly quote macro arguments
+
+ Autoconf 2.70+ is more picky about the quotation (even though with
+ previous versions the arguments should have been quoted, too). When we
+ don't quote macros inside the AC_CACHE_VAL macro - some of the Autoconf
+ initialization is wrongly ordered in ./configure script and we keep
+ seeing bugs like:
+
+ ./configure: line 2165: ac_fn_c_try_run: command not found
+
+ Original report: https://bugzilla.redhat.com/1943013
+
+ Signed-off-by: Pavel Raiskup <praiskup@redhat.com>
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -213,7 +213,8 @@ if test $sasl_cv_uscore = yes; then
+ AC_MSG_CHECKING(whether dlsym adds the underscore for us)
+ cmu_save_LIBS="$LIBS"
+ LIBS="$LIBS $SASL_DL_LIB"
+- AC_CACHE_VAL(sasl_cv_dlsym_adds_uscore,AC_TRY_RUN( [
++ AC_CACHE_VAL([sasl_cv_dlsym_adds_uscore],
++ [AC_TRY_RUN([
+ #include <dlfcn.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -221,9 +222,9 @@ void foo() { int i=0;}
+ int main() { void *self, *ptr1, *ptr2; self=dlopen(NULL,RTLD_LAZY);
+ if(self) { ptr1=dlsym(self,"foo"); ptr2=dlsym(self,"_foo");
+ if(ptr1 && !ptr2) exit(0); } exit(1); }
+-], [sasl_cv_dlsym_adds_uscore=yes], sasl_cv_dlsym_adds_uscore=no
+- AC_DEFINE(DLSYM_NEEDS_UNDERSCORE, [], [Do we need a leading _ for dlsym?]),
+- AC_MSG_WARN(cross-compiler, we'll do our best)))
++], [sasl_cv_dlsym_adds_uscore=yes], [sasl_cv_dlsym_adds_uscore=no
++ AC_DEFINE(DLSYM_NEEDS_UNDERSCORE, [], [Do we need a leading _ for dlsym?])],
++ [AC_MSG_WARN(cross-compiler, we'll do our best)])])
+ LIBS="$cmu_save_LIBS"
+ AC_MSG_RESULT($sasl_cv_dlsym_adds_uscore)
+