summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-10 11:47:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-10 13:42:56 +0100
commit7d11bcf35e2a17deeb6dd6a0ac31ccae98fc313f (patch)
treee90c8761300b0aaa56e5f126bffe5ef767e67f81 /dev-libs
parentsys-libs/librtas-2.0.2-r1: fix install for Prefix (diff)
downloadgentoo-7d11bcf35e2a17deeb6dd6a0ac31ccae98fc313f.tar.gz
gentoo-7d11bcf35e2a17deeb6dd6a0ac31ccae98fc313f.tar.bz2
gentoo-7d11bcf35e2a17deeb6dd6a0ac31ccae98fc313f.zip
dev-libs/libb64: Bump to 2.0.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libb64/Manifest1
-rw-r--r--dev-libs/libb64/libb64-2.0.0.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libb64/Manifest b/dev-libs/libb64/Manifest
index 0e3869afeccc..de017bb98a03 100644
--- a/dev-libs/libb64/Manifest
+++ b/dev-libs/libb64/Manifest
@@ -1 +1,2 @@
DIST libb64-1.2.1.zip 23316 BLAKE2B 1e3aa08679e363d61b7a0a77bfe909c0fc80411bf2c7b0f35e7a8a692a25585a37303ea0f010600c0e07e0419f016fe60f88851eebb26d044e7dbaf3d02726a0 SHA512 8b1e5c8086a38be82471b5f37393f3f236c923f4a2bb737209a297cbab32a9f0a5c4af4ac912c695f0f7d8ff9458d97ce0d01092fbacbfe7181e4fd816e2153d
+DIST libb64-2.0.0.1.tar.gz 15766 BLAKE2B 45e3cab768cae39758d146cd84b72a7644592e55553be9c11ed1e83c3acbf4ed05cd00bbd59371b9e71cd53012149f25c371769afba7fbdaafdf561a297247c8 SHA512 72c2fd4c81575b505f4851cd3820b6a2d8e78cd031a1ed138ffe5667ca711558f43b515428971966f7a73ace7c9951f1f0b39c362a59fe4691958875775cce23
diff --git a/dev-libs/libb64/libb64-2.0.0.1.ebuild b/dev-libs/libb64/libb64-2.0.0.1.ebuild
new file mode 100644
index 000000000000..9adbb345b334
--- /dev/null
+++ b/dev-libs/libb64/libb64-2.0.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Fast Base64 encoding/decoding routines"
+HOMEPAGE="https://github.com/libb64/libb64/"
+SRC_URI="
+ https://github.com/libb64/libb64/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-PD"
+# static library, so always rebuild
+SLOT="0/${PVR}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+src_compile() {
+ # override -O3, -Werror non-sense
+ emake -C src CFLAGS="${CFLAGS} -I../include"
+}
+
+src_install() {
+ dolib.a src/libb64.a
+ insinto /usr/include
+ doins -r include/b64
+ einstalldocs
+}