summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-09-30 22:35:46 +0200
committerMichał Górny <mgorny@gentoo.org>2015-09-30 22:40:22 +0200
commit8d3e54d82cf53ab67e01f3d980efc73d23d69589 (patch)
treedaff13e1a05cd01489681c07fa273ab7e3e8d551 /dev-libs
parentwww-client/links: Version bump. (diff)
downloadgentoo-8d3e54d82cf53ab67e01f3d980efc73d23d69589.tar.gz
gentoo-8d3e54d82cf53ab67e01f3d980efc73d23d69589.tar.bz2
gentoo-8d3e54d82cf53ab67e01f3d980efc73d23d69589.zip
dev-libs/jsoncpp: Bump to 1.6.5
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/jsoncpp/Manifest1
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/jsoncpp/Manifest b/dev-libs/jsoncpp/Manifest
index 82f32f6e2cef..ae89c33e769b 100644
--- a/dev-libs/jsoncpp/Manifest
+++ b/dev-libs/jsoncpp/Manifest
@@ -1,3 +1,4 @@
DIST jsoncpp-0.10.2.tar.gz 197188 SHA256 37bb72615018522bb78a5eb425b36dfc79e049c1d5471b724f7ccadeac0ed479 SHA512 8e451e3ba37094445ab098d5b9f7236ac84e2f15d98e2039c565e609b757c2383e91850bd86aca507ca5cd2f733fedc484bb7760eeeee7fe9bace71d97ae0d2e WHIRLPOOL 85f9861e77a7c3cecd5e859adde832b7f12a0c5eae04ecbee203e5d8c4b8b13ba034b4aa6b78a3b981aa392a4ea6a26c2e1d411ae97768d7ed422f71ec2e5d79
DIST jsoncpp-1.6.2.tar.gz 198824 SHA256 c40e5a2583df633b904525305bda40b622d9971fee1ece7ce48ca723a4907d36 SHA512 b70dc99ec57357943f7b56d013abc6245c1ffdc3c16313bcf72ba624fa5f6d72eebfda0188a229c7757e00e3ad2c19d67048acd33c22260079e37b32000a39a7 WHIRLPOOL 35f337812bda3cb24a9b221578c72d48876427e2fe10c1c57beea308b855c6d48d688d73260bd7915261676bd4463062191948d630bfac53350a855d89a8d7fe
+DIST jsoncpp-1.6.5.tar.gz 200507 SHA256 a2b121eaff56ec88cfd034d17685821a908d0d87bc319329b04f91a6552c1ac2 SHA512 589153d525ffde15e10f1ef6907c6b5d0f62a41c8cebdc12fe2bc4d989bcd861cdac79526de2f51872c0a17e574bf0fd8c913f0aa301c184efa1e3f2fb2b1955 WHIRLPOOL a1253362a0bdd8a6d05e84fb7d7de5b79aec0cadf5a03a8c2be8a6e8062e6ae231e5b97cd99ee9607c2c546afa58dabb183167c6a74b409d32485b45c7d3e9ae
DIST jsoncpp-src-0.5.0.tar.gz 107466 SHA256 22b14ecd0de8cdad2b6b6839f6d0804d3b84e91f42861ebd843832a26a927433 SHA512 2815d3523f92c33a5be3221161a590a0fddd16cb22e5dc634791535ee44271ec4fbb64f81cc958a87b1f029a8108ed9f169cda5a2d0422f60699ac286386a1bc WHIRLPOOL f6174f08dc647a189fc17f93343a72fb83bea66f27e60707b6bf300a185d4d3e8d5f347dd6f0d06462e45086c7c1dbd352e22ac08fef13d9235a65bad44f0d67
diff --git a/dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild b/dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild
new file mode 100644
index 000000000000..3dbd839f047d
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-1.6.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ ${PYTHON_DEPS}
+ )
+ test? (
+ ${PYTHON_DEPS}
+ )"
+RDEPEND=""
+
+pkg_setup() {
+ if use doc || use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSONCPP_WITH_TESTS=$(usex test)
+ -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF
+ -DJSONCPP_WITH_CMAKE_PACKAGE=ON
+
+ -DBUILD_SHARED_LIBS=ON
+ # Follow Debian, Ubuntu, Arch convention for headers location
+ # bug #452234
+ -DINCLUDE_INSTALL_DIR="${EPREFIX}"/usr/include/jsoncpp
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ "${EPYTHON}" doxybuild.py --doxygen=/usr/bin/doxygen || die
+ fi
+}
+
+src_test() {
+ emake -C "${BUILD_DIR}" jsoncpp_check
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ dohtml dist/doxygen/jsoncpp*/*
+ fi
+}