summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-08-31 15:35:07 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-08-31 15:35:07 +0200
commit90c715d4ad5e6d47c442d76b7a815d385775974e (patch)
treed6539d17c690a66acf231f7f62e94b2ff05a26fb /dev-libs
parentnet-print/hplip: Version bump to 3.16.8 (diff)
downloadgentoo-90c715d4ad5e6d47c442d76b7a815d385775974e.tar.gz
gentoo-90c715d4ad5e6d47c442d76b7a815d385775974e.tar.bz2
gentoo-90c715d4ad5e6d47c442d76b7a815d385775974e.zip
dev-libs/libinput: Version bump to 1.4.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.4.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index fafb652c7ad5..a37885158719 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -4,3 +4,4 @@ DIST libinput-1.3.0.tar.xz 878372 SHA256 998a75fb261d161efaa7da44411cdc9a32a9532
DIST libinput-1.3.1.tar.xz 880284 SHA256 cdff653d93395c718f367af61fee866914bc45de75ac94abe7dc1b720462aca9 SHA512 b63f28bb99544bea48742669156a8dd6041e00315cbe75849d6bcee2c9f7c0570c9b96e59982cdfe5f972bd15cd97f852038ecce0feaed071fe31cc26a3936e8 WHIRLPOOL f0732988b7f24bf1d1a97210071488925ba139033c374f0b345b45ec74073df3a778189bad0c1c949d26997c4068d9e55ebab386438cc18cea2ca933767ae9da
DIST libinput-1.3.3.tar.xz 881992 SHA256 30c8edfe47654a38c235ac6b0541d79fd593d010bc18cdda8bd1f6cc6ad8b1ce SHA512 3acfa15ed39bb59fb18e3587718714eb277144069938c609b99a7b861e2fad85426cff840e3914552e98c2d06c010755f82fca705bab211195735a7753e191e9 WHIRLPOOL 928ffc16337e1ab49e577a05b85ddecfa037be2c0d3028d5aad2fc89cc82f30cba312500765d96661248e94b396888819ce4a3d63e6bfc93637575aef496ddcd
DIST libinput-1.4.0.tar.xz 901316 SHA256 76ef10874519d1a67b57e5c68ede06106b9fbf611a3ecf69c84886107c67b420 SHA512 1b9922c5f528df5dbcaa8ed5376c8b36a0e3f5108a9012fc2e3811ff9fdab7c814fc63c4c0404ac26cbf925db45a6fbd8c7bf5ec288a795b2e7123c315b20765 WHIRLPOOL 40c4f9da1cede78875244fe0602339ada5ec3d31cdf427d8c78fa9c920967841d3e81da5354c417119bd28f557da1115ac22888018fd4faacda857d3d9a58f5e
+DIST libinput-1.4.2.tar.xz 900776 SHA256 8c38826a785594811bef6a9daadbfa2e172e3f070f8863393d6fb7ca4c68e451 SHA512 ecd1ddc737b8207d9e494f809340e2c0ac2927db80cf4c325ba12fb84387138d0128df7e841c87feafe425d6382f87f123f28531f7045fbcdd1176559895b79b WHIRLPOOL 99f18e00e2a4a284b7995f677053501989b526e16f41e508023638a1c0e660940d0cb991f399480a30a49073063aab1651e52bdea7861266300d9db885806ac4
diff --git a/dev-libs/libinput/libinput-1.4.2.ebuild b/dev-libs/libinput/libinput-1.4.2.ebuild
new file mode 100644
index 000000000000..8ec94bd29692
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.4.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}