summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2015-10-12 17:58:09 +0200
committerSebastian Pipping <sping@gentoo.org>2015-10-12 17:58:15 +0200
commit91193fef82f0d5f01f043742a735935a14eb02e4 (patch)
treee85da1105145d054adef71c7dea17d4aacaab663 /dev-libs
parentnet-mail/dovecot: version bump to 2.2.19 (diff)
downloadgentoo-91193fef82f0d5f01f043742a735935a14eb02e4.tar.gz
gentoo-91193fef82f0d5f01f043742a735935a14eb02e4.tar.bz2
gentoo-91193fef82f0d5f01f043742a735935a14eb02e4.zip
dev-libs/uriparser: 0.8.4
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/uriparser/uriparser-0.8.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/uriparser/uriparser-0.8.4.ebuild b/dev-libs/uriparser/uriparser-0.8.4.ebuild
new file mode 100644
index 000000000000..a52452d55d6d
--- /dev/null
+++ b/dev-libs/uriparser/uriparser-0.8.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
+HOMEPAGE="http://uriparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc qt4 test unicode"
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.5.8
+ qt4? ( dev-qt/qthelp:4 ) )
+ test? ( >=dev-util/cpptest-1.1.1 )"
+
+REQUIRED_USE="test? ( unicode )"
+
+src_configure() {
+ econf \
+ --disable-sizedown \
+ $(use_enable test) \
+ --enable-char \
+ $(use_enable unicode wchar_t) \
+ $(use_enable doc) \
+ --docdir=/usr/share/doc/${PF}/
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog THANKS
+
+ if use doc && use qt4; then
+ dodoc doc/*.qch
+ docompress -x /usr/share/doc/${PF}/${P}.qch
+ fi
+}