summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-09 22:08:50 +0000
committerSam James <sam@gentoo.org>2021-05-09 22:09:33 +0000
commit94c5fdde92104a42fba127ea0c0442f7a0b345a2 (patch)
treec1937783e34816d8ae15094a832b38be214fcb08 /dev-libs
parentdev-cpp/eigen: Drop 3.3.8-r1, overshadowed by 3.3.9 (diff)
downloadgentoo-94c5fdde92104a42fba127ea0c0442f7a0b345a2.tar.gz
gentoo-94c5fdde92104a42fba127ea0c0442f7a0b345a2.tar.bz2
gentoo-94c5fdde92104a42fba127ea0c0442f7a0b345a2.zip
dev-libs/botan: add 2.18.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/botan/Manifest2
-rw-r--r--dev-libs/botan/botan-2.18.1.ebuild164
2 files changed, 166 insertions, 0 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 5509e2815c24..0df8aa5911d2 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,3 +1,5 @@
DIST Botan-2.17.3.tar.xz 5937596 BLAKE2B 605e71c959889b459bc26f17d310a33f26c9a51fe00db91db407ac5b96c9ff57bef67a401f71826e83e0d4eda2289c22685957289e6bb357f3693a1bce60f44d SHA512 ead0f144dfb9eca66d0e81e376d0d49f4b0b6bc1599f8cf52299e1753645b5b20100efa004ef5f9571f7bea88958f35db38367fc26f2603890f8f199cc890dbc
DIST Botan-2.18.0.tar.xz 5941536 BLAKE2B 2a4182bab5e681fdfeafa113462bf5a31057d7be97d71d0a6e60975b84432dd3932498f42f0b879e216727df4bbfcbf0d844e971df95eaf9cf922280f32858b4 SHA512 8613412e3e2fe8b787db7a4d4dbadf60b8fe6b68a84408c600c37cd0b5dbdf3f347a49f5bd88eb8d4f658e927a8b976884146551bf7d256fa80e9675297c0f09
DIST Botan-2.18.0.tar.xz.asc 488 BLAKE2B b9a9c98e11eae227fb900cae2dca3aecc2114ecacd87336cf5cdbe6fbcb9676514f11e365e94dbfecf3b9edc1a9a3398ff2c66f34a77d7b4d6b0f87518af6d9a SHA512 f2e1689e10b0706eed5a3cf08dfcb163874d3ada12968ac739eeff259ae81b1329fafdae4d29290195276fe3bb1cdeaf3f302b8df53a377c5bbdb7964deaa044
+DIST Botan-2.18.1.tar.xz 5953936 BLAKE2B 82f6a9563377542d059901adec0fc17a41b0184cf59af76084babec2591830314a4d7f8d3308eb393c4910c9b0e6c056625765f0d95b435f47dc94cf4b83b128 SHA512 2f11d1ab703d977a2d64504d2a2489ce56109a2a6c46c0dc7c8db428470ce511bcc0160f70baedad29237abd5e1622f2c155ea58c4dec4d3ae57ee7b350415c3
+DIST Botan-2.18.1.tar.xz.asc 488 BLAKE2B d7e6f18ba969b1fffe5aec27ec28839bb6eefac438b0971bb24293a9a1dc104d4355feaae4f8749ea9ea9a729e9f0c0368782c60c2f1aaed58620624248d09d2 SHA512 0cb24d544e31f347e649661d28fedaad4352cd5096ad41e1513c7915138981c7c099e4ee6025893ed829a65082aaded738a94018a8e0bc079f4f0fb63bbec262
diff --git a/dev-libs/botan/botan-2.18.1.ebuild b/dev-libs/botan/botan-2.18.1.ebuild
new file mode 100644
index 000000000000..4d9fc251745d
--- /dev/null
+++ b/dev-libs/botan/botan-2.18.1.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/botan.asc"
+inherit python-r1 toolchain-funcs verify-sig
+
+MY_P="Botan-${PV}"
+DESCRIPTION="C++ crypto library"
+HOMEPAGE="https://botan.randombit.net/"
+SRC_URI="https://botan.randombit.net/releases/${MY_P}.tar.xz"
+SRC_URI+=" verify-sig? ( https://botan.randombit.net/releases/${MY_P}.tar.xz.asc )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="2/$(ver_cut 1-2)" # soname version
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="bindist doc boost bzip2 lzma python ssl static-libs sqlite zlib"
+
+CPU_USE=(
+ cpu_flags_arm_{aes,neon}
+ cpu_flags_ppc_altivec
+ cpu_flags_x86_{aes,avx2,popcnt,rdrand,sse2,ssse3,sse4_1,sse4_2}
+)
+
+IUSE+=" ${CPU_USE[@]}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# NOTE: Boost is needed at runtime too for the CLI tool.
+DEPEND="
+ boost? ( >=dev-libs/boost-1.48:= )
+ bzip2? ( >=app-arch/bzip2-1.0.5:= )
+ lzma? ( app-arch/xz-utils:= )
+ python? ( ${PYTHON_DEPS} )
+ ssl? ( dev-libs/openssl:0=[bindist=] )
+ sqlite? ( dev-db/sqlite:3= )
+ zlib? ( >=sys-libs/zlib-1.2.3:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ')
+ verify-sig? ( app-crypt/openpgp-keys-botan )
+"
+
+# NOTE: Considering patching Botan?
+# Please see upstream's guidance:
+# https://botan.randombit.net/handbook/packaging.html#minimize-distribution-patches
+
+python_check_deps() {
+ if use doc ; then
+ has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+src_configure() {
+ local disable_modules=(
+ $(usex boost '' 'boost')
+ $(usex bindist 'ecdsa' '')
+ )
+
+ if [[ -z "${DISABLE_MODULES}" ]] ; then
+ elog "Disabling module(s): ${disable_modules[@]}"
+ fi
+
+ local chostarch="${CHOST%%-*}"
+
+ # Arch specific wrangling
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*)
+ myos=darwin
+ ;;
+
+ *)
+ myos=linux
+
+ if [[ ${CHOST} == *hppa* ]] ; then
+ chostarch=parisc
+ elif [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
+ chostarch="sparc32-v9"
+ fi
+ ;;
+
+ esac
+
+ local pythonvers=()
+ if use python ; then
+ _append() {
+ pythonvers+=( ${EPYTHON/python/} )
+ }
+
+ python_foreach_impl _append
+ fi
+
+ local myargs=(
+ # Intrinsics
+ # TODO: x86 RDSEED (new CPU_FLAGS_X86?)
+ # TODO: POWER Crypto (new CPU_FLAGS_PPC?)
+ $(usex cpu_flags_arm_aes '' '--disable-armv8crypto')
+ $(usex cpu_flags_arm_neon '' '--disable-neon')
+ $(usex cpu_flags_ppc_altivec '' '--disable-altivec')
+ $(usex cpu_flags_x86_aes '' '--disable-aes-ni')
+ $(usex cpu_flags_x86_avx2 '' '--disable-avx2')
+ $(usex cpu_flags_x86_popcnt '' '--disable-bmi2')
+ $(usex cpu_flags_x86_rdrand '' '--disable-rdrand')
+ $(usex cpu_flags_x86_sse2 '' '--disable-sse2')
+ $(usex cpu_flags_x86_ssse3 '' '--disable-ssse3')
+ $(usex cpu_flags_x86_sse4_1 '' '--disable-sse4.1')
+ $(usex cpu_flags_x86_sse4_2 '' '--disable-sse4.2')
+
+ $(usex hppa --without-stack-protector '')
+
+ $(use_with boost)
+ $(use_with bzip2)
+ $(use_with doc documentation)
+ $(use_with doc sphinx)
+ $(use_with lzma)
+ $(use_enable static-libs static-library)
+ $(use_with ssl openssl)
+ $(use_with sqlite sqlite3)
+ $(use_with zlib)
+
+ --cpu=${chostarch}
+ --docdir=share/doc
+ --disable-modules=$( IFS=","; echo "${disable_modules[*]}" )
+ --distribution-info="Gentoo ${PVR}"
+ --libdir=$(get_libdir)
+
+ # Don't install Python bindings automatically
+ # (do it manually later in the right place)
+ # https://bugs.gentoo.org/723096
+ --no-install-python-module
+
+ --os=${myos}
+ --prefix="${EPREFIX}/usr"
+ --with-endian="$(tc-endian)"
+ --with-python-version=$( IFS=","; echo "${pythonvers[*]}" )
+ --without-doxygen
+ )
+
+ tc-export CC CXX AR
+
+ ./configure.py "${myargs[@]}" || die "configure.py failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+}
+
+src_install() {
+ default
+
+ # Manually install the Python bindings (bug #723096)
+ if use python ; then
+ python_foreach_impl python_domodule src/python/botan2.py
+ fi
+}