summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-10-25 09:42:00 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-10-25 09:42:00 -0400
commit97a6f1c945aef15774aba257fd9088bf5c5013ad (patch)
treeea1d4aa908657427c5ffc4231e4a4fa2c6d3079a /dev-libs
parentnet-misc/wol: Clang 16 fixes (diff)
downloadgentoo-97a6f1c945aef15774aba257fd9088bf5c5013ad.tar.gz
gentoo-97a6f1c945aef15774aba257fd9088bf5c5013ad.tar.bz2
gentoo-97a6f1c945aef15774aba257fd9088bf5c5013ad.zip
dev-libs/ppl: drop 1.2-r4
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ppl/ppl-1.2-r4.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-libs/ppl/ppl-1.2-r4.ebuild b/dev-libs/ppl/ppl-1.2-r4.ebuild
deleted file mode 100644
index 6ce0fa97ee98..000000000000
--- a/dev-libs/ppl/ppl-1.2-r4.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="The Parma Polyhedra Library for numerical analysis of complex systems"
-HOMEPAGE="http://bugseng.com/products/ppl"
-SRC_URI="http://bugseng.com/products/ppl/download/ftp/releases/${PV}/${P}.tar.xz
- https://dev.gentoo.org/~juippis/distfiles/tmp/ppl-1.2-r3-disable-boeing-tests.patch"
-
-LICENSE="GPL-3"
-SLOT="0/4.14" # SONAMEs
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~sparc-solaris"
-IUSE="cdd +cxx doc lpsol pch static-libs test"
-
-RDEPEND=">=dev-libs/gmp-6[cxx(+)]
- lpsol? ( sci-mathematics/glpk )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- sys-devel/m4"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/disable-mipproblem2.patch"
- "${FILESDIR}/disable-containsintegerpoint1.patch"
- "${DISTDIR}/ppl-1.2-r3-disable-boeing-tests.patch"
- "${FILESDIR}/fix-clang-build.patch"
-)
-
-src_prepare() {
- default
-
- # The patch should do this, but then the diff makes it run
- # afoul of the Gentoo patch size limit.
- rm demos/ppl_lpsol/examples/boeing[12].mps || die
-
- eautoreconf
-}
-
-src_configure() {
- local interfaces=( c )
- use cxx && interfaces+=( cxx )
- econf \
- --disable-debugging \
- --disable-optimization \
- $(use_enable doc documentation) \
- $(use_enable cdd ppl_lcdd) \
- $(use_enable lpsol ppl_lpsol) \
- $(use_enable pch) \
- $(use_enable static-libs static) \
- --enable-interfaces="${interfaces[*]}" \
- $(use test && echo --enable-check=quick)
-}
-
-src_install() {
- default
- if ! use static-libs; then
- find "${ED}"/usr -name 'libppl*.la' -delete || die
- fi
-
- pushd "${ED}/usr/share/doc/${PF}" >/dev/null || die
- rm gpl* fdl* || die
- if ! use doc ; then
- rm -r *-html/ *.ps.gz *.pdf || die
- fi
-}