summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-06-07 09:59:09 -0700
committerMatt Turner <mattst88@gentoo.org>2018-06-07 09:59:36 -0700
commit984aeb36130e302a44907a2c29d835b57127d55f (patch)
tree6b1a8d5556bd046bd8d07562e6af3a8044e47ad9 /dev-libs
parentkde-misc/kmarkdownwebview: 0.5.3 version bump (diff)
downloadgentoo-984aeb36130e302a44907a2c29d835b57127d55f.tar.gz
gentoo-984aeb36130e302a44907a2c29d835b57127d55f.tar.bz2
gentoo-984aeb36130e302a44907a2c29d835b57127d55f.zip
dev-libs/libinput: Restore version 1.10.6
This reverts commit 913b01c6a2adcdce78aceb272c105bc1f4eb63b4. Bug: https://bugs.gentoo.org/657520
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.10.6.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 149e8df4e41a..807098601ecf 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,2 +1,3 @@
+DIST libinput-1.10.6.tar.xz 495536 BLAKE2B 3f23808635406eeb66cd6b4ce2a2dbaed69ee0917045f75ad262a59702d72923493b6faa7951ea3f7cc2591d4c9e1fc49cffc53b6dfbcb2aadc7b9f40c20517b SHA512 b76963c3429c5590ee04f1da94d08775c8bb8584830e678804fb1d4cf0e2af84826782eae71fdd57492461f85df87ac2fc940c280b0672c75cd81d5f34702fe4
DIST libinput-1.10.7.tar.xz 494648 BLAKE2B ddcbe5f54b90f8291c16e5912fa3d673fb2c66f0247c9d771f7c2dfeeef9b51404f31d7ac99cfd20b37e1d01d6b2b3bc95155ab6581c6a94e922e153d9098892 SHA512 b102b8065ceed7511ad26efba34d5d9b0c13f0f7aaa882bb21501f7a5166f4cbe140fcbb488e90e6880bd47bb2b27667a4d6aa79b8726269fa1337897034a684
DIST libinput-1.11.0.tar.xz 485976 BLAKE2B f0bd88463b6aba7bfcf80d3354e53fe86e367a29055e295621d84175720544af035cc6303a2777d6ac4535d4706c41fa435a3a5a3abd20eb9ad33366dad4eae8 SHA512 382a6c9ec4aaf13ac209ee5a7f507c7a6d2dd399c5104703ac7c6ac62fb3f393de6f4e15d7895b18c8b8d845ce8fc1f551a90aa7532f0de4cc17e57a09cfe857
diff --git a/dev-libs/libinput/libinput-1.10.6.ebuild b/dev-libs/libinput/libinput-1.10.6.ebuild
new file mode 100644
index 000000000000..9e10a1005467
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.10.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit meson udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="doc input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ -Ddocumentation="$(usex doc true false)"
+ -Dlibwacom="$(usex input_devices_wacom true false)"
+ -Dtests="$(usex test true false)"
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/html/.
+ fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}