summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 21:40:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 21:58:50 +0100
commit9d235fd5927b38ca008e04941ca640ef8a09603e (patch)
tree96727f7fb4803b2ca36c35403178c76a01061086 /dev-libs
parentx11-misc/spnavcfg: 1.1 + EAPI 8 (diff)
downloadgentoo-9d235fd5927b38ca008e04941ca640ef8a09603e.tar.gz
gentoo-9d235fd5927b38ca008e04941ca640ef8a09603e.tar.bz2
gentoo-9d235fd5927b38ca008e04941ca640ef8a09603e.zip
dev-libs/libwbxml: drop 0.11.7, 0.11.7-r1
Closes: https://bugs.gentoo.org/887499 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libwbxml/Manifest1
-rw-r--r--dev-libs/libwbxml/files/libwbxml-0.11.7-expat-compat-fixes.patch116
-rw-r--r--dev-libs/libwbxml/libwbxml-0.11.7-r1.ebuild37
-rw-r--r--dev-libs/libwbxml/libwbxml-0.11.7.ebuild33
4 files changed, 0 insertions, 187 deletions
diff --git a/dev-libs/libwbxml/Manifest b/dev-libs/libwbxml/Manifest
index 8fddd78e5437..0eb3efae0e0b 100644
--- a/dev-libs/libwbxml/Manifest
+++ b/dev-libs/libwbxml/Manifest
@@ -1,2 +1 @@
-DIST libwbxml-0.11.7.tar.gz 427429 BLAKE2B 1ec456032d4d343f5b11c60dfe5fa5dfb8750c87f1e05c48b1671257822ce7ec121a7006ed9749aacd84d4ce9f5dfa0c358cf3f3581a4a24a34db1c91338f74a SHA512 fc855650661593596a158527682d2c40d800c1fa44169d79e9ca9c6d64d67b6c660807ed89b1bddd644f114c27711356627ac919af91fd7f19d409879505512f
DIST libwbxml-0.11.8.tar.gz 362833 BLAKE2B 8501a578c1937097a7f0993baf0bed1d645d14441fca149142a8d338f9b6aece7f726576d9170dfc298388c66937d8a6549d52ed75305cab2c427c82b1331dfd SHA512 14b74e3d25f21ce4bf05f4ed546087817c698b5a44190c569b7691e26510b117118bf828e15beccaa4bdd2e744c45f9b5695b38eb7994f3af0f4f81f90ecff69
diff --git a/dev-libs/libwbxml/files/libwbxml-0.11.7-expat-compat-fixes.patch b/dev-libs/libwbxml/files/libwbxml-0.11.7-expat-compat-fixes.patch
deleted file mode 100644
index 00479c7f6437..000000000000
--- a/dev-libs/libwbxml/files/libwbxml-0.11.7-expat-compat-fixes.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-https://github.com/libwbxml/libwbxml/commit/4664d476fb5029073012b91880ce2a9bbc0b4725
-https://github.com/libwbxml/libwbxml/commit/4425e80f74b93a590b2c99638b9c5095e6a66244
-
-From: =?UTF-8?q?Sl=C3=A1vek=20Banko?= <slavek.banko@axis.cz>
-Date: Thu, 24 Feb 2022 20:30:18 +0100
-Subject: [PATCH] Allow the use of a namespace separator specified by the
- constant instead of hardcoded colon in the SyncML related code.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
---- a/src/wbxml_internals.h
-+++ b/src/wbxml_internals.h
-@@ -156,7 +156,9 @@ typedef enum WBXMLWVDataType_e {
- #pragma warning(error: 4761) /**< integral size mismatch in argument : conversion supplied */
- #endif /* WIN32 */
-
--#define WBXML_NAMESPACE_SEPARATOR ':'
-+/* Separator must be the same in both cases - once as a char, once as a string */
-+#define WBXML_NAMESPACE_SEPARATOR ':'
-+#define WBXML_NAMESPACE_SEPARATOR_STR ":"
-
- /** @} */
-
---- a/src/wbxml_tree_clb_xml.c
-+++ b/src/wbxml_tree_clb_xml.c
-@@ -33,6 +33,7 @@
- * @brief WBXML Tree Callbacks for XML Parser (Expat)
- */
-
-+#include "wbxml_internals.h"
- #include "wbxml_config_internals.h"
-
- #if defined( HAVE_EXPAT )
-@@ -160,8 +161,8 @@ void wbxml_tree_clb_xml_start_element(void *ctx,
- * potentially embedded documents.
- */
- if ((
-- (WBXML_STRCMP(localName, "syncml:devinf:DevInf") == 0) ||
-- (WBXML_STRCMP(localName, "syncml:dmddf1.2:MgmtTree") == 0)
-+ (WBXML_STRCMP(localName, "syncml:devinf" WBXML_NAMESPACE_SEPARATOR_STR "DevInf") == 0) ||
-+ (WBXML_STRCMP(localName, "syncml:dmddf1.2" WBXML_NAMESPACE_SEPARATOR_STR "MgmtTree") == 0)
- )&&
- (tree_ctx->current != NULL))
- {
-@@ -255,8 +256,8 @@ void wbxml_tree_clb_xml_end_element(void *ctx,
- /* End of skipped node */
-
- #if defined( WBXML_SUPPORT_SYNCML )
-- if (WBXML_STRCMP(localName, "syncml:devinf:DevInf") == 0 ||
-- WBXML_STRCMP(localName, "syncml:dmddf1.2:MgmtTree") == 0) {
-+ if (WBXML_STRCMP(localName, "syncml:devinf" WBXML_NAMESPACE_SEPARATOR_STR "DevInf") == 0 ||
-+ WBXML_STRCMP(localName, "syncml:dmddf1.2" WBXML_NAMESPACE_SEPARATOR_STR "MgmtTree") == 0) {
- /* definitions first ... or some compilers don't like it */
- WBXMLBuffer *embed_doc = NULL;
- WBXMLTree *tree = NULL;
-@@ -277,10 +278,10 @@ void wbxml_tree_clb_xml_end_element(void *ctx,
- }
-
- /* Check Buffer Creation and add the closing tag */
-- if ((WBXML_STRCMP(localName, "syncml:devinf:DevInf") == 0 &&
-+ if ((WBXML_STRCMP(localName, "syncml:devinf" WBXML_NAMESPACE_SEPARATOR_STR "DevInf") == 0 &&
- (!wbxml_buffer_append_cstr(embed_doc, "</DevInf>")))
- ||
-- (WBXML_STRCMP(localName, "syncml:dmddf1.2:MgmtTree") == 0 &&
-+ (WBXML_STRCMP(localName, "syncml:dmddf1.2" WBXML_NAMESPACE_SEPARATOR_STR "MgmtTree") == 0 &&
- (!wbxml_buffer_append_cstr(embed_doc, "</MgmtTree>"))))
- {
- tree_ctx->error = WBXML_ERROR_NOT_ENOUGH_MEMORY;
-@@ -289,7 +290,7 @@ void wbxml_tree_clb_xml_end_element(void *ctx,
- }
-
- /* Add doctype to give the XML parser a chance */
-- if (WBXML_STRCMP(localName, "syncml:dmddf1.2:MgmtTree") == 0 &&
-+ if (WBXML_STRCMP(localName, "syncml:dmddf1.2" WBXML_NAMESPACE_SEPARATOR_STR "MgmtTree") == 0 &&
- tree_ctx->tree->lang->langID != WBXML_LANG_SYNCML_SYNCML12)
- {
- tree_ctx->error = WBXML_ERROR_UNKNOWN_XML_LANGUAGE;
-@@ -305,7 +306,7 @@ void wbxml_tree_clb_xml_end_element(void *ctx,
- lang = wbxml_tables_get_table(WBXML_LANG_SYNCML_DEVINF11);
- break;
- case WBXML_LANG_SYNCML_SYNCML12:
-- if (WBXML_STRCMP(localName, "syncml:dmddf1.2:MgmtTree") == 0) {
-+ if (WBXML_STRCMP(localName, "syncml:dmddf1.2" WBXML_NAMESPACE_SEPARATOR_STR "MgmtTree") == 0) {
- lang = wbxml_tables_get_table(WBXML_LANG_SYNCML_DMDDF12);
- } else {
- lang = wbxml_tables_get_table(WBXML_LANG_SYNCML_DEVINF12);
-
-From: =?UTF-8?q?Sl=C3=A1vek=20Banko?= <slavek.banko@axis.cz>
-Date: Thu, 24 Feb 2022 20:31:15 +0100
-Subject: [PATCH] Change the default internal namespace separator from the
- colon to the pipe.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This solves compatibility with libexpat >= 2.4.5
-after fix the security problem CVE-2022-25236.
-
-This resolves issue #76.
-
-Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
---- a/src/wbxml_internals.h
-+++ b/src/wbxml_internals.h
-@@ -157,8 +157,8 @@ typedef enum WBXMLWVDataType_e {
- #endif /* WIN32 */
-
- /* Separator must be the same in both cases - once as a char, once as a string */
--#define WBXML_NAMESPACE_SEPARATOR ':'
--#define WBXML_NAMESPACE_SEPARATOR_STR ":"
-+#define WBXML_NAMESPACE_SEPARATOR '|'
-+#define WBXML_NAMESPACE_SEPARATOR_STR "|"
-
- /** @} */
-
diff --git a/dev-libs/libwbxml/libwbxml-0.11.7-r1.ebuild b/dev-libs/libwbxml/libwbxml-0.11.7-r1.ebuild
deleted file mode 100644
index d351e183714d..000000000000
--- a/dev-libs/libwbxml/libwbxml-0.11.7-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Library and tools to parse, encode and handle WBXML documents"
-HOMEPAGE="https://github.com/libwbxml/libwbxml"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-libs/expat
- virtual/libiconv"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )"
-
-DOCS=( BUGS ChangeLog README References THANKS TODO )
-S=${WORKDIR}/${PN}-${P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-expat-compat-fixes.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_INSTALL_DOC=OFF
- -DENABLE_UNIT_TEST=$(usex test)
- )
-
- cmake_src_configure
-}
diff --git a/dev-libs/libwbxml/libwbxml-0.11.7.ebuild b/dev-libs/libwbxml/libwbxml-0.11.7.ebuild
deleted file mode 100644
index a36bf18136e4..000000000000
--- a/dev-libs/libwbxml/libwbxml-0.11.7.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Library and tools to parse, encode and handle WBXML documents"
-HOMEPAGE="https://github.com/libwbxml/libwbxml"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-libs/expat
- virtual/libiconv"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )"
-
-DOCS=( BUGS ChangeLog README References THANKS TODO )
-S=${WORKDIR}/${PN}-${P}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_INSTALL_DOC=OFF
- -DENABLE_UNIT_TEST=$(usex test)
- )
-
- cmake_src_configure
-}