summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-01-19 10:17:49 -0500
committerBrian Evans <grknight@gentoo.org>2018-01-19 10:17:49 -0500
commita42f289d6ee90f6598147d1679c069754a9577da (patch)
treefde2fd4b135cc1d71f2a65b42887637687f8fdf1 /dev-libs
parentdev-util/sysdig: Bump to 0.20.0 (diff)
downloadgentoo-a42f289d6ee90f6598147d1679c069754a9577da.tar.gz
gentoo-a42f289d6ee90f6598147d1679c069754a9577da.tar.bz2
gentoo-a42f289d6ee90f6598147d1679c069754a9577da.zip
dev-libs/legousbtower: Revbump for EAPI and eclass
Previously, it looked in the linux-mod eclass to check KV_MINOR = 4 as it expected 2.x to still be current. Now it uses the modern linux-info eclass and compares with kernel_is Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/legousbtower/legousbtower-0.5.4-r1.ebuild (renamed from dev-libs/legousbtower/legousbtower-0.5.4.ebuild)24
1 files changed, 15 insertions, 9 deletions
diff --git a/dev-libs/legousbtower/legousbtower-0.5.4.ebuild b/dev-libs/legousbtower/legousbtower-0.5.4-r1.ebuild
index 4f09ec70ef7f..f8553d8ef6fb 100644
--- a/dev-libs/legousbtower/legousbtower-0.5.4.ebuild
+++ b/dev-libs/legousbtower/legousbtower-0.5.4-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit linux-mod
+EAPI=6
+
+inherit linux-info
DESCRIPTION="The lego mindstorms usb tower headers and/or modules"
SRC_URI="mirror://sourceforge/legousb/${P}.tar.gz"
@@ -9,20 +11,24 @@ HOMEPAGE="http://legousb.sourceforge.net/"
SLOT="0"
LICENSE="MPL-1.0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
+src_configure() {
+ if kernel_is -lt 2 5 ; then
+ econf
+ fi
+}
src_compile()
{
- if [ ${KV_MINOR} -eq 4 ] ; then
- econf || die "Configuration failed"
- emake || die "Compilation failed"
+ if kernel_is -lt 2 5 ; then
+ emake
fi
}
src_install() {
- if [ ${KV_MINOR} -eq 4 ] ; then
- einstall || die "Make Install Failed"
+ if kernel_is -lt 2 5 ; then
+ einstall
else
insinto /usr/include/LegoUSB
doins include/legousbtower.h
@@ -33,7 +39,7 @@ src_install() {
}
pkg_postinst() {
- if [ ${KV_MINOR} -eq 4 ] ; then
+ if kernel_is -lt 2 5 ; then
elog "You are using the 2.4 kernel series."
elog "These are unsupported."
else