summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-08 16:51:42 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-08 16:52:15 -0500
commitabe95f7952f00bf0340c8708e458d65002e1bb5a (patch)
treeb1aa69da3ecea12fae15550ffac44e3891aaa50e /dev-libs
parentdev-libs/DirectFB: update homepage to .net (diff)
downloadgentoo-abe95f7952f00bf0340c8708e458d65002e1bb5a.tar.gz
gentoo-abe95f7952f00bf0340c8708e458d65002e1bb5a.tar.bz2
gentoo-abe95f7952f00bf0340c8708e458d65002e1bb5a.zip
dev-libs/DirectFB: fix tslib detection #567294
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/DirectFB/DirectFB-1.7.6.ebuild3
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.7.6-tslib.patch33
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-libs/DirectFB/DirectFB-1.7.6.ebuild b/dev-libs/DirectFB/DirectFB-1.7.6.ebuild
index 7e56b85c7c6a..fdb99b17576c 100644
--- a/dev-libs/DirectFB/DirectFB-1.7.6.ebuild
+++ b/dev-libs/DirectFB/DirectFB-1.7.6.ebuild
@@ -77,7 +77,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.6.3-setregion.patch \
"${FILESDIR}"/${PN}-1.6.3-atomic-fix-compiler-error-when-building-for-thumb2.patch \
"${FILESDIR}"/${PN}-1.7.6-cle266.patch \
- "${FILESDIR}"/${PN}-1.7.6-idivine.patch
+ "${FILESDIR}"/${PN}-1.7.6-idivine.patch \
+ "${FILESDIR}"/${PN}-1.7.6-tslib.patch
sed -i \
-e '/#define RASPBERRY_PI/d' \
systems/egl/egl_system.c || die #497124
diff --git a/dev-libs/DirectFB/files/DirectFB-1.7.6-tslib.patch b/dev-libs/DirectFB/files/DirectFB-1.7.6-tslib.patch
new file mode 100644
index 000000000000..3315968bc092
--- /dev/null
+++ b/dev-libs/DirectFB/files/DirectFB-1.7.6-tslib.patch
@@ -0,0 +1,33 @@
+https://github.com/deniskropp/DirectFB/pull/6
+https://bugs.gentoo.org/567294
+
+From 5c7c4b197b9d04587b05624db4cfca6503adb3ff Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 8 Dec 2016 16:47:34 -0500
+Subject: [PATCH] configure: fix tslib version check
+
+The tslib version is 1.0, not 1.0.0. Trying to check for the latter
+fails when using pkg-config:
+$ pkg-config --exists --print-errors "tslib-1.0 >= 1.0"
+$ pkg-config --exists --print-errors "tslib-1.0 >= 1.0.0"
+Requested 'tslib-1.0 >= 1.0.0' but version of tslib is 1.0
+---
+ configure.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.in b/configure.in
+index 6143cd393699..12a65fdc4f52 100644
+--- a/configure.in
++++ b/configure.in
+@@ -2561,7 +2561,7 @@ fi
+
+ enable_tslib=no
+ if test "$checkfor_tslib" = "yes"; then
+- PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0], [enable_tslib=yes], [enable_tslib=no])
+ if test "$enable_tslib" = "no"; then
+ PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no
+ AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
+--
+2.11.0.rc2
+