summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-27 11:47:38 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-27 12:28:07 -0500
commitae36bdfc3dd2e202c667540d0576a3c89e82cf22 (patch)
treee4bfcae611d78512fcc23dc3f5fc003db5682a40 /dev-libs
parentdev-libs/univalue: 1.0.4 version bump (diff)
downloadgentoo-ae36bdfc3dd2e202c667540d0576a3c89e82cf22.tar.gz
gentoo-ae36bdfc3dd2e202c667540d0576a3c89e82cf22.tar.bz2
gentoo-ae36bdfc3dd2e202c667540d0576a3c89e82cf22.zip
dev-libs/univalue: Add -9999 live version
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/univalue/univalue-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/univalue/univalue-9999.ebuild b/dev-libs/univalue/univalue-9999.ebuild
new file mode 100644
index 000000000000..989d23ce6cce
--- /dev/null
+++ b/dev-libs/univalue/univalue-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C++ universal value object and JSON library"
+HOMEPAGE="https://github.com/jgarzik/univalue"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/jgarzik/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://codeload.github.com/jgarzik/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}