summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-18 20:10:58 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-18 20:10:58 +0100
commitb494f3adc4171d519211345b7e3abe29e5dfe9c5 (patch)
treed90b5fee7b7e3922085689165038e599d6e3d9da /dev-libs
parentdev-libs/libg15: Port to EAPI 7 (diff)
downloadgentoo-b494f3adc4171d519211345b7e3abe29e5dfe9c5.tar.gz
gentoo-b494f3adc4171d519211345b7e3abe29e5dfe9c5.tar.bz2
gentoo-b494f3adc4171d519211345b7e3abe29e5dfe9c5.zip
dev-libs/libee: Port to EAPI 7
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libee/libee-0.4.1.ebuild31
1 files changed, 17 insertions, 14 deletions
diff --git a/dev-libs/libee/libee-0.4.1.ebuild b/dev-libs/libee/libee-0.4.1.ebuild
index 266f15686957..c00d1015be58 100644
--- a/dev-libs/libee/libee-0.4.1.ebuild
+++ b/dev-libs/libee/libee-0.4.1.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit autotools-utils
+EAPI=7
DESCRIPTION="An Event Expression Library inspired by CEE"
HOMEPAGE="http://www.libee.org"
@@ -12,22 +10,27 @@ SRC_URI="http://www.libee.org/files/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 hppa x86 ~amd64-linux"
-IUSE="debug static-libs"
+IUSE="debug"
-DEPEND="dev-libs/libxml2
+RDEPEND="
+ dev-libs/libxml2
dev-libs/libestr"
-RDEPEND="${DEPEND}"
-
-DOCS=(INSTALL ChangeLog)
+DEPEND="${RDEPEND}"
src_configure() {
- local myeconfargs=(
+ econf \
+ --disable-static \
+ --enable-testbench \
$(use_enable debug)
- --enable-testbench
- )
- autotools-utils_src_configure
}
src_compile() {
- autotools-utils_src_compile -j1
+ emake -j1
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}