summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 14:00:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 14:35:07 +0200
commitba900f6dfec4cdd31b9146cae36b82eb08914c7d (patch)
tree46839df7d88607faeb7fab86e99baccde22eadb9 /dev-libs
parentapp-crypt/libmd: EAPI-8 bump, multilib support (diff)
downloadgentoo-ba900f6dfec4cdd31b9146cae36b82eb08914c7d.tar.gz
gentoo-ba900f6dfec4cdd31b9146cae36b82eb08914c7d.tar.bz2
gentoo-ba900f6dfec4cdd31b9146cae36b82eb08914c7d.zip
dev-libs/libbsd: 0.11.3 version bump
Closes: https://bugs.gentoo.org/789009 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libbsd/Manifest1
-rw-r--r--dev-libs/libbsd/libbsd-0.11.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index 5a70770bb835..d24a2a7fc16d 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1 +1,2 @@
DIST libbsd-0.10.0.tar.xz 393576 BLAKE2B 66005a511dae7fb799322c813b8ea058ab460e3b9044756d6efad5de741d8f70270496f09803bbce8cd0000ff37e998f18e092037c850826c3c8e3f47ddfdb28 SHA512 b75529785b16c93d31401187f8a58258fbebe565dac071c8311775c913af989f62cd29d5ce2651af3ea6221cffd31cf04826577d3e546ab9ca14340f297777b9
+DIST libbsd-0.11.3.tar.xz 399712 BLAKE2B 1af04b8fcbc0bfa59fba549639d61a33ac934fe7ee42b506d1b0452e0b836b0bfdd3d8739de90465be46fe6a9d326a2d11bcf72280aa19ccba81db5da6d63d89 SHA512 a7015ea1ffa3766b1a4690526a25231898ad8275149b31fb6801082450172249997c36165626d101ffce53b59767a46676eebc0806426922fe4e773a0376c1f5
diff --git a/dev-libs/libbsd/libbsd-0.11.3.ebuild b/dev-libs/libbsd/libbsd-0.11.3.ebuild
new file mode 100644
index 000000000000..d9667f872ea7
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.11.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="https://libbsd.freedesktop.org/wiki/ https://gitlab.freedesktop.org/libbsd/libbsd"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-crypt/libmd[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-3.17
+"
+
+pkg_setup() {
+ local f="${EROOT}/usr/$(get_libdir)/${PN}.a"
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # https://gitlab.freedesktop.org/libbsd/libbsd/commit/c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ find "${ED}" -type f -name "*.la" -delete || die
+}