summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-23 16:37:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-24 13:07:16 +0200
commitc61a904c47d6c311e2fd04e58df89a6e77233ffb (patch)
treea9d01a4dee823b949b39082425828dfc30d4fe97 /dev-libs
parentmedia-video/libva-utils: Bump to 1.8.2 and disable Werror (diff)
downloadgentoo-c61a904c47d6c311e2fd04e58df89a6e77233ffb.tar.gz
gentoo-c61a904c47d6c311e2fd04e58df89a6e77233ffb.tar.bz2
gentoo-c61a904c47d6c311e2fd04e58df89a6e77233ffb.zip
dev-libs/capnproto: Bump to 0.6.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/capnproto/Manifest1
-rw-r--r--dev-libs/capnproto/capnproto-0.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/capnproto/Manifest b/dev-libs/capnproto/Manifest
index f80a113e6d2e..df84de82cfb1 100644
--- a/dev-libs/capnproto/Manifest
+++ b/dev-libs/capnproto/Manifest
@@ -1 +1,2 @@
DIST capnproto-0.5.3.1.tar.gz 992237 SHA256 e9af9ccfcb6d61be2dca1daf75e90daea32cf6f4c7c24a19919815ce527d9ac8 SHA512 9d359d9ec2a8557ec92919becbd59f9df89633c9b4c7e078f390d02e6b9a4e5f48a1fb3cad595577b3ab7c5effc44733b0b7687002229a9b81b4495fb11c91c8 WHIRLPOOL 4474fd673b02b37f51db973f90ca56451cf8f4c1ccea87c47ed73135d13b495b4c4a6c4267c867c3bb17327585dd49f3e590f6f20536521941ee970f4da755f1
+DIST capnproto-0.6.0.tar.gz 1199198 SHA256 3b73a3dc39592a30b1bb6d00dff930e5fb277c774a1d40bf6a1aa7758c5fec74 SHA512 4882b2e5d1544517348e436600705d18b41fc82e6fc141a934ad960556ed73781c974d4a45f8c949a297edd5c95fb156fd75f1d7179666dc7ab881f98ac9e69d WHIRLPOOL 466a664f90778c28114eed94bac488c7e104b17225c9b18bd2c1835d23f3bf8ac92f6cbc2d9c123b469c786341d45eb97d881607ba2ffb590ec2fc2776fe5a7b
diff --git a/dev-libs/capnproto/capnproto-0.6.0.ebuild b/dev-libs/capnproto/capnproto-0.6.0.ebuild
new file mode 100644
index 000000000000..0bc56e3248b3
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="http://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/060"
+KEYWORDS="~amd64 ~arm"
+IUSE="static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-cpp/gtest )"
+
+S=${WORKDIR}/${P}/c++
+
+src_prepare() {
+ sed -e 's/ldconfig/true/' -i Makefile.am || die
+ sed -e 's#gtest/lib/libgtest.la gtest/lib/libgtest_main.la#-lgtest -lgtest_main#' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}