summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-03-30 06:24:50 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-03-30 06:24:50 -0400
commitc7fd85b6682637d924c0bd4d648e575990ca5654 (patch)
tree4d8f6fe6955d769d905928a77f6e960a08b40ba8 /dev-libs
parentdev-libs/xapian: version bump to 1.2.23 (diff)
downloadgentoo-c7fd85b6682637d924c0bd4d648e575990ca5654.tar.gz
gentoo-c7fd85b6682637d924c0bd4d648e575990ca5654.tar.bz2
gentoo-c7fd85b6682637d924c0bd4d648e575990ca5654.zip
dev-libs/xapian-bindings: version bump to 1.2.23
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian-bindings/Manifest1
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.2.23.ebuild203
2 files changed, 204 insertions, 0 deletions
diff --git a/dev-libs/xapian-bindings/Manifest b/dev-libs/xapian-bindings/Manifest
index 86247efb2cbf..b31f9f478142 100644
--- a/dev-libs/xapian-bindings/Manifest
+++ b/dev-libs/xapian-bindings/Manifest
@@ -1,3 +1,4 @@
DIST xapian-bindings-1.2.19.tar.xz 828904 SHA256 3b9434c6144cc347783175c92829f304e86919bbbd44f51b7b4a7148960cde17 SHA512 ac72ec35ae3b767e04e848a9782b41d74e99b6b1f795d5096373911ff549b3bf2e602a91ed0e5f7dce2e43e1dd308af710719e5a80c6a179393aac4af316de30 WHIRLPOOL 33770203390fea6f6048ebdc63cb7031f53a30be3568e3f3f6f8a25f8aa30a284347b402e360c0c2182069e3f6dab067fc5f6cd2b950f45e196afe057e4d80e3
DIST xapian-bindings-1.2.22.tar.xz 844040 SHA256 b15ca7984980a1d2aedd3378648ef5f3889cb39a047bac1522a8e5d04f0a8557 SHA512 0eec204ebb92f1230b9dbd080ad2b56ea5fa8e6170eb4354556e5790c7a7da7ba4c8475aaf86fb8f10f102a461d91590184271220626315f55c0631e73e122e0 WHIRLPOOL 05ac5b31d73f9de0c101da832ef289f6a505baa68216eba6fa0cf80df1709feef7e42c7b8f4cf9af35f775e8514c6d4b944c2acebffff10bc558a83305a637ce
+DIST xapian-bindings-1.2.23.tar.xz 885888 SHA256 19b4b56c74863c51733d8c2567272ef7f004b898cf44016711ae25bc524b2215 SHA512 4be9d103a4073a08d2481e9ddc347156d4028a1517f313861ad3664e6103e052dc1a0d07a992da3ca02599505c002d09d77c4fd886c144918aab72977e69994c WHIRLPOOL 1323e51dcd8f18f573f9338d9a013bfd370870c1fd2c0b0e3ff9d1f6b3b9154a0512d7442d7c7b1b00a70757faa218e8894a0f4fe56da88bca12ba2259cd35de
DIST xapian-bindings-1.3.4.tar.xz 1206856 SHA256 c2481c49007392ebe5f7a1bfbd88c528e329b74650a985dd3c7d3d6649d58498 SHA512 e47f0ee0a113aa3a89310ef1844a46477b8720d5caf6490c0a319ebd091307af0d9c52c76cc34c5fab6ba511128e7781f3878a38e20017040233bc9f150a9c3f WHIRLPOOL f5f0a72ca9586eefa51d880f59fc1a098fdabee89ccc8f9e0c8db345e9b55307d1fb8aabbe0a1deade387fe57ec39acce29b6966872fafcb25994105da07ebd5
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.2.23.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.2.23.ebuild
new file mode 100644
index 000000000000..12bd02614099
--- /dev/null
+++ b/dev-libs/xapian-bindings/xapian-bindings-1.2.23.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+USE_PHP="php5-5"
+
+PHP_EXT_NAME="xapian"
+PHP_EXT_INI="yes"
+PHP_EXT_OPTIONAL_USE="php"
+
+#mono violates sandbox, we disable it until we figure this out
+#inherit java-pkg-opt-2 mono-env php-ext-source-r2 python
+inherit java-pkg-opt-2 php-ext-source-r2 python-r1 toolchain-funcs
+
+DESCRIPTION="SWIG and JNI bindings for Xapian"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+#IUSE="java lua mono perl php python ruby tcl"
+#REQUIRED_USE="|| ( java lua mono perl php python ruby tcl )"
+IUSE="java lua perl php python ruby tcl"
+REQUIRED_USE="|| ( java lua perl php python ruby tcl )"
+
+COMMONDEPEND="dev-libs/xapian:0/1.2.22
+ lua? ( dev-lang/lua:0 )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-lang/ruby:= )
+ tcl? ( >=dev-lang/tcl-8.1:0= )"
+# mono? ( >=dev-lang/mono-1.0.8 )
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.3 )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.3 )"
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ java-pkg-opt-2_src_prepare
+ if use java; then
+ sed \
+ -e 's/$(JAVAC)/$(JAVAC) $(JAVACFLAGS)/' \
+ -i java{/,/org/xapian/errors/,/org/xapian/}Makefile.in || die "sed failed"
+ fi
+
+ if use python; then
+ sed \
+ -e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \
+ -e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian.so|' \
+ -i python/Makefile.in || die "sed failed"
+ fi
+}
+
+src_configure() {
+ if use java; then
+ CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
+ fi
+
+ if use perl; then
+ export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
+ export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
+ fi
+
+ if use lua; then
+ export LUA_LIB="$($(tc-getPKG_CONFIG) --variable=INSTALL_CMOD lua)"
+ fi
+
+ econf \
+ $(use_with java) \
+ $(use_with lua) \
+ $(use_with perl) \
+ $(use_with php) \
+ $(use_with python) \
+ $(use_with ruby) \
+ $(use_with tcl)
+# $(use_with mono csharp) \
+
+ # PHP and Python bindings are built/tested/installed manually.
+ sed -e "/SUBDIRS =/s/ php//" -i Makefile || die "sed Makefile"
+ sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
+}
+
+src_compile() {
+ default
+
+ if use php; then
+ local php_slot
+ for php_slot in $(php_get_slots); do
+ cp -r php php-${php_slot}
+ emake -C php-${php_slot} \
+ PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \
+ PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \
+ PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \
+ PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)"
+ done
+ fi
+
+ if use python; then
+ python_copy_sources
+# building() {
+# emake -C python \
+# PYTHON="$(PYTHON)" \
+# PYTHON_INC="$(python_get_includedir)" \
+# PYTHON_LIB="$(python_get_libdir)" \
+# PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
+# pkgpylibdir="$(python_get_sitedir)/xapian"
+# }
+ building() {
+ emake -C python \
+ PYTHON_INC="$(python_get_includedir)" \
+ pkgpylibdir="$(python_get_sitedir)/xapian"
+ VERBOSE="1"
+ }
+ python_foreach_impl building
+ fi
+}
+
+src_test() {
+ default
+
+ if use php; then
+ local php_slot
+ for php_slot in $(php_get_slots); do
+ emake -C php-${php_slot} \
+ PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \
+ PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \
+ PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \
+ PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \
+ check
+ done
+ fi
+
+ if use python; then
+ testing() {
+ emake -C python \
+ PYTHON_INC="$(python_get_includedir)" \
+ pkgpylibdir="$(python_get_sitedir)/xapian" \
+ VERBOSE="1" \
+ check
+ }
+ python_foreach_impl testing
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ if use java; then
+ java-pkg_dojar java/built/xapian_jni.jar
+ # TODO: make the build system not install this...
+ java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
+ rm "${D}/${S}/java/built/libxapian_jni.so"
+ rmdir -p "${D}/${S}/java/built"
+ rmdir -p "${D}/${S}/java/native"
+ fi
+
+ if use php; then
+ local php_slot
+ for php_slot in $(php_get_slots); do
+ emake DESTDIR="${D}" -C php-${php_slot} \
+ PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \
+ PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \
+ PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \
+ PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \
+ install
+ done
+
+ php-ext-source-r2_createinifiles
+ fi
+
+ if use python; then
+ installation() {
+ emake -C python \
+ DESTDIR="${D}" \
+ PYTHON_INC="$(python_get_includedir)" \
+ pkgpylibdir="$(python_get_sitedir)/xapian" \
+ VERBOSE="1" \
+ install
+ }
+ python_foreach_impl installation
+ fi
+
+ # For some USE combinations this directory is not created
+ if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
+ mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
+ fi
+
+ dodoc AUTHORS HACKING NEWS TODO README
+}