summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-02-03 22:12:44 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 03:30:42 +0200
commitdb2b900503f1183aa62ed201f8bdfb771a22afa8 (patch)
treeb49f54a440bddfe18d846075a7d93e685f25891b /dev-libs
parentdev-libs/engine_pkcs11: home fixup (diff)
downloadgentoo-db2b900503f1183aa62ed201f8bdfb771a22afa8.tar.gz
gentoo-db2b900503f1183aa62ed201f8bdfb771a22afa8.tar.bz2
gentoo-db2b900503f1183aa62ed201f8bdfb771a22afa8.zip
dev-libs/cryptlib: version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cryptlib/Manifest1
-rw-r--r--dev-libs/cryptlib/cryptlib-3.4.3.1.ebuild137
-rw-r--r--dev-libs/cryptlib/files/cryptlib-3.4.3.1-build.patch26
-rw-r--r--dev-libs/cryptlib/files/cryptlib-3.4.3.1-zlib.patch55
4 files changed, 219 insertions, 0 deletions
diff --git a/dev-libs/cryptlib/Manifest b/dev-libs/cryptlib/Manifest
index b624a48f11c4..0516966bfe5d 100644
--- a/dev-libs/cryptlib/Manifest
+++ b/dev-libs/cryptlib/Manifest
@@ -1,3 +1,4 @@
DIST cl340.zip 5514751 SHA256 fff4cca9e70e579763882cd58bc8a5b36c52c20a7ace6c8b21c5e4e9e05fd9d5 SHA512 b9091ee4ce589f95ce479a0de25c5456db18d955350cc245637addf31f3c03cfe87c971f5a7bff274d17451059d319723cd337cb25a672e0823e29b98b4b87f8 WHIRLPOOL 8965d0c6b0e0bd38d0bbf674a75ac43ea7ea482218c6592d51d0baa7a6ff8673a27c8095084dc7d7cbca39c29bc9acdb6351d6a1f64f6cdc6c1bf906b2579cff
DIST cl343.zip 5703258 SHA256 08b104442bb5c7281a3299853d5585cc63bd928454dff3150569c02b957427ad SHA512 abbd53c00be82749f7e359f22cd45ef2b1d90040427457ee8d452d2b513093789b99fa8e904b8a7c75e8db046c59d96e966ce64c2b3630bd21cf3e91b57bc58a WHIRLPOOL 0e1f9dd18172ac9ba244845147e7da41932ea13099aa94957b090be2eb302f179a96bb64c04ddcb74f21cdf5be0c6ed849df4076eb77cbde912719a73ffb1b26
+DIST cl3431.zip 5828863 SHA256 4a608d725f66669d983083420f9f57f763f320292c50346de3e8c1caeee743bd SHA512 d6a3403361fe39b855ec85b030989c5dfc54e499260869de0de151ad6f62245020561dd308b86edf6792da9663e19a0c0d21c53aa7434b21e83eb4b7445fd8dc WHIRLPOOL eccc446361f7daa9cf5a017ae7e229b2003f198490b9cae1bed61fd7bd585e9a08ec54c6c035ba2c4f3e8a58d3eb9756a61f608d5a299c8cc66b159a87e95874
DIST cryptlib-3.4.0-manual.pdf.bz2 1215921 SHA256 b06b736e6e123f578adcd08a8ede6cdb62e3e6d4ac2decb3570def1b29d44da8 SHA512 dbf9914a110a686dc23fedd23c16cefbae12cc67e378db67ac292f8f782b3b615a5819013f2b9c4861086c7ddfab690db9d68a911346102def323255cf48069b WHIRLPOOL 8cc64ab7ffe8a97714e793dd3dfe36708e7e2c7ec583479c593d767de22b860be5bcf0a70427f6f2e7e1d9732ec4ba2d2b3f1617f97bb649c0298924e4a93fb6
diff --git a/dev-libs/cryptlib/cryptlib-3.4.3.1.ebuild b/dev-libs/cryptlib/cryptlib-3.4.3.1.ebuild
new file mode 100644
index 000000000000..de6d98ca9155
--- /dev/null
+++ b/dev-libs/cryptlib/cryptlib-3.4.3.1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1 eutils flag-o-matic multilib toolchain-funcs versionator
+
+MY_PV="${PV//.}"
+
+DESCRIPTION="Powerful security toolkit for adding encryption to software"
+HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
+DOC_PREFIX="${PN}-$(get_version_component_range 1-2 ${PV}).0"
+SRC_URI="ftp://ftp.franken.de/pub/crypt/cryptlib/cl${MY_PV}.zip
+ doc? ( mirror://gentoo/${DOC_PREFIX}-manual.pdf.bz2 )"
+
+LICENSE="Sleepycat"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc ldap odbc python"
+
+S="${WORKDIR}"
+
+RDEPEND="sys-libs/zlib
+ ldap? ( net-nds/openldap )
+ odbc? ( dev-db/unixODBC )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-zlib.patch"
+)
+
+src_unpack() {
+ # we need the -a option, so we can not use 'unpack'
+ unzip -qoa "${DISTDIR}/cl${MY_PV}.zip" || die
+ use doc && unpack "${DOC_PREFIX}-manual.pdf.bz2"
+}
+
+wrap_python() {
+ if use python; then
+ cd bindings || die
+ distutils-r1_${1}
+ fi
+}
+
+src_prepare() {
+ default
+
+ rm -fr zlib || die
+
+ # we want our own CFLAGS ;-)
+ sed -i -e "s:-m.*=pentium::g" -e "s:-fomit-frame-pointer::g" -e "s:-O2::g" \
+ -e "s:-O3::g" -e "s:-O4::g" makefile || die "sed makefile failed"
+ sed -i -e "s/-march=[[:alnum:]\.=-]*//g" -e "s/-mcpu=[[:alnum:]\.=-]*//g" \
+ -e "s:-O2::g" -e "s:-O3::g" tools/ccopts.sh || die "sed tools/ccopts.sh failed"
+
+ # change 'make' to '$(MAKE)'
+ sed -i -e "s:@\?make:\$(MAKE):g" makefile || die "sed makefile failed"
+
+ # NOTICE:
+ # Because of stack execution
+ # assembly parts are disabled.
+ sed -i -e 's:i\[3,4,5,6\]86:___:g' makefile || die "sed makefile failed"
+
+ # Fix version number of shared library.
+ sed -i -e 's/PLV="2"/PLV="3"/' tools/buildall.sh || die "sed tools/buildall.sh failed"
+
+ wrap_python ${FUNCNAME}
+}
+
+src_compile() {
+ local libname="libcl.so.$(get_version_component_range 1-3 ${PV})"
+
+ # At least -O2 is needed.
+ replace-flags -O -O2
+ replace-flags -O0 -O2
+ replace-flags -O1 -O2
+ replace-flags -Os -O2
+ is-flagq -O* || append-flags -O2
+
+ append-flags "-fPIC"
+ append-cppflags "-D__UNIX__ -DOSVERSION=2 -DNDEBUG -I."
+
+ if [ -f /usr/include/pthread.h -a \
+ `grep -c PTHREAD_MUTEX_RECURSIVE /usr/include/pthread.h` -ge 0 ] ; then
+ append-cppflags "-DHAS_RECURSIVE_MUTEX"
+ fi
+ if [ -f /usr/include/pthread.h -a \
+ `grep -c PTHREAD_MUTEX_ROBUST /usr/include/pthread.h` -ge 0 ] ; then
+ append-cppflags "-DHAS_ROBUST_MUTEX"
+ fi
+
+ use ldap && append-cppflags -DHAS_LDAP
+ use odbc && append-cppflags -DHAS_ODBC
+
+ emake directories
+ emake toolscripts
+ emake CC="$(tc-getCC)" CFLAGS="${CPPFLAGS} ${CFLAGS} -c" STRIP=true Linux
+
+ emake TARGET=${libname} OBJPATH="./shared-obj/" CC="$(tc-getCC)" \
+ CFLAGS="${CPPFLAGS} ${CFLAGS} -c" STRIP=true Linux
+
+ if use python; then
+ # Without this python will link against the static lib
+ ln -s libcl.so.${PV} libcl.so || die
+
+ # Python bindings don't work with -O2 and higher.
+ replace-flags -O* -O1
+
+ wrap_python ${FUNCNAME}
+ fi
+}
+
+src_install() {
+ local libname="libcl.so.$(get_version_component_range 1-3 ${PV})"
+ local solibname="libcl.so.$(get_version_component_range 1-2 ${PV})"
+
+ dolib.so "${libname}"
+ dosym "${libname}" "/usr/$(get_libdir)/${solibname}"
+ dosym "${solibname}" "/usr/$(get_libdir)/libcl.so"
+ dolib.a "libcl.a"
+
+ doheader cryptlib.h
+
+ dodoc README
+ if use doc; then
+ newdoc "${DOC_PREFIX}-manual.pdf" "manual.pdf"
+ fi
+
+ wrap_python ${FUNCNAME}
+}
diff --git a/dev-libs/cryptlib/files/cryptlib-3.4.3.1-build.patch b/dev-libs/cryptlib/files/cryptlib-3.4.3.1-build.patch
new file mode 100644
index 000000000000..3a0e558bd0de
--- /dev/null
+++ b/dev-libs/cryptlib/files/cryptlib-3.4.3.1-build.patch
@@ -0,0 +1,26 @@
+From a65e87b8dbc48411b7fcade37612cf6e35be9865 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Fri, 3 Feb 2017 21:54:54 +0200
+Subject: [PATCH] build: use ldflags
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ tools/buildsharedlib.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/buildsharedlib.sh b/tools/buildsharedlib.sh
+index 9a23592..c90dbc1 100644
+--- a/tools/buildsharedlib.sh
++++ b/tools/buildsharedlib.sh
+@@ -86,7 +86,7 @@ shift
+
+ if [ "$($LD -v 2>&1 | grep -c gcc)" -gt 0 ] ; then
+ LD_IS_GCC=1 ;
+- LDFLAGS="-shared -Wl,-soname,libcl.so.$VERS" ;
++ LDFLAGS="-shared -Wl,-soname,libcl.so.$VERS $LDFLAGS" ;
+ fi
+
+ # Create the response file to hold the link command
+--
+2.10.2
+
diff --git a/dev-libs/cryptlib/files/cryptlib-3.4.3.1-zlib.patch b/dev-libs/cryptlib/files/cryptlib-3.4.3.1-zlib.patch
new file mode 100644
index 000000000000..8bb722a6bf5b
--- /dev/null
+++ b/dev-libs/cryptlib/files/cryptlib-3.4.3.1-zlib.patch
@@ -0,0 +1,55 @@
+From 3a3a469d226b6da69b583516b982135af4bb2718 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Fri, 3 Feb 2017 21:41:40 +0200
+Subject: [PATCH] build: use system zlib
+
+this should be a toggle of build system not hard coded.
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ envelope/envelope.h | 6 +-----
+ makefile | 4 ++--
+ 2 files changed, 3 insertions(+), 7 deletions(-)
+
+diff --git a/envelope/envelope.h b/envelope/envelope.h
+index e0e0c3e..90a8267 100644
+--- a/envelope/envelope.h
++++ b/envelope/envelope.h
+@@ -17,11 +17,7 @@
+ #endif /* Compiler-specific includes */
+ #endif /* _STREAM_DEFINED */
+ #ifdef USE_COMPRESSION
+- #if defined( INC_ALL )
+- #include "zlib.h"
+- #else
+- #include "zlib/zlib.h"
+- #endif /* Compiler-specific includes */
++ #include <zlib.h>
+ #endif /* USE_COMPRESSION */
+
+ /****************************************************************************
+diff --git a/makefile b/makefile
+index 14c0b8f..cb9884c 100644
+--- a/makefile
++++ b/makefile
+@@ -283,7 +283,7 @@ ZLIBOBJS = $(OBJPATH)adler32.o $(OBJPATH)deflate.o $(OBJPATH)inffast.o \
+ OBJS = $(BNOBJS) $(CERTOBJS) $(CRYPTOBJS) $(CTXOBJS) $(DEVOBJS) \
+ $(ENCDECOBJS) $(ENVOBJS) $(HASHOBJS) $(IOOBJS) $(KEYSETOBJS) \
+ $(KRNLOBJS) $(LIBOBJS) $(MECHOBJS) $(MISCOBJS) $(SESSOBJS) \
+- $(ZLIBOBJS) $(OSOBJS)
++ $(OSOBJS)
+
+ # Object files for the self-test code
+
+@@ -1486,7 +1486,7 @@ $(LIBNAME): $(OBJS) $(EXTRAOBJS) $(TESTOBJS)
+
+ $(SLIBNAME): $(OBJS) $(EXTRAOBJS) $(TESTOBJS)
+ @./tools/buildsharedlib.sh $(OSNAME) $(SLIBNAME) $(LD) \
+- $(STRIP) $(MAJ).$(MIN) $(OBJS) $(EXTRAOBJS)
++ $(STRIP) $(MAJ).$(MIN) $(OBJS) $(EXTRAOBJS) -lz
+
+ $(DYLIBNAME): $(OBJS) $(EXTRAOBJS) $(TESTOBJS)
+ @$(LD) -dynamiclib -compatibility_version $(MAJ).$(MIN) \
+--
+2.10.2
+