summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-11-21 16:07:56 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-11-21 17:42:15 +0100
commitdc76ae1d5d3c0a0771527ebf39d9eb41b24abde7 (patch)
treeb6b51386d51c834386dac39e50b5fcc43d82fc86 /dev-libs
parentdev-java/jython: use icu4j:70 (diff)
downloadgentoo-dc76ae1d5d3c0a0771527ebf39d9eb41b24abde7.tar.gz
gentoo-dc76ae1d5d3c0a0771527ebf39d9eb41b24abde7.tar.bz2
gentoo-dc76ae1d5d3c0a0771527ebf39d9eb41b24abde7.zip
dev-libs/intel-compute-runtime: add 21.46.21636
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-21.46.21636.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 85caab610101..e9a65d488166 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -3,3 +3,4 @@ DIST intel-compute-runtime-21.42.21270.tar.gz 4761371 BLAKE2B 5dd2886e4b2a84a224
DIST intel-compute-runtime-21.43.21438.tar.gz 4840204 BLAKE2B 6de3075132b9a48e97e30e66c6e09dd24f51cabddf55622f2c7490d38bd1ad25e4853206a0a8a3c4c34ac3eb774e44974c47089182652ae2d234044b72d1d048 SHA512 e8f98d9c8c0a01794d57276706ec4212a3fb082c8ac04dc76ceb0e30fecbd8d35405baaa45685fd4b241e8b04a15db16aef75bf1929c81ff879af46e5be00d1e
DIST intel-compute-runtime-21.44.21506.tar.gz 4851449 BLAKE2B beb49e8bbbfab098bb07943def326463b50f3a4b659368c5b24aadede582331c2c15d4d047e3bbae3d0ca32752c4a05861b0c0a325f30e91bc865276722116b6 SHA512 ae8ca2780602c53f13379ea798462fff1c136967186da21c5b714ed5ab405cb815e0e5e9e60cf8586cef151424270db624b473748d2756ee5768dba4cc020ea6
DIST intel-compute-runtime-21.45.21574.tar.gz 4868091 BLAKE2B 48ff1ba42e5fe5eb231ec82bb7b33d0bb96460fc5adbfcb4702b68397d58b1b88f2a4e5a2dbef462731d43c284439cc4626ebf308d9dcfc509ccb68cea63eb19 SHA512 ede4ca4772ec6518592557d4c49d0a25204773607ae6737a35d20a3abb73ebbe66d01139baba544d5292d848a05a166a2c5ca1712408f85ce6be840bcf104650
+DIST intel-compute-runtime-21.46.21636.tar.gz 4878855 BLAKE2B 0ada296b36567038b2abeba50c2dae6604981f00cdfc0d5d9d197c793534c887fa1d321ced34b37cf6760bdc9e2b8769cdc24fe3884036b78b983660c90b1ee7 SHA512 a63436d049737b955f0e23bbfc78684f665f3d1a668120e803165839792144154f3f42a52c6533611711592ba6e41408d81196a61e318746b1dae1392d1d29ac
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-21.46.21636.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.46.21636.ebuild
new file mode 100644
index 000000000000..4fba2fba02df
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.46.21636.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.8744
+ >=dev-util/intel-graphics-system-controller-0.2.4
+ >=media-libs/gmmlib-21.2.1
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.6.2 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+# for Khronos OpenGL headers
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-21.31.20514-no_Werror.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="ON"
+ )
+
+ cmake_src_configure
+}