summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-05-17 17:10:16 +0200
committerMike Gilbert <floppym@gentoo.org>2019-05-17 15:33:25 -0400
commitde4ace87337a164f0fa086e9f4c3d546f615377f (patch)
treec872d71ba070ac596fb9a701f9bd3319b39696a5 /dev-libs
parentdev-libs/oniguruma: Delete old versions (6.8.2, 6.9.0). (diff)
downloadgentoo-de4ace87337a164f0fa086e9f4c3d546f615377f.tar.gz
gentoo-de4ace87337a164f0fa086e9f4c3d546f615377f.tar.bz2
gentoo-de4ace87337a164f0fa086e9f4c3d546f615377f.zip
dev-libs/oniguruma: Version bump (6.9.2).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/oniguruma/Manifest1
-rw-r--r--dev-libs/oniguruma/oniguruma-6.9.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/oniguruma/Manifest b/dev-libs/oniguruma/Manifest
index 32b17ae8cfe4..198c2d1c2de5 100644
--- a/dev-libs/oniguruma/Manifest
+++ b/dev-libs/oniguruma/Manifest
@@ -1 +1,2 @@
DIST onig-6.9.1.tar.gz 870525 BLAKE2B 8427b92670545e66deba35dfde0cb0ce346629a188c4adaa3025d0acaa81d2ffd86111be17419ea67b2d5f3fb4387aab0d8d20d70fb2f518ccc0ca165b66207d SHA512 5454c161d2d45f2c992513a695ff586ffa99e44a27d7ac5498370e200adb664bb02f2d8cd7d73e61d467f626d1a9b41d9e6e3051e1ea1a021624f94f7d52975f
+DIST onig-6.9.2.tar.gz 901931 BLAKE2B 93326408c7c9cd9c5053f14edd0e5fbf348a4da135146cfbff7659518686a83301b8d4111dbd65b834e201334871d9fa8202a8ed3cc4f793d444591e96071c74 SHA512 c10134e42a3c0b0eeae2027ffb7a3e1bcc9228dee286f6b6e997f8a73d717217fa74de0e19c40975d2e78044c8c4f029eb622f90c8eb4fdc4667eb4804e97001
diff --git a/dev-libs/oniguruma/oniguruma-6.9.2.ebuild b/dev-libs/oniguruma/oniguruma-6.9.2.ebuild
new file mode 100644
index 000000000000..ef4e2c1366d5
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-6.9.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2003-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="onig-${PV}"
+
+DESCRIPTION="Regular expression library for different character encodings"
+HOMEPAGE="https://github.com/kkos/oniguruma"
+SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="crnl-as-line-terminator static-libs"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable crnl-as-line-terminator) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name "*.la" -type f -delete || die
+}