summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-12-21 01:36:52 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-12-21 01:36:52 +0100
commite3df7355d9bde61edd010d5167e4e0d6a695687a (patch)
treea9a99601034088af2d05443af77a41565921f8e7 /dev-libs
parentnet-im/prosody: add 0.11.11 (diff)
downloadgentoo-e3df7355d9bde61edd010d5167e4e0d6a695687a.tar.gz
gentoo-e3df7355d9bde61edd010d5167e4e0d6a695687a.tar.bz2
gentoo-e3df7355d9bde61edd010d5167e4e0d6a695687a.zip
dev-libs/intel-compute-runtime: add 21.50.21939
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-21.50.21939.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index dd6ee91016de..d972671410b2 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,2 +1,3 @@
DIST intel-compute-runtime-21.46.21636.tar.gz 4878855 BLAKE2B 0ada296b36567038b2abeba50c2dae6604981f00cdfc0d5d9d197c793534c887fa1d321ced34b37cf6760bdc9e2b8769cdc24fe3884036b78b983660c90b1ee7 SHA512 a63436d049737b955f0e23bbfc78684f665f3d1a668120e803165839792144154f3f42a52c6533611711592ba6e41408d81196a61e318746b1dae1392d1d29ac
DIST intel-compute-runtime-21.49.21786.tar.gz 4939973 BLAKE2B 27a02e31adb45146d353b3a37e5a1bd618de8c2a458cb5e905fa729fc879ce8220d8f08f1f63579beb702f69d9aa324a7aeab5bc28473ba8d0d0a4fa1e852db3 SHA512 0715e9711570251514ad63f68c2a259fab8ee46741f5fd543901059eaa4152830c51f62903d4f4b59cf6cf7742dd95f9d03e2f2394f4d0bf3dfeb02f16954f23
+DIST intel-compute-runtime-21.50.21939.tar.gz 5106368 BLAKE2B 3a8613c7178975bf930f0ccbed06d31952f05c8316e7735db759a7bcc8b81b5bd3040af62bae6e63fc9781ce2e6e8f035751cd6696b4c7cfbb6025f3d4fcfd8b SHA512 cabcb0fb9816ca8e6b93fa069c73926ccdaf3803c073b11f62477f80d38af49a7b4e814765a40e3daae50a6159560872c5b5123f64e68a570556c80d47a120c9
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-21.50.21939.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.50.21939.ebuild
new file mode 100644
index 000000000000..211c859a70c9
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.50.21939.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.9389
+ >=dev-util/intel-graphics-system-controller-0.2.4
+ >=media-libs/gmmlib-21.2.1:=
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.6.2 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+# for Khronos OpenGL headers
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-21.31.20514-no_Werror.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="ON"
+ )
+
+ cmake_src_configure
+}