summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-13 13:37:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-13 14:21:44 +0200
commitf9ab2a2d9e5750a4f76aca1b1bba234099e48dec (patch)
tree9ddd3e003c6a923e620eb4ff9691c52cd6b4f63a /dev-libs
parentnet-p2p/ktorrent: 21.04.1 version bump (diff)
downloadgentoo-f9ab2a2d9e5750a4f76aca1b1bba234099e48dec.tar.gz
gentoo-f9ab2a2d9e5750a4f76aca1b1bba234099e48dec.tar.bz2
gentoo-f9ab2a2d9e5750a4f76aca1b1bba234099e48dec.zip
dev-libs/kopeninghours: 21.04.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-21.04.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 262e73545671..6c9357b5e1ac 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1 +1,2 @@
DIST kopeninghours-21.04.0.tar.xz 62144 BLAKE2B ae90c941716f30bf36cdf46bf0d2d28eb17793b7c9b81773ec6694561e1254bad40dea64481f871ea2dc9f91765cf18a174c77d07113844d3088a1dad8b85550 SHA512 a074c5920439fcc18a4078dbb0df410555725f20d06bc8d9fb4f9c97613a55ae74077c600b77260d7b699e50badbdd0c086e43500e182ce25b1466ce00135b96
+DIST kopeninghours-21.04.1.tar.xz 62176 BLAKE2B c0b8bbc747fdc947eb05980796a0b8c2f6006cff4278ec5fe941eaed66becb8904e05b599a7562680bdfee79ecdc6755bbe4afdd8dec928b7ef404becbd9c3d1 SHA512 dd65c0ef888e5e8b88109eb9e873203f190ca657812d4be72ac59d2ac7910fad9342a47b185af1c6949cd9045f15e1deaae0ac95eebee64d10e702621a8d2fe0
diff --git a/dev-libs/kopeninghours/kopeninghours-21.04.1.ebuild b/dev-libs/kopeninghours/kopeninghours-21.04.1.ebuild
new file mode 100644
index 000000000000..405678cd3d3d
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-21.04.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.80.0
+QTMIN=5.15.2
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-21.03.90-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}