summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-05 15:15:01 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-05 15:16:50 +0200
commitfd88098364053a9b5c2bfe1154a37627f3e50eb4 (patch)
treebb3d4924cf964d443b14536a6fb2005e67ecedb0 /dev-libs
parentwww-apps/grafana-bin: Version bump to 6.1.1 (diff)
downloadgentoo-fd88098364053a9b5c2bfe1154a37627f3e50eb4.tar.gz
gentoo-fd88098364053a9b5c2bfe1154a37627f3e50eb4.tar.bz2
gentoo-fd88098364053a9b5c2bfe1154a37627f3e50eb4.zip
dev-libs/ell: Added live ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ell/ell-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/ell/ell-9999.ebuild b/dev-libs/ell/ell-9999.ebuild
new file mode 100644
index 000000000000..6e917adf8117
--- /dev/null
+++ b/dev-libs/ell/ell-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Embedded Linux Library provides core, low-level functionality for system daemons"
+HOMEPAGE="https://01.org/ell"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/libs/ell/ell.git"
+else
+ SRC_URI="https://mirrors.edge.kernel.org/pub/linux/libs/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+fi
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+IUSE="glib pie"
+
+RDEPEND="
+ glib? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ [[ "${PV}" == *9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable glib)
+ $(use_enable pie)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ local DOCS=( ChangeLog README )
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}