summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lisp/abcl/abcl-0.0.9-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lisp/abcl/abcl-0.0.9-r1.ebuild')
-rw-r--r--dev-lisp/abcl/abcl-0.0.9-r1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-lisp/abcl/abcl-0.0.9-r1.ebuild b/dev-lisp/abcl/abcl-0.0.9-r1.ebuild
new file mode 100644
index 000000000000..8e660c63529f
--- /dev/null
+++ b/dev-lisp/abcl/abcl-0.0.9-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="ABCL is an implementation of ANSI Common Lisp that runs in a Java VM"
+HOMEPAGE="http://armedbear.org/abcl.html"
+SRC_URI="http://armedbear.org/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="jad clisp cmucl"
+
+RDEPEND=">=virtual/jre-1.4
+ jad? ( dev-java/jad-bin )"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-lang/python
+ !cmucl? ( !clisp? ( dev-lisp/sbcl ) )
+ cmucl? ( dev-lisp/cmucl )
+ clisp? ( dev-lisp/clisp )"
+
+src_unpack() {
+ unpack ${A}
+ cat > "${S}/customizations.lisp" <<EOF
+(in-package #:build-abcl)
+(setf
+*javac-options* "-g $(java-pkg_javac-args)"
+*jikes-options* "+D -g $(java-pkg_javac-args)"
+*jdk* "${JAVA_HOME}/"
+*java-compiler* "${JAVAC}"
+*jar* "jar")
+EOF
+ einfo "Building with the following customizations.lisp:"
+ cat "${S}/customizations.lisp"
+ cat >"${S}/build.lisp" <<'EOF'
+(progn (load "build-abcl") (funcall (intern "BUILD-ABCL" "BUILD-ABCL") :clean t :full t) #+sbcl (sb-ext:quit) #+clisp (ext:quit) #+cmu (extensions:quit))
+EOF
+}
+
+getutfvars() {
+python << EOF
+import os
+for key,value in os.environ.iteritems():
+ try:
+ value.encode()
+ except UnicodeDecodeError:
+ print key
+EOF
+}
+
+src_compile() {
+ local lisp_compiler lisp_compiler_args
+ if use clisp; then
+ lisp_compiler="clisp"
+ lisp_compiler_args="-ansi build.lisp"
+ elif use cmucl; then
+ lisp_compiler="lisp"
+ lisp_compiler_args="-noinit -nositeinit -batch -load build.lisp"
+ else
+ lisp_compiler="sbcl"
+ lisp_compiler_args="--sysinit /dev/null --userinit /dev/null --disable-debugger --load build.lisp"
+ fi
+
+ einfo "Filtering non ASCII environment variables"
+ for var in $(getutfvars); do
+ einfo " ${var}"
+ unset ${var}
+ done
+ $lisp_compiler $lisp_compiler_args || die
+}
+
+src_install() {
+ java-pkg_dolauncher ${PN} --java_args "-Xmx256M -Xrs" --main org.armedbear.lisp.Main
+ java-pkg_doso src/org/armedbear/lisp/libabcl.so
+ java-pkg_dojar abcl.jar
+ dodoc README || die
+}