summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-10-29 19:41:47 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2017-10-29 19:42:47 +0100
commit818a3be725caad1597aa8ef3d4b37033160309a7 (patch)
tree570defbece6fa6df6678606bd652bc2ccd7f8d06 /dev-lisp/alexandria/alexandria-20171029.ebuild
parentdev-python/virtualenvwrapper: 4.8.2 bup (diff)
downloadgentoo-818a3be725caad1597aa8ef3d4b37033160309a7.tar.gz
gentoo-818a3be725caad1597aa8ef3d4b37033160309a7.tar.bz2
gentoo-818a3be725caad1597aa8ef3d4b37033160309a7.zip
dev-lisp/alexandria: Adds new package
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-lisp/alexandria/alexandria-20171029.ebuild')
-rw-r--r--dev-lisp/alexandria/alexandria-20171029.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lisp/alexandria/alexandria-20171029.ebuild b/dev-lisp/alexandria/alexandria-20171029.ebuild
new file mode 100644
index 000000000000..c5656e8f3de0
--- /dev/null
+++ b/dev-lisp/alexandria/alexandria-20171029.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 eutils
+
+DESCRIPTION="A collection of public domain utilities."
+HOMEPAGE="http://common-lisp.net/project/alexandria/"
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.common-lisp.net/alexandria/alexandria.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="doc? ( sys-apps/texinfo )"
+RDEPEND=""
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-fix-docstrings.patch"
+ eapply_user
+}
+
+src_compile() {
+ use doc && emake -C doc
+}
+
+src_install() {
+ common-lisp-install-sources -t all *.lisp LICENCE
+ common-lisp-install-asdf
+ dodoc README AUTHORS
+ use doc && doinfo doc/${PN}.info && dodoc doc/{"${PN}.html","${PN}.pdf"}
+}