summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lisp/common-lisp-controller
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lisp/common-lisp-controller')
-rw-r--r--dev-lisp/common-lisp-controller/Manifest2
-rw-r--r--dev-lisp/common-lisp-controller/common-lisp-controller-4.27.ebuild93
-rw-r--r--dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild97
-rw-r--r--dev-lisp/common-lisp-controller/files/4.27/lisp-config.lisp3
-rw-r--r--dev-lisp/common-lisp-controller/files/5.13/lisp-config.lisp3
-rw-r--r--dev-lisp/common-lisp-controller/files/README.Gentoo27
-rw-r--r--dev-lisp/common-lisp-controller/metadata.xml11
7 files changed, 236 insertions, 0 deletions
diff --git a/dev-lisp/common-lisp-controller/Manifest b/dev-lisp/common-lisp-controller/Manifest
new file mode 100644
index 000000000000..001aef39dae2
--- /dev/null
+++ b/dev-lisp/common-lisp-controller/Manifest
@@ -0,0 +1,2 @@
+DIST common-lisp-controller_4.27.tar.gz 27636 SHA256 e4576c018e136ae34dfaf163cd20c3fc000b4a7ac716a53bde6268700a515082 SHA512 afba310bf525fb40f98a6bd67747647d105080667a3ebef883e19ffc60186bdfc7b937c2efe7535e3daa08503d8079d69453264fe8124f1b9a4a55e6303fe1b3 WHIRLPOOL d30ec6261cadd4235bebbc9d87493cb7a8ffb76027f3913f07af2ee0a047881b253e6816ad1309ff407462d37e4b804ba5470cee1888339e10668b18d0a79204
+DIST common-lisp-controller_5.13.tar.gz 30846 SHA256 ec2e9c6fa566b2d5f18d2823e48e54834392ca8c76e677047f03d5d940e40249 SHA512 11a6e2b7a3ca6846c8b88ee3808ae4e01c269dce8eb4293e57bf061a6c74786fe8bdff0f11c3db5c8ac60e3ba7a1e74222f9ab1418da114b6ece2fa6f23464e2 WHIRLPOOL 2211168a7cf0198cec689caf3fd07dc2a1d536bbb1005287abae9e8d1e135754a38980aef220696e175805aa64a8d5dd8b8a874c7bd9b76029bac62cf175357e
diff --git a/dev-lisp/common-lisp-controller/common-lisp-controller-4.27.ebuild b/dev-lisp/common-lisp-controller/common-lisp-controller-4.27.ebuild
new file mode 100644
index 000000000000..fe890f28949b
--- /dev/null
+++ b/dev-lisp/common-lisp-controller/common-lisp-controller-4.27.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Common Lisp Controller"
+HOMEPAGE="http://packages.debian.org/unstable/devel/common-lisp-controller"
+SRC_URI="mirror://gentoo/common-lisp-controller_${PV}.tar.gz"
+
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="|| ( >=sys-apps/coreutils-8.15 app-misc/realpath )
+ >=dev-lisp/asdf-1.84
+ dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/man"
+ ln -s clc-{,un}register-user-package.1
+ for i in unregister-common-lisp-implementation {,un}register-common-lisp-source; do
+ ln -s register-common-lisp-implementation.8 ${i}.8
+ done
+}
+
+src_install() {
+ dobin clc-register-user-package
+ dobin clc-unregister-user-package
+ dosbin register-common-lisp-implementation
+ dosbin register-common-lisp-source
+ dosbin unregister-common-lisp-implementation
+ dosbin unregister-common-lisp-source
+ insinto /usr/share/common-lisp/source/common-lisp-controller
+ doins common-lisp-controller.lisp
+ doins post-sysdef-install.lisp
+ doman man/*.[18]
+ insinto /etc
+ doins "${FILESDIR}/${PV}/lisp-config.lisp"
+ dodoc "${FILESDIR}/README.Gentoo"
+ dodoc DESIGN.txt
+}
+
+pkg_postinst() {
+ test -d /var/cache/common-lisp-controller \
+ || mkdir /var/cache/common-lisp-controller
+ chmod 1777 /var/cache/common-lisp-controller
+
+ # This code from ${S}/debian/postinst
+
+ for compiler in /usr/lib/common-lisp/bin/*.sh
+ do
+ if [ -f "${compiler}" -a -r "${compiler}" -a -x "${compiler}" ] ; then
+ i=${compiler##*/}
+ i=${i%.sh}
+ einfo ">>> Recompiling Common Lisp Controller for $i"
+ bash "$compiler" install-clc || true
+ einfo ">>> Done rebuilding"
+ fi
+ done
+
+ # This code from ${S}/debian/preinst
+
+ # cleanup fasl files:
+ ( find /usr/share/common-lisp/source/defsystem \
+ /usr/share/common-lisp/source/asdf \
+ /usr/share/common-lisp/source/common-lisp-controller -type f -not -name "*.lisp" -print0 \
+ | xargs --null rm --force 2> /dev/null ) &>/dev/null
+
+ # remove old autobuild files:
+# find /etc/common-lisp -name autobuild -print0 \
+# | xargs -0 rm 2> /dev/null || true
+# find /etc/common-lisp -type d -depth -print0 \
+# | xargs rmdir 2> /dev/null || true
+
+ # remove old fals files:
+ test -d /usr/lib/common-lisp-controller \
+ && rmdir --ignore-fail-on-non-empty /usr/lib/common-lisp-controller
+ for compiler in /usr/lib/common-lisp/bin/*.sh ; do
+ if [ -f "$compiler" -a -r "$compiler" ] ; then
+ i=${compiler##*/}
+ i=${i%.sh}
+ if [ -d "/usr/lib/common-lisp/${i}" ] ; then
+ rm -rf "/usr/lib/common-lisp/${i}"
+ fi
+ fi
+ done
+}
diff --git a/dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild b/dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild
new file mode 100644
index 000000000000..a4dfe46ee55c
--- /dev/null
+++ b/dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+inherit eutils
+
+DESCRIPTION="Common Lisp Controller"
+HOMEPAGE="http://packages.debian.org/unstable/devel/common-lisp-controller"
+SRC_URI="mirror://gentoo/common-lisp-controller_${PV}.tar.gz"
+
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="|| ( >=sys-apps/coreutils-8.15 app-misc/realpath )
+ >=dev-lisp/asdf-1.84
+ dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/man"
+ ln -s clc-{,un}register-user-package.1
+ for i in unregister-common-lisp-implementation {,un}register-common-lisp-source; do
+ ln -s register-common-lisp-implementation.8 ${i}.8
+ done
+}
+
+src_install() {
+ dobin clc-register-user-package
+ dobin clc-unregister-user-package
+ dosbin register-common-lisp-implementation
+ dosbin register-common-lisp-source
+ dosbin unregister-common-lisp-implementation
+ dosbin unregister-common-lisp-source
+
+ dosbin clc-update-customized-images
+ keepdir /etc/common-lisp/images
+
+ insinto /usr/share/common-lisp/source/common-lisp-controller
+ doins common-lisp-controller.lisp post-sysdef-install.lisp
+ doman man/*.[138]
+ insinto /etc
+ doins "${FILESDIR}/${PV}/lisp-config.lisp"
+ dodoc "${FILESDIR}/README.Gentoo"
+ dodoc DESIGN.txt debian/changelog
+}
+
+pkg_postinst() {
+ test -d /var/cache/common-lisp-controller \
+ || mkdir /var/cache/common-lisp-controller
+ chmod 1777 /var/cache/common-lisp-controller
+
+ # This code from ${S}/debian/postinst
+
+ for compiler in /usr/lib/common-lisp/bin/*.sh
+ do
+ if [ -f "${compiler}" -a -r "${compiler}" -a -x "${compiler}" ] ; then
+ i=${compiler##*/}
+ i=${i%.sh}
+ einfo ">>> Recompiling Common Lisp Controller for $i"
+ bash "$compiler" install-clc || true
+ einfo ">>> Done rebuilding"
+ fi
+ done
+
+ # This code from ${S}/debian/preinst
+
+ # cleanup fasl files:
+ ( find /usr/share/common-lisp/source/defsystem \
+ /usr/share/common-lisp/source/asdf \
+ /usr/share/common-lisp/source/common-lisp-controller -type f -not -name "*.lisp" -print0 \
+ | xargs --null rm --force 2> /dev/null ) &>/dev/null
+
+ # remove old autobuild files:
+# find /etc/common-lisp -name autobuild -print0 \
+# | xargs -0 rm 2> /dev/null || true
+# find /etc/common-lisp -type d -depth -print0 \
+# | xargs rmdir 2> /dev/null || true
+
+ # remove old fals files:
+ test -d /usr/lib/common-lisp-controller \
+ && rmdir --ignore-fail-on-non-empty /usr/lib/common-lisp-controller
+ for compiler in /usr/lib/common-lisp/bin/*.sh ; do
+ if [ -f "$compiler" -a -r "$compiler" ] ; then
+ i=${compiler##*/}
+ i=${i%.sh}
+ if [ -d "/usr/lib/common-lisp/${i}" ] ; then
+ rm -rf "/usr/lib/common-lisp/${i}"
+ fi
+ fi
+ done
+}
diff --git a/dev-lisp/common-lisp-controller/files/4.27/lisp-config.lisp b/dev-lisp/common-lisp-controller/files/4.27/lisp-config.lisp
new file mode 100644
index 000000000000..a6d36ce22005
--- /dev/null
+++ b/dev-lisp/common-lisp-controller/files/4.27/lisp-config.lisp
@@ -0,0 +1,3 @@
+
+(in-package common-lisp-user)
+
diff --git a/dev-lisp/common-lisp-controller/files/5.13/lisp-config.lisp b/dev-lisp/common-lisp-controller/files/5.13/lisp-config.lisp
new file mode 100644
index 000000000000..a6d36ce22005
--- /dev/null
+++ b/dev-lisp/common-lisp-controller/files/5.13/lisp-config.lisp
@@ -0,0 +1,3 @@
+
+(in-package common-lisp-user)
+
diff --git a/dev-lisp/common-lisp-controller/files/README.Gentoo b/dev-lisp/common-lisp-controller/files/README.Gentoo
new file mode 100644
index 000000000000..adaa56315a4f
--- /dev/null
+++ b/dev-lisp/common-lisp-controller/files/README.Gentoo
@@ -0,0 +1,27 @@
+ -*-outline-*-
+
+* Common Lisp Controller 4.x and 5.x
+
+With version 4.x and 5.x of the Debian Common Lisp Controller, the
+design of the controller was simplified so that source was compiled
+into /var/cache/, per user, on demand (ie. when you evaluate (require
+:foo) at the REPL).
+
+* Common Lisp Controller 3.x
+
+** IMPORTANT
+
+The Common Lisp Controller (CLC) in Gentoo GNU/Linux is a modified
+version of the original CLC sources from the Debian Project. Do not
+send bug reports to the Debian Project -- always send bug reports to
+http://bugs.gentoo.org.
+
+** NOTES
+
+If you are used to the CLC in Debian, please note that the Gentoo CLC
+does not require an Internet super-server such as inetd or xinetd in
+order to function. The original CLC implementation's clc-send-command
+has been replaced with a shell script which implements the same
+interface, but bypasses clc-build-daemon entirely.
+
+-- Matthew Kennedy <mkennedy@gentoo.org>
diff --git a/dev-lisp/common-lisp-controller/metadata.xml b/dev-lisp/common-lisp-controller/metadata.xml
new file mode 100644
index 000000000000..c3581b8c864c
--- /dev/null
+++ b/dev-lisp/common-lisp-controller/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+The Common Lisp Controller was originally used in the Debian project. The Common
+Lisp Contoller lets you install and manage common lisp sources and compilers.
+It creates a user-specific cache of compiled objects. When a library or an
+implementation is upgraded all compiled objects in the cache are flushed.
+</longdescription>
+</pkgmetadata>