summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-12 21:10:10 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-12 21:10:10 +0100
commit4605bfd24bd6640baabdb944b3a4584a25810f97 (patch)
treea3185464d13348d77f8da661a66db8db6baafec4 /dev-lisp/gcl
parentdev-java/sac: Keyword 1.3-r4 arm64, #831062 (diff)
downloadgentoo-4605bfd24bd6640baabdb944b3a4584a25810f97.tar.gz
gentoo-4605bfd24bd6640baabdb944b3a4584a25810f97.tar.bz2
gentoo-4605bfd24bd6640baabdb944b3a4584a25810f97.zip
dev-lisp/gcl: Apply assertion patch (thanks to MaxKarlErnstPlanck)
Thanks-to: MaxKarlErnstPlanck <Giovanni.Antonio.Carl.Friedrich@protonmail.com> Closes: https://bugs.gentoo.org/778770 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-lisp/gcl')
-rw-r--r--dev-lisp/gcl/files/gcl-2.6.13_pre99-assertion.patch12
-rw-r--r--dev-lisp/gcl/gcl-2.6.13_pre99.ebuild7
2 files changed, 18 insertions, 1 deletions
diff --git a/dev-lisp/gcl/files/gcl-2.6.13_pre99-assertion.patch b/dev-lisp/gcl/files/gcl-2.6.13_pre99-assertion.patch
new file mode 100644
index 000000000000..e788b62f2bf0
--- /dev/null
+++ b/dev-lisp/gcl/files/gcl-2.6.13_pre99-assertion.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/778770
+--- a/h/notcomp.h
++++ b/h/notcomp.h
+@@ -299,7 +299,7 @@
+ #define coerce_to_filename(a_,b_) coerce_to_filename1(a_,b_,sizeof(b_))
+
+ #include <errno.h>
+-#define massert(a_) ({errno=0;if (!(a_)||errno) assert_error(#a_,__LINE__,__FILE__,__FUNCTION__);})
++#define massert(a_) ({errno=0;if (!(a_)) assert_error(#a_,__LINE__,__FILE__,__FUNCTION__);})
+
+ extern bool writable_malloc;
+ #define writable_malloc_wrap(f_,rt_,a_...) ({rt_ v;bool w=writable_malloc;writable_malloc=1;v=f_(a_);writable_malloc=w;v;})
diff --git a/dev-lisp/gcl/gcl-2.6.13_pre99.ebuild b/dev-lisp/gcl/gcl-2.6.13_pre99.ebuild
index a1f37e04a53b..6858ff5af62f 100644
--- a/dev-lisp/gcl/gcl-2.6.13_pre99.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.13_pre99.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,6 +28,11 @@ DEPEND="${RDEPEND}
app-text/texi2html
>=sys-devel/autoconf-2.52"
+PATCHES=(
+ # bug 778770
+ "${FILESDIR}"/${P}-assertion.patch
+)
+
src_configure() {
strip-flags
filter-flags -fstack-protector -fstack-protector-all