summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso Josa <nimiux@gentoo.org>2015-12-15 23:10:00 +0100
committerJosé María Alonso Josa <nimiux@gentoo.org>2015-12-15 23:10:46 +0100
commit12258bb30a6f0de2297501eea706c1ce1d8e9914 (patch)
treee34633afb71ab6bbbb8dae5b3cb1751d507d9259 /dev-lisp/trivial-gray-streams
parentdev-ruby/redis: Version bump (diff)
downloadgentoo-12258bb30a6f0de2297501eea706c1ce1d8e9914.tar.gz
gentoo-12258bb30a6f0de2297501eea706c1ce1d8e9914.tar.bz2
gentoo-12258bb30a6f0de2297501eea706c1ce1d8e9914.zip
dev-lisp/trivial-gray-streams add from lisp overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lisp/trivial-gray-streams')
-rw-r--r--dev-lisp/trivial-gray-streams/Manifest1
-rw-r--r--dev-lisp/trivial-gray-streams/metadata.xml9
-rw-r--r--dev-lisp/trivial-gray-streams/trivial-gray-streams-20081102.ebuild28
-rw-r--r--dev-lisp/trivial-gray-streams/trivial-gray-streams-9999.ebuild17
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-lisp/trivial-gray-streams/Manifest b/dev-lisp/trivial-gray-streams/Manifest
new file mode 100644
index 000000000000..80183fe3b004
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/Manifest
@@ -0,0 +1 @@
+DIST trivial-gray-streams-2008-11-02.tar.gz 3522 SHA256 827eff9528b469f18c332d0dec68a2498ca9261950635b1cd8e589a492b589a4 SHA512 81ca798988511237a5a4c9ae4e0b15253404c47e245cc644211ffc58015fd46fa1623fecf7f07ea5df7acf80fff24782410ef832f08fd55f71c57daad6ced787 WHIRLPOOL 07b4ba232c7a6156667a084adf56684c3d04ace96d56a282298fd7e284760b60c1fefa09f90053e1400fed5c2d6cb25dbb2756697c08ad15b2647fd72933e26e
diff --git a/dev-lisp/trivial-gray-streams/metadata.xml b/dev-lisp/trivial-gray-streams/metadata.xml
new file mode 100644
index 000000000000..6dbd467b762f
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>common-lisp</herd>
+ <longdescription lang="en">
+ This system provides an extremely thin compatibility layer for
+ Gray streams
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-lisp/trivial-gray-streams/trivial-gray-streams-20081102.ebuild b/dev-lisp/trivial-gray-streams/trivial-gray-streams-20081102.ebuild
new file mode 100644
index 000000000000..71cf386709f7
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/trivial-gray-streams-20081102.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit common-lisp-3
+
+MY_PV=${PV:0:4}-${PV:4:2}-${PV:6:2}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A thin compatibility layer between Gray Stream Common Lisp implementations"
+HOMEPAGE="https://common-lisp.net/project/trivial-gray-streams/"
+SRC_URI="http://common-lisp.net/project/cl-plus-ssl/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ rm "${S}"/Makefile
+}
diff --git a/dev-lisp/trivial-gray-streams/trivial-gray-streams-9999.ebuild b/dev-lisp/trivial-gray-streams/trivial-gray-streams-9999.ebuild
new file mode 100644
index 000000000000..f73f20d10c7d
--- /dev/null
+++ b/dev-lisp/trivial-gray-streams/trivial-gray-streams-9999.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit common-lisp-3 git-2
+
+DESCRIPTION="A thin compatibility layer between Gray Stream Common Lisp implementations"
+HOMEPAGE="https://common-lisp.net/project/trivial-gray-streams/"
+EGIT_REPO_URI="git://github.com/${PN}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}"