summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-05-28 11:05:21 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-05-28 11:05:21 +0200
commit6e2570dc3f7f09535cf7a2247c042dd71970e5fc (patch)
tree98797ecbc6e0576e4ee41fae6db36a8565a12aed /dev-lisp
parentapp-admin/tripwire: Drop old version 2.4.3.6 (diff)
downloadgentoo-6e2570dc3f7f09535cf7a2247c042dd71970e5fc.tar.gz
gentoo-6e2570dc3f7f09535cf7a2247c042dd71970e5fc.tar.bz2
gentoo-6e2570dc3f7f09535cf7a2247c042dd71970e5fc.zip
dev-lisp/ecls: Drop old version 13.5.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/Manifest1
-rw-r--r--dev-lisp/ecls/ecls-13.5.1-r1.ebuild89
-rw-r--r--dev-lisp/ecls/files/13.5.1-gc74.patch57
-rw-r--r--dev-lisp/ecls/files/13.5.1-headers-gentoo.patch13
4 files changed, 0 insertions, 160 deletions
diff --git a/dev-lisp/ecls/Manifest b/dev-lisp/ecls/Manifest
index d1e11077a9cf..c5eba6edf5ac 100644
--- a/dev-lisp/ecls/Manifest
+++ b/dev-lisp/ecls/Manifest
@@ -1,2 +1 @@
-DIST ecl-13.5.1.tgz 9401163 BLAKE2B 441f2ed429f9f508d12fec333aeed7178aedab0e2011c57fbf0c6695747de95e5db6818c5cfc6acd1097804a4cd7bf1dd0ec3e79c04a5b4399d61cefb5179ba7 SHA512 a09f8b824aa78e461d700eefb1a8b68b876e15d49124a397e0b5b58ad73b80f818133a7b8e48ddb83505eea2f9c5fb024de8701b527524004e336e456eb07c84
DIST ecl-16.1.3.tgz 7459212 BLAKE2B 4f9d6ad2bd92ede4b5b20857b95a48bad5002049e83611865d9cf13e7131adfaad147a31f22f9a3f6a2c06e46db1996aa98135c28b97bf5ef16e17b5eba0dc4b SHA512 5d743f422f6bc24671abf4c739cde8273d08f056906a1ef8aed5145c703b6d52c7fa4b5e0be8c125f32240c20ce053007786bb3ae81cc34d47791f6fae0819c1
diff --git a/dev-lisp/ecls/ecls-13.5.1-r1.ebuild b/dev-lisp/ecls/ecls-13.5.1-r1.ebuild
deleted file mode 100644
index 19c50b0e32be..000000000000
--- a/dev-lisp/ecls/ecls-13.5.1-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils multilib
-
-# test phase only works if ecls already installed #516876
-RESTRICT="test"
-
-MY_P=ecl-${PV}
-
-DESCRIPTION="ECL is an embeddable Common Lisp implementation"
-HOMEPAGE="http://ecls.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
-
-LICENSE="BSD LGPL-2"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE="debug emacs gengc precisegc cpu_flags_x86_sse +threads +unicode X"
-
-CDEPEND="dev-libs/gmp
- virtual/libffi
- >=dev-libs/boehm-gc-7.1[threads?]
- >=dev-lisp/asdf-2.33-r3:="
-DEPEND="${CDEPEND}
- app-text/texi2html
- emacs? ( virtual/emacs >=app-eselect/eselect-emacs-1.12 )"
-RDEPEND="${CDEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-pkg_setup () {
- if use gengc || use precisegc ; then
- ewarn "You have enabled the generational garbage collector or"
- ewarn "the precise collection routines. These features are not very stable"
- ewarn "at the moment and may cause crashes."
- ewarn "Don't enable them unless you know what you're doing."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
- # bug #496780
- epatch "${FILESDIR}"/${PV}-gc74.patch
- cp "${EPREFIX}"/usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
-}
-
-src_configure() {
- econf \
- --with-system-gmp \
- --enable-boehm=system \
- --enable-longdouble \
- --with-dffi \
- $(use_enable gengc) \
- $(use_enable precisegc) \
- $(use_with debug debug-cflags) \
- $(use_with cpu_flags_x86_sse sse) \
- $(use_enable threads) \
- $(use_with threads __thread) \
- $(use_enable unicode) \
- $(use_with X x) \
- $(use_with X clx)
-}
-
-src_compile() {
- if use emacs; then
- local ETAGS=$(eselect --brief etags list | sed -ne '/emacs/{p;q}')
- [[ -n ${ETAGS} ]] || die "No etags implementation found"
- pushd build > /dev/null || die
- emake ETAGS=${ETAGS} TAGS
- popd > /dev/null
- else
- touch build/TAGS
- fi
-
- #parallel make fails
- emake -j1 || die "Compilation failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- dodoc ANNOUNCEMENT Copyright
- dodoc "${FILESDIR}"/README.Gentoo
- pushd build/doc
- newman ecl.man ecl.1
- newman ecl-config.man ecl-config.1
- popd
-}
diff --git a/dev-lisp/ecls/files/13.5.1-gc74.patch b/dev-lisp/ecls/files/13.5.1-gc74.patch
deleted file mode 100644
index a1069b214b4b..000000000000
--- a/dev-lisp/ecls/files/13.5.1-gc74.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff -r -U1 ecl-13.5.1.orig/src/aclocal.m4 ecl-13.5.1/src/aclocal.m4
---- ecl-13.5.1.orig/src/aclocal.m4 2013-05-28 03:37:36.000000000 +0700
-+++ ecl-13.5.1/src/aclocal.m4 2014-01-12 00:34:36.663129950 +0700
-@@ -942,2 +942,6 @@
- fi
-+ if test "${system_boehm}" = "yes"; then
-+ AC_CHECK_LIB( [gc], [GC_set_start_callback],
-+ [AC_DEFINE(HAVE_GC_SET_START_CALLBACK)], [] )
-+ fi
- AC_MSG_CHECKING( [whether we can use the existing Boehm-Weiser library] )
-diff -r -U1 ecl-13.5.1.orig/src/c/alloc_2.d ecl-13.5.1/src/c/alloc_2.d
---- ecl-13.5.1.orig/src/c/alloc_2.d 2013-05-28 03:37:36.000000000 +0700
-+++ ecl-13.5.1/src/c/alloc_2.d 2014-01-12 00:43:44.177106924 +0700
-@@ -33,2 +33,9 @@
-
-+static void (*GC_old_start_callback)(void) = NULL;
-+#ifdef HAVE_GC_START_CALLBACK
-+extern void GC_set_start_callback(void *);
-+extern void *GC_get_start_callback(void *);
-+#else
-+extern void *GC_start_call_back(void);
-+#endif
- static void gather_statistics();
-@@ -752,3 +759,2 @@
- extern void (*GC_push_other_roots)();
--extern void (*GC_start_call_back)();
- static void (*old_GC_push_other_roots)();
-@@ -1092,3 +1098,9 @@
- GC_push_other_roots = stacks_scanner;
-+#ifdef HAVE_GC_SET_START_CALLBACK
-+ GC_old_start_callback = GC_get_start_callback();
-+ GC_set_start_callback(gather_statistics);
-+#else
-+ GC_old_start_callback = GC_start_call_back;
- GC_start_call_back = (void (*)())gather_statistics;
-+#endif
- GC_java_finalization = 1;
-@@ -1200,3 +1212,3 @@
- */
--#if 1 /*GBC_BOEHM == 0*/
-+#if GBC_BOEHM == 0
- extern int GC_print_stats;
-@@ -1279,2 +1291,4 @@
- }
-+ if (GC_old_start_callback)
-+ GC_old_start_callback();
- }
-Только в ecl-13.5.1/src/c: alloc_2.d.orig
-diff -r -U1 ecl-13.5.1.orig/src/h/config.h.in ecl-13.5.1/src/h/config.h.in
---- ecl-13.5.1.orig/src/h/config.h.in 2013-05-28 03:37:36.000000000 +0700
-+++ ecl-13.5.1/src/h/config.h.in 2014-01-12 00:34:36.663129950 +0700
-@@ -310,2 +310,5 @@
-
-+/* GC_set_start_callback */
-+#define HAVE_GC_SET_START_CALLBACK
-+
- /*
diff --git a/dev-lisp/ecls/files/13.5.1-headers-gentoo.patch b/dev-lisp/ecls/files/13.5.1-headers-gentoo.patch
deleted file mode 100644
index 958b948bac41..000000000000
--- a/dev-lisp/ecls/files/13.5.1-headers-gentoo.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -r -U1 ecl-13.5.1.orig/src/h/object.h ecl-13.5.1/src/h/object.h
---- ecl-13.5.1.orig/src/h/object.h 2013-05-28 03:37:36.000000000 +0700
-+++ ecl-13.5.1/src/h/object.h 2013-05-29 19:23:34.000000000 +0700
-@@ -25,4 +25,9 @@
-
-+#ifndef TRUE
- #define TRUE 1 /* boolean true value */
-+#endif
-+
-+#ifndef FALSE
- #define FALSE 0 /* boolean false value */
-+#endif
-