summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 23:37:56 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-29 00:25:10 +0100
commit82f2636f13ae0f8d8e073c89392b88caaa0d9781 (patch)
treedcd90ceeb8c42c61b8215b6b89a9032592e833bb /dev-lua/LuaBitOp
parentdev-lua/LuaBitOp: drop old version (diff)
downloadgentoo-82f2636f13ae0f8d8e073c89392b88caaa0d9781.tar.gz
gentoo-82f2636f13ae0f8d8e073c89392b88caaa0d9781.tar.bz2
gentoo-82f2636f13ae0f8d8e073c89392b88caaa0d9781.zip
dev-lua/LuaBitOp: depend on lua-5.1
Changing RDEPEND to lua-5.1 non slotted, as we will have a new version in future, which will be used for slotted lua. Closes: https://bugs.gentoo.org/739916 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/LuaBitOp')
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.2-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r2.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..67165da21a3c
--- /dev/null
+++ b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="Bit Operations Library for the Lua Programming Language"
+HOMEPAGE="http://bitop.luajit.org"
+SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~hppa ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1.5-r2:0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ multilib_copy_sources
+}
+
+multilib_src_compile()
+{
+ emake CC="$(tc-getCC)" INCLUDES= CCOPT=
+}
+
+multilib_src_test() {
+ # tests use native lua interpreter
+ multilib_is_native_abi && default
+}
+
+multilib_src_install()
+{
+ local instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"
+ exeinto "${instdir#${EPREFIX}}"
+ doexe bit.so
+}
+
+multilib_src_install_all() {
+ dodoc README
+ dohtml -r doc/.
+}