summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-14 18:23:56 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-14 18:57:38 +0100
commitbb6472442703a84040740b6877a56bf7aea6942b (patch)
tree1326dbe69acdcdf21d879116874cdcbf1c74ccae /dev-lua/LuaBitOp
parentdev-libs/libratbag: Removed old (diff)
downloadgentoo-bb6472442703a84040740b6877a56bf7aea6942b.tar.gz
gentoo-bb6472442703a84040740b6877a56bf7aea6942b.tar.bz2
gentoo-bb6472442703a84040740b6877a56bf7aea6942b.zip
dev-lua/LuaBitOp: add luajit (slotted)
Dropping also multilib, as no package, which depends on this package, needs multilib. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/LuaBitOp')
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.2-r102.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r102.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r102.ebuild
new file mode 100644
index 000000000000..2fd5a1f8e262
--- /dev/null
+++ b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r102.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..2} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Bit Operations Library for the Lua Programming Language"
+HOMEPAGE="http://bitop.luajit.org"
+SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( "doc/." )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "CCOPT="
+ "INCLUDES=$(lua_get_CFLAGS)"
+ )
+
+ emake "${myemakeargs[@]}" all
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+
+ local mytests=(
+ "bitbench.lua"
+ "bittest.lua"
+ "md5test.lua"
+ "nsievebits.lua"
+ )
+
+ for mytest in ${mytests[@]}; do
+ LUA_CPATH="./?.so" ${ELUA} ${mytest}
+ done
+
+ popd
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ exeinto $(lua_get_cmod_dir)
+ doexe bit.so
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}