summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-10-11 20:22:21 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-10-11 20:22:35 +0200
commitf2d6b0683ab150dbc6ef3074a599be8b70f99a3b (patch)
treeb3ee6970e4b7b16d880214e3bd22eabde66a2ee9 /dev-lua/LuaBitOp
parentx11-misc/projecteur: bump to version 0.9.2 (diff)
downloadgentoo-f2d6b0683ab150dbc6ef3074a599be8b70f99a3b.tar.gz
gentoo-f2d6b0683ab150dbc6ef3074a599be8b70f99a3b.tar.bz2
gentoo-f2d6b0683ab150dbc6ef3074a599be8b70f99a3b.zip
dev-lua/LuaBitOp: drop old version
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/LuaBitOp')
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.2-r102.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r102.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r102.ebuild
deleted file mode 100644
index 11bcdb422dd5..000000000000
--- a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r102.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..2} luajit )
-
-inherit flag-o-matic lua toolchain-funcs
-
-DESCRIPTION="Bit Operations Library for the Lua Programming Language"
-HOMEPAGE="http://bitop.luajit.org"
-SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~x64-macos"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "doc/." )
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "CCOPT="
- "INCLUDES=$(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}" all
-
- popd
-}
-
-src_compile() {
- if [[ $CHOST == *-darwin* ]] ; then
- append-ldflags "-undefined dynamic_lookup"
- fi
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
-
- local mytests=(
- "bitbench.lua"
- "bittest.lua"
- "md5test.lua"
- "nsievebits.lua"
- )
-
- for mytest in ${mytests[@]}; do
- LUA_CPATH="./?.so" ${ELUA} ${mytest}
- done
-
- popd
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- mycmoddir="$(lua_get_cmod_dir)"
- exeinto "${mycmoddir#$EPREFIX}"
- doexe bit.so
-
- popd
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- local luav=$(lua_get_version)
- # we only want the major version (e.g. 5.1)
- local luamv=${luav:0:3}
- local file="lua/${luamv}/bit.so"
- install_name_tool -id "${EPREFIX}/usr/$(get_libdir)/${file}" "${ED}/usr/$(get_libdir)/${file}" || die "Failed to adjust install_name"
- fi
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}