summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-12-15 22:11:36 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-12-15 22:11:36 +0100
commitc2e3f6ea330492f79bb40b7b1c7a5ed98e522faf (patch)
tree8c68d2a1f39d6d8638ea7c3935a9c68315ff9485 /dev-lua/lua-cjson
parentgames-simulation/openrct2: add 0.4.3 (diff)
downloadgentoo-c2e3f6ea330492f79bb40b7b1c7a5ed98e522faf.tar.gz
gentoo-c2e3f6ea330492f79bb40b7b1c7a5ed98e522faf.tar.bz2
gentoo-c2e3f6ea330492f79bb40b7b1c7a5ed98e522faf.zip
dev-lua/lua-cjson: drop 2.1.0.8-r1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-cjson')
-rw-r--r--dev-lua/lua-cjson/Manifest1
-rw-r--r--dev-lua/lua-cjson/files/lua-cjson-2.1.0.8-lua52.patch143
-rw-r--r--dev-lua/lua-cjson/files/lua-cjson-2.1.0.8-sparse_array_test_fix.patch31
-rw-r--r--dev-lua/lua-cjson/lua-cjson-2.1.0.8-r1.ebuild105
4 files changed, 0 insertions, 280 deletions
diff --git a/dev-lua/lua-cjson/Manifest b/dev-lua/lua-cjson/Manifest
index 03695f44513d..d07c1321b4b4 100644
--- a/dev-lua/lua-cjson/Manifest
+++ b/dev-lua/lua-cjson/Manifest
@@ -1,2 +1 @@
DIST lua-cjson-2.1.0.10.tar.gz 78651 BLAKE2B c215f0a78ba306831a9aa147df9edcb693164a82a0b0505265425124adb40c918da826d128c2dcd048e2c3040d191e177c78b143abb28608b38b3c2b21760539 SHA512 889761b6381b2d10b7aa2e5687e5059705352c0f7fbbca9bc5f7c9d89aed8b1e283c18e217183042cc6f1ec4f19d1c4cf720e3efc6f5a06e81aa1bec8a6b93c4
-DIST lua-cjson-2.1.0.8.tar.gz 77211 BLAKE2B 227171576318939ab48abe26e87fa905cf9a15e6ff44065c0713b6a6fedac571f1dbbb88526b957836a4368e71c4d19a748b2a3250221572f580f1d32ccf50a0 SHA512 577278ccb58a23ea56ea9ad34c5fb0a07c13c6691a3b666f58fa6427bca269aaec26271d7400dcd253c922d1bb0b3b322915a2ce139880c1ed4c1d2c15437580
diff --git a/dev-lua/lua-cjson/files/lua-cjson-2.1.0.8-lua52.patch b/dev-lua/lua-cjson/files/lua-cjson-2.1.0.8-lua52.patch
deleted file mode 100644
index 8f8c98243f1f..000000000000
--- a/dev-lua/lua-cjson/files/lua-cjson-2.1.0.8-lua52.patch
+++ /dev/null
@@ -1,143 +0,0 @@
-From e8dddaf2c9c370f3676441304955d81543c5cceb Mon Sep 17 00:00:00 2001
-From: leaf corcoran <leafot@gmail.com>
-Date: Sat, 21 Sep 2019 17:31:38 -0700
-Subject: [PATCH 1/5] support lua 5.2 with LUA_COMPAT_ALL
-
----
- lua_cjson.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/lua_cjson.c b/lua_cjson.c
-index 2a69699..83118b1 100644
---- a/lua_cjson.c
-+++ b/lua_cjson.c
-@@ -36,6 +36,9 @@
- * difficult to know object/array sizes ahead of time.
- */
-
-+
-+#define LUA_COMPAT_ALL 1
-+
- #include <assert.h>
- #include <stdint.h>
- #include <string.h>
-
-From 2b3c3c866701a0110a6ac50a9bec9f23adc2956e Mon Sep 17 00:00:00 2001
-From: leaf corcoran <leafot@gmail.com>
-Date: Sat, 21 Sep 2019 18:01:05 -0700
-Subject: [PATCH 2/5] support lua 5.3 with LUA_COMPAT_5_1
-
----
- lua_cjson.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/lua_cjson.c b/lua_cjson.c
-index 83118b1..9d25f7c 100644
---- a/lua_cjson.c
-+++ b/lua_cjson.c
-@@ -38,6 +38,7 @@
-
-
- #define LUA_COMPAT_ALL 1
-+#define LUA_COMPAT_5_1 1
-
- #include <assert.h>
- #include <stdint.h>
-
-From 639c4a38bf0b1bddef4bfdb22bb6a3f8493cc3fe Mon Sep 17 00:00:00 2001
-From: leaf corcoran <leafot@gmail.com>
-Date: Sat, 21 Sep 2019 18:18:27 -0700
-Subject: [PATCH 3/5] Lua 5.2+ unpack support
-
----
- lua/cjson/util.lua | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/lua/cjson/util.lua b/lua/cjson/util.lua
-index 5d80106..48fa33c 100644
---- a/lua/cjson/util.lua
-+++ b/lua/cjson/util.lua
-@@ -1,5 +1,7 @@
- local json = require "cjson"
-
-+local unpack = unpack or table.unpack
-+
- -- Various common routines used by the Lua CJSON package
- --
- -- Mark Pulford <mark@kyne.com.au>
-
-From 9163dd3c431bd7ab45bdb218c32c8c9633ddf2cc Mon Sep 17 00:00:00 2001
-From: leaf corcoran <leafot@gmail.com>
-Date: Sat, 21 Sep 2019 18:43:47 -0700
-Subject: [PATCH 4/5] Lua 5.2+ maxn support
-
----
- lua/cjson/util.lua | 12 +++++++++++-
- 1 file changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/lua/cjson/util.lua b/lua/cjson/util.lua
-index 48fa33c..2405257 100644
---- a/lua/cjson/util.lua
-+++ b/lua/cjson/util.lua
-@@ -2,6 +2,16 @@ local json = require "cjson"
-
- local unpack = unpack or table.unpack
-
-+local maxn = table.maxn or function(t)
-+ local max = 0
-+ for k,v in pairs(t) do
-+ if type(k) == "number" and k > max then
-+ max = k
-+ end
-+ end
-+ return max
-+end
-+
- -- Various common routines used by the Lua CJSON package
- --
- -- Mark Pulford <mark@kyne.com.au>
-@@ -194,7 +204,7 @@ local function run_test(testname, func, input, should_work, output)
- local result = {}
- local tmp = { pcall(func, unpack(input)) }
- local success = tmp[1]
-- for i = 2, table.maxn(tmp) do
-+ for i = 2, maxn(tmp) do
- result[i - 1] = tmp[i]
- end
-
-
-From c390998582b959389d0fc039743c96e861902587 Mon Sep 17 00:00:00 2001
-From: leaf corcoran <leafot@gmail.com>
-Date: Sun, 22 Sep 2019 13:43:18 -0700
-Subject: [PATCH 5/5] use macro instead of header defines for Lua 5.2+ support
-
----
- lua_cjson.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/lua_cjson.c b/lua_cjson.c
-index 9d25f7c..718a5b9 100644
---- a/lua_cjson.c
-+++ b/lua_cjson.c
-@@ -36,10 +36,6 @@
- * difficult to know object/array sizes ahead of time.
- */
-
--
--#define LUA_COMPAT_ALL 1
--#define LUA_COMPAT_5_1 1
--
- #include <assert.h>
- #include <stdint.h>
- #include <string.h>
-@@ -105,6 +101,10 @@
- #define json_lightudata_mask(ludata) (ludata)
- #endif
-
-+#if LUA_VERSION_NUM > 501
-+#define lua_objlen(L,i) lua_rawlen(L, (i))
-+#endif
-+
- static const char * const *json_empty_array;
- static const char * const *json_array;
-
diff --git a/dev-lua/lua-cjson/files/lua-cjson-2.1.0.8-sparse_array_test_fix.patch b/dev-lua/lua-cjson/files/lua-cjson-2.1.0.8-sparse_array_test_fix.patch
deleted file mode 100644
index e031672dae33..000000000000
--- a/dev-lua/lua-cjson/files/lua-cjson-2.1.0.8-sparse_array_test_fix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/tests/test.lua
-+++ b/tests/test.lua
-@@ -10,6 +10,17 @@
- local json_safe = require "cjson.safe"
- local util = require "cjson.util"
-
-+local function json_encode_output_type(value)
-+ local text = json.encode(value)
-+ if string.match(text, "{.*}") then
-+ return "object"
-+ elseif string.match(text, "%[.*%]") then
-+ return "array"
-+ else
-+ return "scalar"
-+ end
-+end
-+
- local function gen_raw_octets()
- local chars = {}
- for i = 0, 255 do chars[i + 1] = string.char(i) end
-@@ -292,8 +303,8 @@
- json.encode, { { [1] = "one", [4] = "sparse test" } },
- true, { '["one",null,null,"sparse test"]' } },
- { "Encode sparse array as object",
-- json.encode, { { [1] = "one", [5] = "sparse test" } },
-- true, { '{"5":"sparse test","1":"one"}' } },
-+ json_encode_output_type, { { [1] = "one", [5] = "sparse test" } },
-+ true, { 'object' } },
- { "Encode table with numeric string key as object",
- json.encode, { { ["2"] = "numeric string key test" } },
- true, { '{"2":"numeric string key test"}' } },
diff --git a/dev-lua/lua-cjson/lua-cjson-2.1.0.8-r1.ebuild b/dev-lua/lua-cjson/lua-cjson-2.1.0.8-r1.ebuild
deleted file mode 100644
index 90bef7a81942..000000000000
--- a/dev-lua/lua-cjson/lua-cjson-2.1.0.8-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="A fast JSON encoding/parsing module for Lua"
-HOMEPAGE="https://www.kyne.com.au/~mark/software/lua-cjson.php https://github.com/openresty/lua-cjson"
-SRC_URI="https://github.com/openresty/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+internal-fpconv test +threads"
-REQUIRED_USE="
- threads? ( internal-fpconv )
- ${LUA_REQUIRED_USE}
-"
-RESTRICT="!test? ( test )"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-lang/perl )"
-
-DOCS=( "manual.txt" "NEWS" "performance.txt" "README.md" "THANKS" )
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.1.0.8-sparse_array_test_fix.patch"
- "${FILESDIR}/${PN}-2.1.0.8-lua52.patch"
-)
-
-src_prepare() {
- default
-
- # Don't install tests
- sed -e '/cd tests/d' -i Makefile || die
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "CFLAGS=${CFLAGS}"
- "LDFLAGS=${LDFLAGS}"
- "LUA_INCLUDE_DIR=$(lua_get_include_dir)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- if ! [[ ${ELUA} == "lua5.3" || ${ELUA} == "lua5.4" ]]; then
- pushd "${BUILD_DIR}" || die
- cd tests || die
-
- ln -s "${BUILD_DIR}"/cjson.so ./ || die
- ln -s "${S}"/lua/cjson ./ || die
-
- ./genutf8.pl || die
- ./test.lua || die
-
- popd
- else
- ewarn "Not running tests under ${ELUA} because they are known to fail"
- ewarn "See: https://github.com/openresty/lua-cjson/pull/50"
- return
- fi
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "DESTDIR=${D}"
- "LUA_CMODULE_DIR=$(lua_get_lmod_dir)"
- "LUA_MODULE_DIR=$(lua_get_lmod_dir)"
- "PREFIX=${EPREFIX}/usr"
- )
-
- emake "${myemakeargs[@]}" install install-extra
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}