summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 17:06:09 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 17:16:40 +0100
commit798995d092765da59dbe28edd90561368afcc1bb (patch)
tree86df0ce50b948ebb51b200cd27972a2517b50457 /dev-lua/lua-term
parentdev-lua/lua_cliargs: migrate to lua eclass (diff)
downloadgentoo-798995d092765da59dbe28edd90561368afcc1bb.tar.gz
gentoo-798995d092765da59dbe28edd90561368afcc1bb.tar.bz2
gentoo-798995d092765da59dbe28edd90561368afcc1bb.zip
dev-lua/lua-term: migrate to lua eclass
Closes: https://bugs.gentoo.org/752624 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-term')
-rw-r--r--dev-lua/lua-term/lua-term-0.7-r100.ebuild66
-rw-r--r--dev-lua/lua-term/metadata.xml4
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-lua/lua-term/lua-term-0.7-r100.ebuild b/dev-lua/lua-term/lua-term-0.7-r100.ebuild
new file mode 100644
index 000000000000..5ced1bbb4f1a
--- /dev/null
+++ b/dev-lua/lua-term/lua-term-0.7-r100.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+MY_PV="0.07"
+MY_PV_SO="1.0.1"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Terminal operations for Lua"
+HOMEPAGE="https://github.com/hoelzro/lua-term"
+SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-O3//g' -i Makefile
+}
+
+lua_src_compile() {
+ # Clean project to compile it for every lua slot
+ emake clean
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "CFLAGS=${CFLAGS} ${LDFLAGS} $(lua_get_CFLAGS)"
+ )
+
+ emake "${myemakeargs[@]}" all
+
+ # Copy module to match the choosen LUA implementation
+ cp "core.so.${MY_PV_SO}" "core-${ELUA}.so.${MY_PV_SO}" || die
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ # Use correct module for the choosen LUA implementation
+ cp "core-${ELUA}.so.${MY_PV_SO}" "core.so.${MY_PV_SO}" || die
+
+ local myemakeargs=(
+ LUA_LIBDIR="${ED}/$(lua_get_cmod_dir)/term"
+ LUA_SHARE="${ED}/$(lua_get_lmod_dir)/term"
+ )
+
+ emake "${myemakeargs[@]}" install
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}
diff --git a/dev-lua/lua-term/metadata.xml b/dev-lua/lua-term/metadata.xml
index cd082b51556c..a0fd1bd9d692 100644
--- a/dev-lua/lua-term/metadata.xml
+++ b/dev-lua/lua-term/metadata.xml
@@ -5,6 +5,10 @@
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
<upstream>
<remote-id type="github">hoelzro/lua-term</remote-id>
</upstream>