summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-07-08 10:22:53 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-07-12 13:49:17 -0500
commitebe78fa1faed4ef8dd9926dae19cc22a60b32437 (patch)
tree90f6f4b6e799aa8e1389f887d0d47c706f817906 /dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild
parentdev-python/apsw: remove old (diff)
downloadgentoo-ebe78fa1faed4ef8dd9926dae19cc22a60b32437.tar.gz
gentoo-ebe78fa1faed4ef8dd9926dae19cc22a60b32437.tar.bz2
gentoo-ebe78fa1faed4ef8dd9926dae19cc22a60b32437.zip
dev-lua/lua_cliargs: 3.0_p1 version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild')
-rw-r--r--dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild b/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild
new file mode 100644
index 000000000000..4a4b90430594
--- /dev/null
+++ b/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+# Below is the upstream package version.
+# The final component of the version number has been mapped to the _px
+# component of the version number in portage so should be kept in sync.
+MY_PV="3.0-1"
+
+DESCRIPTION="A command-line argument parser."
+HOMEPAGE="https://github.com/amireh/lua_cliargs"
+SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r src/cliargs.lua src/cliargs
+ dodoc README.md
+ dodoc -r examples
+ docinto html
+ dodoc -r doc/*
+}