summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-14 23:08:49 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-14 23:23:29 +0200
commit4160186131fc18a6497c98762341eb3ab6ec88f5 (patch)
tree99256154fbc635128008c8b6441b2b77c47ab667 /dev-lua/luadbi
parentdev-lua/luaevent: drop old version (diff)
downloadgentoo-4160186131fc18a6497c98762341eb3ab6ec88f5.tar.gz
gentoo-4160186131fc18a6497c98762341eb3ab6ec88f5.tar.bz2
gentoo-4160186131fc18a6497c98762341eb3ab6ec88f5.zip
dev-lua/luadbi: add tests
Uunfortunately, the tests must be restricted, as they need a real database for execution. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luadbi')
-rw-r--r--dev-lua/luadbi/luadbi-0.7.2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lua/luadbi/luadbi-0.7.2.ebuild b/dev-lua/luadbi/luadbi-0.7.2.ebuild
index 63e97642ea17..3c01ee07123f 100644
--- a/dev-lua/luadbi/luadbi-0.7.2.ebuild
+++ b/dev-lua/luadbi/luadbi-0.7.2.ebuild
@@ -12,8 +12,9 @@ SRC_URI="https://github.com/mwild1/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="mysql postgres +sqlite"
+IUSE="mysql postgres +sqlite test"
REQUIRED_USE="|| ( mysql postgres sqlite )"
+RESTRICT="test"
RDEPEND="
>=dev-lang/lua-5.1:=
@@ -47,6 +48,10 @@ src_compile() {
use sqlite emake ${myemakeargs} SQLITE3_INC="-I/usr/include" sqlite
}
+src_test() {
+ cd "${S}"/tests && lua run_tests.lua || die
+}
+
src_install() {
local myemakeargs=(
DESTDIR="${ED}"