summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-14 23:21:31 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-14 23:23:31 +0200
commitae4cdb501d80da917dece46e914a2806519a3cd7 (patch)
tree641952bcc7fad1c609090ae7fa814b5b45d8a174 /dev-lua/luadbi
parentprofiles/package.mask: add slotted lua ebuild (diff)
downloadgentoo-ae4cdb501d80da917dece46e914a2806519a3cd7.tar.gz
gentoo-ae4cdb501d80da917dece46e914a2806519a3cd7.tar.bz2
gentoo-ae4cdb501d80da917dece46e914a2806519a3cd7.zip
dev-lua/luadbi: add support for slotted lua
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luadbi')
-rw-r--r--dev-lua/luadbi/luadbi-0.7.2-r100.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/dev-lua/luadbi/luadbi-0.7.2-r100.ebuild b/dev-lua/luadbi/luadbi-0.7.2-r100.ebuild
new file mode 100644
index 000000000000..f7f3c1fdcab6
--- /dev/null
+++ b/dev-lua/luadbi/luadbi-0.7.2-r100.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A database interface library for Lua"
+HOMEPAGE="https://github.com/mwild1/luadbi"
+SRC_URI="https://github.com/mwild1/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="mysql postgres +sqlite test"
+REQUIRED_USE="
+ ${LUA_REQUIRED_USE}
+ || ( mysql postgres sqlite )
+"
+RESTRICT="test"
+
+RDEPEND="
+ ${LUA_DEPS}
+ mysql? ( dev-db/mysql-connector-c:0= )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-lua/busted
+ dev-lua/luarocks
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.7.2-mysql-8.patch" )
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-g //' -e 's/-O2 //g' -i Makefile || die
+}
+
+lua_src_compile() {
+ tc-export AR CC
+
+ local myemakeargs=(
+ "LUA_INC=$(lua_get_CFLAGS)"
+ )
+
+ use mysql && emake ${myemakeargs} MYSQL_INC="-I$(mariadb_config --libs)" mysql
+ use postgres && emake ${myemakeargs} PSQL_INC="-I$(pg_config --libdir)" psql
+ use sqlite emake ${myemakeargs} SQLITE3_INC="-I/usr/include" sqlite
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ cd "${S}"/tests && ${ELUA} run_tests.lua || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ local myemakeargs=(
+ DESTDIR="${ED}"
+ LUA_CDIR="$(lua_get_cmod_dir)"
+ LUA_LDIR="$(lua_get_lmod_dir)"
+ )
+
+ use mysql && emake ${myemakeargs[@]} install_mysql
+ use postgres && emake ${myemakeargs[@]} install_psql
+ use sqlite && emake ${myemakeargs[@]} install_sqlite3
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}