summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-23 20:44:39 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-23 20:53:35 +0100
commit6cbbbd10a9a5a5ed5b8f801b04d3bfd08a59407d (patch)
treeeb6a64b2fa78b57d4930b5d2e006fd5c664de031 /dev-lua/luaexpat
parentdev-scheme/guile-json: bump up to 4.4.0 (diff)
downloadgentoo-6cbbbd10a9a5a5ed5b8f801b04d3bfd08a59407d.tar.gz
gentoo-6cbbbd10a9a5a5ed5b8f801b04d3bfd08a59407d.tar.bz2
gentoo-6cbbbd10a9a5a5ed5b8f801b04d3bfd08a59407d.zip
dev-lua/luaexpat: migrate to lua eclass
Closes: https://bugs.gentoo.org/752642 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luaexpat')
-rw-r--r--dev-lua/luaexpat/luaexpat-1.3.0-r100.ebuild78
-rw-r--r--dev-lua/luaexpat/luaexpat-1.3.3-r100.ebuild82
2 files changed, 160 insertions, 0 deletions
diff --git a/dev-lua/luaexpat/luaexpat-1.3.0-r100.ebuild b/dev-lua/luaexpat/luaexpat-1.3.0-r100.ebuild
new file mode 100644
index 000000000000..28ce6e137095
--- /dev/null
+++ b/dev-lua/luaexpat/luaexpat-1.3.0-r100.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} )
+LUA_REQ_USE="${MULTILIB_USEDEP}"
+
+inherit lua multilib-minimal toolchain-funcs
+
+DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library"
+HOMEPAGE="https://matthewwild.co.uk/projects/luaexpat/"
+SRC_URI="https://matthewwild.co.uk/projects/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ ${LUA_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( "doc/us/." )
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ # Add '-DLUA_32BITS' for fixing compilation with lua5.3
+ sed -e 's/-O2/-DLUA_32BITS/g' -i Makefile || die
+
+ multilib_copy_sources
+}
+
+lua_multilib_src_compile() {
+ # Clean project, to compile it for every lua slot
+ emake clean
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LUA_INC=$(lua_get_CFLAGS)"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ # Copy module to match the choosen LUA implementation
+ cp "src/lxp.so" "src/lxp-${ELUA}.so" || die
+}
+
+multilib_src_compile() {
+ lua_foreach_impl lua_multilib_src_compile
+}
+
+lua_multilib_src_install() {
+ # Use correct module for the choosen LUA implementation
+ cp "src/lxp-${ELUA}.so" "src/lxp.so" || die
+
+ local myemakeargs=(
+ "DESTDIR=${ED}"
+ "LUA_CDIR=$(lua_get_cmod_dir)"
+ "LUA_INC=$(lua_get_include_dir)"
+ "LUA_LDIR=$(lua_get_lmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+}
+
+multilib_src_install() {
+ lua_foreach_impl lua_multilib_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+}
diff --git a/dev-lua/luaexpat/luaexpat-1.3.3-r100.ebuild b/dev-lua/luaexpat/luaexpat-1.3.3-r100.ebuild
new file mode 100644
index 000000000000..7674c7cd76ab
--- /dev/null
+++ b/dev-lua/luaexpat/luaexpat-1.3.3-r100.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} )
+LUA_REQ_USE="${MULTILIB_USEDEP}"
+
+inherit lua multilib-minimal toolchain-funcs
+
+DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library"
+HOMEPAGE="https://github.com/tomasguisasola/luaexpat"
+SRC_URI="https://github.com/tomasguisasola/luaexpat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ ${LUA_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( "doc/us/." )
+
+PATCHES=(
+ "${FILESDIR}/${P}_makefile.patch"
+ "${FILESDIR}/${P}_getcurrentbytecount.patch"
+ "${FILESDIR}/${P}_restore_functionality.patch"
+)
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-O2//g' -i makefile || die
+
+ multilib_copy_sources
+}
+
+lua_multilib_src_compile() {
+ # Clean project, to compile it for every lua slot
+ emake clean
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LUA_INC=$(lua_get_include_dir)"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ # Copy module to match the choosen LUA implementation
+ cp "src/lxp.so.${PV}" "src/lxp-${ELUA}.so.${PV}" || die
+}
+
+multilib_src_compile() {
+ lua_foreach_impl lua_multilib_src_compile
+}
+
+lua_multilib_src_install() {
+ # Use correct module for the choosen LUA implementation
+ cp "src/lxp-${ELUA}.so.${PV}" "src/lxp.so.${PV}" || die
+
+ local myemakeargs=(
+ "LUA_DIR=${ED}/$(lua_get_lmod_dir)"
+ "LUA_INC=${ED}/$(lua_get_include_dir)"
+ "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+}
+
+multilib_src_install() {
+ lua_foreach_impl lua_multilib_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+}