summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:32:18 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:48 +0100
commitbe1cf47e657c9d20cfb3af9f80985c7226f97fda (patch)
treeab4af3f3f3fd26723c45b299dee920391be08269 /dev-lua/lualdap
parentdev-lua/luafilesystem: drop 1.8.0-r101 (diff)
downloadgentoo-be1cf47e657c9d20cfb3af9f80985c7226f97fda.tar.gz
gentoo-be1cf47e657c9d20cfb3af9f80985c7226f97fda.tar.bz2
gentoo-be1cf47e657c9d20cfb3af9f80985c7226f97fda.zip
dev-lua/lualdap: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lualdap')
-rw-r--r--dev-lua/lualdap/lualdap-1.3.0-r1.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/dev-lua/lualdap/lualdap-1.3.0-r1.ebuild b/dev-lua/lualdap/lualdap-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..bd4441e84ce8
--- /dev/null
+++ b/dev-lua/lualdap/lualdap-1.3.0-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A lua binding for the OpenLDAP client libraries"
+HOMEPAGE="https://github.com/lualdap/lualdap"
+SRC_URI="https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="
+ net-nds/openldap
+ ${LUA_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LBER_LIBDIR=/usr/$(get_libdir)"
+ "LDAP_LIBDIR=/usr/$(get_libdir)"
+ "LUA_INCDIR=$(lua_get_include_dir)"
+ "LUA_LIBDIR=/usr/$(get_libdir)"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+ LUA_CPATH="./src/?.so" ${ELUA} tests/test.lua
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ # Workaround, as 'make install' does not create this directory
+ dodir "$(lua_get_cmod_dir)"
+
+ local myemakeargs=(
+ "DESTDIR=${ED}"
+ "INST_LIBDIR=$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}