summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcrito <crito@fnordpipe.org>2018-09-26 21:56:38 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-28 12:07:53 +0200
commitdddbeb5e4139102deda075fcef14170ec100ae27 (patch)
tree2146cd089c1f49e8377ac3b17bf1f0770dccb942 /dev-lua/luaossl/luaossl-20180708.ebuild
parentapp-benchmarks/stress-ng: drop old version (diff)
downloadgentoo-dddbeb5e4139102deda075fcef14170ec100ae27.tar.gz
gentoo-dddbeb5e4139102deda075fcef14170ec100ae27.tar.bz2
gentoo-dddbeb5e4139102deda075fcef14170ec100ae27.zip
dev-lua/luaossl: bump version to 20180708
Signed-off-by: Matthias Hauber <crito@fnordpipe.org> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9977
Diffstat (limited to 'dev-lua/luaossl/luaossl-20180708.ebuild')
-rw-r--r--dev-lua/luaossl/luaossl-20180708.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lua/luaossl/luaossl-20180708.ebuild b/dev-lua/luaossl/luaossl-20180708.ebuild
new file mode 100644
index 000000000000..fd7565276080
--- /dev/null
+++ b/dev-lua/luaossl/luaossl-20180708.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=${PN}-rel-${PV}
+DESCRIPTION="Most comprehensive OpenSSL module in the Lua universe."
+HOMEPAGE="https://github.com/wahern/luaossl"
+SRC_URI="https://github.com/wahern/luaossl/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="luajit"
+
+RDEPEND="
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( >=dev-lang/lua-5.1:0 )
+ dev-libs/openssl:0[-bindist]
+ !dev-lua/lua-openssl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ LUA_VERSION="$($(tc-getPKG_CONFIG) --variable=$(usex luajit abiver V) $(usex luajit luajit lua))"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" openssl${LUA_VERSION}
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install${LUA_VERSION}
+}