summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-03-02 15:42:00 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-03-02 15:42:08 +0100
commit96c2ad7a91b8d0d03224d413f22af75e496ed137 (patch)
tree68afaff5ecb9b2462874df55c8a25ef8a1e6b077 /dev-lua/luasec/luasec-0.5.1.ebuild
parentapp-crypt/mit-krb5: amd64 stable wrt bug #574604 (diff)
downloadgentoo-96c2ad7a91b8d0d03224d413f22af75e496ed137.tar.gz
gentoo-96c2ad7a91b8d0d03224d413f22af75e496ed137.tar.bz2
gentoo-96c2ad7a91b8d0d03224d413f22af75e496ed137.zip
dev-lua/luasec: bump to 0.5.1 for libressl
Diffstat (limited to 'dev-lua/luasec/luasec-0.5.1.ebuild')
-rw-r--r--dev-lua/luasec/luasec-0.5.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lua/luasec/luasec-0.5.1.ebuild b/dev-lua/luasec/luasec-0.5.1.ebuild
new file mode 100644
index 000000000000..d456bb528350
--- /dev/null
+++ b/dev-lua/luasec/luasec-0.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication"
+HOMEPAGE="https://github.com/brunoos/luasec http://www.inf.puc-rio.br/~brunoos/luasec/"
+SRC_URI="https://github.com/brunoos/luasec/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="libressl"
+
+RDEPEND="
+ >=dev-lang/lua-5.1:0[deprecated]
+ dev-lua/luasocket
+ !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ sed -i -e "s#^LUAPATH.*#LUAPATH=$(pkg-config --variable INSTALL_LMOD lua)#"\
+ -e "s#^LUACPATH.*#LUACPATH=$(pkg-config --variable INSTALL_CMOD lua)#" Makefile || die
+ sed -i -e "s/-O2//" src/Makefile || die
+ lua src/options.lua -g /usr/include/openssl/ssl.h > src/options.h || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ linux
+}