summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-14 22:41:36 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-14 22:41:36 +0200
commit882f5c5578c2491a2d1b5619cbf05a2f498aa03e (patch)
tree0539c3c134decf9cb44493f1b43a7d97627d1d69 /dev-lua/luasec
parentapp-benchmarks/stress-ng: drop 0.13.12 (diff)
downloadgentoo-882f5c5578c2491a2d1b5619cbf05a2f498aa03e.tar.gz
gentoo-882f5c5578c2491a2d1b5619cbf05a2f498aa03e.tar.bz2
gentoo-882f5c5578c2491a2d1b5619cbf05a2f498aa03e.zip
dev-lua/luasec: add 1.1.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luasec')
-rw-r--r--dev-lua/luasec/Manifest1
-rw-r--r--dev-lua/luasec/luasec-1.1.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-lua/luasec/Manifest b/dev-lua/luasec/Manifest
index 58e6b86aab21..448c866a4199 100644
--- a/dev-lua/luasec/Manifest
+++ b/dev-lua/luasec/Manifest
@@ -1 +1,2 @@
DIST luasec-1.0.2.tar.gz 52838 BLAKE2B 41bfaf8af6be56bb46c747b2bf3e938a164f43d2f39cde7386d5795811a555ebad3146344ef491412489de7679f82948bb9fb862e3ae98ab9b73f4116218a5ac SHA512 a873d8217b1ec9e66f50d7319ea0fa467b92b5855e7514dbd00429a26be3546e69fdfc985ac79a80d86f3c6845910b2e14a2198951dcad249b2d1c7d6855453f
+DIST luasec-1.1.0.tar.gz 53060 BLAKE2B c89e8feea3cb66108ed72c81e1525397bd3c58a25372661b49cbc7bb0fa1f4ab81e39b6065d99fc3e376333f36f9290b136c31e654a30248a6a1d30beaa5d5b2 SHA512 ce08be2c62e97ebfab30e867790874030d404d195ce336b149d9501d652e9b8efe201cc2d0bcbb3be16214d7e4763b5871e45cbc22db758724baab9f7cd78568
diff --git a/dev-lua/luasec/luasec-1.1.0.ebuild b/dev-lua/luasec/luasec-1.1.0.ebuild
new file mode 100644
index 000000000000..3e6906534f17
--- /dev/null
+++ b/dev-lua/luasec/luasec-1.1.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication"
+HOMEPAGE="https://github.com/brunoos/luasec"
+SRC_URI="https://github.com/brunoos/luasec/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-lua/luasocket-3.0_rc1_p20200328-r103[${LUA_USEDEP}]
+ dev-libs/openssl:0=
+ ${LUA_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_prepare() {
+ pushd "${BUILD_DIR}" || die
+
+ ${ELUA} src/options.lua -g /usr/include/openssl/ssl.h > src/options.c || die
+
+ popd
+}
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-O2//g' -i src/Makefile || die
+
+ # Allow to redefine libraries linking
+ sed -e 's/LIBS=/LIBS?=/g' -i src/Makefile || die
+
+ lua_copy_sources
+
+ lua_foreach_impl lua_src_prepare
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "CCLD=$(tc-getCC)"
+ "INC_PATH=-I$(lua_get_include_dir)"
+ "LIB_PATH=-L$(lua_get_cmod_dir)/socket"
+ "LIBS=$($(tc-getPKG_CONFIG) --libs openssl) $(lua_get_cmod_dir)/socket/core.so"
+ "MYLDFLAGS=-Wl,-rpath,$(lua_get_cmod_dir)/socket -Wl,-soname=socket/core.so"
+ "EXTRA="
+ "DEFS="
+ )
+
+ emake "${myemakeargs[@]}" linux
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ local emakeargs=(
+ "DESTDIR=${ED}"
+ "LUAPATH=$(lua_get_lmod_dir)"
+ "LUACPATH=$(lua_get_cmod_dir)"
+ )
+
+ emake "${emakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}