summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 18:25:54 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 18:44:44 +0100
commit8e873539c4713725db3c27eb3d2b7bb73d98a53d (patch)
treee335b60164788686e0f2221e95d9bcdaff9bd63c /dev-lua/mediator_lua
parentdev-lua/luasystem: drop old version (diff)
downloadgentoo-8e873539c4713725db3c27eb3d2b7bb73d98a53d.tar.gz
gentoo-8e873539c4713725db3c27eb3d2b7bb73d98a53d.tar.bz2
gentoo-8e873539c4713725db3c27eb3d2b7bb73d98a53d.zip
dev-lua/mediator_lua: fix lua deps
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/mediator_lua')
-rw-r--r--dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r101.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r101.ebuild b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r101.ebuild
new file mode 100644
index 000000000000..0d1a8c7f594f
--- /dev/null
+++ b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r101.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Mediator pattern implementation for pub-sub management "
+HOMEPAGE="http://olivinelabs.com/mediator_lua/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ >=dev-lua/busted-2.0.0-r100[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins src/mediator.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}