summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-08-23 11:06:07 -0700
committerMichał Górny <mgorny@gentoo.org>2017-09-02 10:45:21 +0200
commit906bc295a93e283bd2888ebd558bb5c665e95665 (patch)
tree482134807b9003df45ad5c3cccbd073ffd83ad4f /dev-lua/say/say-1.3_p1-r1.ebuild
parentnet-irc/atheme-services: New package. (diff)
downloadgentoo-906bc295a93e283bd2888ebd558bb5c665e95665.tar.gz
gentoo-906bc295a93e283bd2888ebd558bb5c665e95665.tar.bz2
gentoo-906bc295a93e283bd2888ebd558bb5c665e95665.zip
dev-lua/say: add luajit support
Bump to EAPI 6 Add Test phase. Gentoo-Bug: https://bugs.gentoo.org/628758
Diffstat (limited to 'dev-lua/say/say-1.3_p1-r1.ebuild')
-rw-r--r--dev-lua/say/say-1.3_p1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lua/say/say-1.3_p1-r1.ebuild b/dev-lua/say/say-1.3_p1-r1.ebuild
new file mode 100644
index 000000000000..e5c2c5512d0e
--- /dev/null
+++ b/dev-lua/say/say-1.3_p1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+MY_PV=1.3-1
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua String Hashing/Indexing Library"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="luajit test"
+
+RDEPEND="
+ !luajit? ( >=dev-lang/lua-5.1:= )
+ luajit? ( dev-lang/luajit:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-lua/busted )"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_test() {
+ busted -o gtest || die
+}
+
+src_install() {
+ local instdir
+ instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"/${PN}
+ insinto "${instdir#${EPREFIX}}"
+ doins src/init.lua
+ einstalldocs
+}