summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 18:30:26 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 18:44:48 +0100
commitf7e0d26b11000d734017cdb62d76db99fc5e7740 (patch)
treea4bdcdf2078b0303d1a84690a2862a3895bc7ffb /dev-lua/say
parentdev-lua/penlight: drop old version (diff)
downloadgentoo-f7e0d26b11000d734017cdb62d76db99fc5e7740.tar.gz
gentoo-f7e0d26b11000d734017cdb62d76db99fc5e7740.tar.bz2
gentoo-f7e0d26b11000d734017cdb62d76db99fc5e7740.zip
dev-lua/say: fix lua deps
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/say')
-rw-r--r--dev-lua/say/say-1.3_p1-r101.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lua/say/say-1.3_p1-r101.ebuild b/dev-lua/say/say-1.3_p1-r101.ebuild
new file mode 100644
index 000000000000..cef73fc92c85
--- /dev/null
+++ b/dev-lua/say/say-1.3_p1-r101.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lua String Hashing/Indexing Library"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( >=dev-lua/busted-2.0.0-r100[${LUA_USEDEP}] )
+ ${RDEPEND}
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)/say
+ doins src/init.lua
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}