summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-23 21:49:32 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-23 21:49:32 -0500
commit14189728e2a351eea65558288b2782398335b1d0 (patch)
tree38f0557c8f145b88431821ecf120d02e581e6681 /dev-lua
parentapp-cdr/dvdisaster: drop old EAPI (diff)
downloadgentoo-14189728e2a351eea65558288b2782398335b1d0.tar.gz
gentoo-14189728e2a351eea65558288b2782398335b1d0.tar.bz2
gentoo-14189728e2a351eea65558288b2782398335b1d0.zip
dev-lua/luarocks: drop old EAPI
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luarocks/Manifest3
-rw-r--r--dev-lua/luarocks/luarocks-2.0.12.ebuild52
-rw-r--r--dev-lua/luarocks/luarocks-2.0.7.1.ebuild51
-rw-r--r--dev-lua/luarocks/luarocks-2.0.8.ebuild52
4 files changed, 0 insertions, 158 deletions
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
index a54a145fe64b..185deea0ade1 100644
--- a/dev-lua/luarocks/Manifest
+++ b/dev-lua/luarocks/Manifest
@@ -1,4 +1 @@
-DIST luarocks-2.0.12.tar.gz 89028 BLAKE2B 66d06696483f6550421acb8e6834b082f06c5bc0088f730b0316db72725ce5c5ebaf0956a7c84f18b03beafaa6e7c558387025ba9ac701c8b8f7f64fa5557e11 SHA512 5ece403d7bc7804ff47ec8d0ecdea7687d530d10ddf0a800c4a2a68b69a263e68f40ab7e55e39a59ab05315d3e2bc9cf76a0618803dc8e12c7e52941b4a7053f
-DIST luarocks-2.0.7.1.tar.gz 81757 BLAKE2B 2b279fd1302e56eaaa5e5b32f4be37cb1fe21ed5b495aae4014903a5f5e87f198e05f8c2a59fba900ff15f26ec76587b5b8114f6bdf3cdf81d5e59795ffbf792 SHA512 00f37c2baed83bbc7182a4595973bbe5c252fd7f530ebc35ba254fab727c1e6a7f743bafc25bfbde945e40d531f0e764c1f785edddef62fc6219e318bffdc6f3
-DIST luarocks-2.0.8.tar.gz 82313 BLAKE2B e27071c1ef6cf9b4182d8100d76c93e86c606b4ccc62be8e883cdfe7e39de900bef100f1e1a9274cfcae58218768b58a1d1189a0a15696091909b77a83a9ed5f SHA512 8246b3a863197bc5bd9efad343f8f5ba22d7a34904fd3afe99f916631ee30930ec91d15298e67abf22f0bcc6cda02785a5bbc9e60b424a631162e20941d20523
DIST luarocks-2.2.0.tar.gz 111549 BLAKE2B 214c1c03e03f95ca1acfc1fda863895c91c508221c615fe3ccc064e9adbcaa8549d24ff788141c0093259ca52578fadccfb3f6891209f86336c57937ac5ec32d SHA512 41f32e383263485758e64df661ecfbd744369035362755c64466f2c52a8740ed941b80cab3212222d7d24e4b1a7ed9ccb84fa66c8e458526056af0b06d97224f
diff --git a/dev-lua/luarocks/luarocks-2.0.12.ebuild b/dev-lua/luarocks/luarocks-2.0.12.ebuild
deleted file mode 100644
index d1b114274466..000000000000
--- a/dev-lua/luarocks/luarocks-2.0.12.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils multilib
-
-DESCRIPTION="A deployment and management system for Lua modules"
-HOMEPAGE="http://www.luarocks.org"
-SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="curl openssl"
-
-DEPEND="dev-lang/lua
- curl? ( net-misc/curl )
- openssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}
- app-arch/unzip"
-
-src_configure() {
- USE_MD5="md5sum"
- USE_FETCH="wget"
- use openssl && USE_MD5="openssl"
- use curl && USE_FETCH="curl"
-
- # econf doesn't work b/c it passes variables the custom configure can't
- # handle
- ./configure \
- --prefix=/usr \
- --with-lua-lib=/usr/$(get_libdir) \
- --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
- --with-downloader=$USE_FETCH \
- --with-md5-checker=$USE_MD5 \
- || die "configure failed"
-}
-
-src_compile() {
- # -j1 b/c make tries to delete files it has yet to create (bug #402005)
- emake DESTDIR="${D}" -j1 || die "make failed"
-}
-
-src_install() {
- # -j1 b/c otherwise it fails to find src/bin/luarocks
- emake DESTDIR="${D}" -j1 install || die "einstall"
-}
-
-pkg_preinst() {
- find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
-}
diff --git a/dev-lua/luarocks/luarocks-2.0.7.1.ebuild b/dev-lua/luarocks/luarocks-2.0.7.1.ebuild
deleted file mode 100644
index 85009d19c02c..000000000000
--- a/dev-lua/luarocks/luarocks-2.0.7.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils multilib
-
-DESCRIPTION="A deployment and management system for Lua modules"
-HOMEPAGE="http://www.luarocks.org"
-SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="curl openssl"
-
-DEPEND="dev-lang/lua
- curl? ( net-misc/curl )
- openssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}
- app-arch/unzip"
-
-src_configure() {
- USE_MD5="md5sum"
- USE_FETCH="wget"
- use openssl && USE_MD5="openssl"
- use curl && USE_FETCH="curl"
-
- # econf doesn't work b/c it passes variables the custom configure can't
- # handle
- ./configure \
- --prefix=/usr \
- --with-lua-lib=/usr/$(get_libdir) \
- --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
- --with-downloader=$USE_FETCH \
- --with-md5-checker=$USE_MD5 \
- --force-config || die "configure failed"
-}
-
-src_compile() {
- emake DESTDIR="${D}" || die "make failed"
-}
-
-src_install() {
- # -j1 b/c otherwise it fails with to find src/bin/luarocks
- emake DESTDIR="${D}" -j1 install || die "einstall"
-}
-
-pkg_preinst() {
- find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
-}
diff --git a/dev-lua/luarocks/luarocks-2.0.8.ebuild b/dev-lua/luarocks/luarocks-2.0.8.ebuild
deleted file mode 100644
index a4e71ae1e79b..000000000000
--- a/dev-lua/luarocks/luarocks-2.0.8.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils multilib
-
-DESCRIPTION="A deployment and management system for Lua modules"
-HOMEPAGE="http://www.luarocks.org"
-SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="curl openssl"
-
-DEPEND="dev-lang/lua
- curl? ( net-misc/curl )
- openssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}
- app-arch/unzip"
-
-src_configure() {
- USE_MD5="md5sum"
- USE_FETCH="wget"
- use openssl && USE_MD5="openssl"
- use curl && USE_FETCH="curl"
-
- # econf doesn't work b/c it passes variables the custom configure can't
- # handle
- ./configure \
- --prefix=/usr \
- --with-lua-lib=/usr/$(get_libdir) \
- --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
- --with-downloader=$USE_FETCH \
- --with-md5-checker=$USE_MD5 \
- --force-config || die "configure failed"
-}
-
-src_compile() {
- # -j1 b/c make tries to delete files it has yet to create (bug #402005)
- emake DESTDIR="${D}" -j1 || die "make failed"
-}
-
-src_install() {
- # -j1 b/c otherwise it fails to find src/bin/luarocks
- emake DESTDIR="${D}" -j1 install || die "einstall"
-}
-
-pkg_preinst() {
- find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
-}